Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thhunderbird filter not working.

  • 2 replies
  • 1 has this problem
  • 7 views
  • Last reply by quakerdave

more options

I often receive spoof messages saying that my account has been hacked and which demand bitcoin payments. The subject line is "Message need your participation in processing :You have an outstanding payment." These are "hacked" to appear to come from my own email address so they do not get trapped by ordinary spam engines. I set up a filter for the subject line using all of this subject line to be deleted but that didn't work. I tried it for the subject line simply beginning with "Message" and that didn't work either. Has the rest of the header been hacked in a way that means Thunderbird isn't picking up the expected information and thus not actually working on the alledged subject line. I notice that the bit of the subject line from the ":" onwards isn't actually showing in the header that appears in the email when it is in the "inbox". Curious

Thanks for any help!

All Replies (2)

more options

Open the Message Source (Ctrl+U) and examine the headers. A filter rule can be tested by entering the same criteria in Classic Search Ctrl+Shift+F. Custom headers such as Reply-to can be added to filters (and search).

Helpful?

more options

Thanks for the reply. Unfortunately, this doesn't work but I have now found what the problem is. The main body of the header is:

From: (my email address is here) To: (my email address is here) Subject: Message need your participation in processing :You have an outstanding payment. Date: 17 Oct 2021 18:12:57 -0600 MIME-Version: 1.0 Content-Type: text/plain; charset="windows-1250" Content-Transfer-Encoding: 7bit X-Priority: 3 X-MSMail-Priority: Normal X-Mailer: Microsoft Outlook Express 6.00.2900.5931 X-MimeOLE: Produced By Microsoft MimeOLE X-Spam-Status: No, score=-67.0 X-Spam-Score: -669 X-Spam-Bar: --------------------------------------------------- X-Spam-Flag: NO

I entered this line exactly as it says from the header but the filter using that insertion doesn't work. NB Despite what the header says, the subject line appearing for the email in the inbox only shows the section AFTER the : I think the ":" in the header stops Thunderbird displaying the text BEFORE that point. If I Set a filter for subject line component AFTER the : this DOES work. To sum up - the ":" in the header stops Thunderbird processing the subject line or filtering it properly. This therefore seems to me a bug worthy of addressing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.