Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox/Options/Privacy/Permissions/Camera/Settings

  • 3 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

Hi. Been having nothing but huge hassles trying to get Firefox to do anything with letting the website access my webcam. I've already read a bunch of articles on this but still no luck getting it to work. I keep putting in the url of the website, pressing enter, but firebox will never show the website in the box below it like your help section said would happen. I have used both the actual url from the website page which is asking me to connect my cam, and I have also shortened that web address to just the website's main address, but still nothing happens when I out that address into the camera setting's search box and then press enter ( I attached 2 screen capture images if that). I have even doubled checked the web address and copy n pasted it into the camera settings search box, pressed enter, but still nothing shows in the box down below it. I have Windows 8.1 Pro 64 bit in case that matters

Attached screenshots

All Replies (3)

more options

Permissions work by origin (protocol and hostname) and not by a full website link that includes path information.

You can also use "Tools -> Page Info -> Permissions" to set permission for camera and microphone.

Helpful?

more options

Sorry if I misunderstood something but I actually said in my message and shown in one of the pictures I uploaded, that I didn't just try using the "full website link that includes path information." but also tried using just the main website name up until it ended with .com, and so I did not put anything else after the website's name and .com

Helpful?

more options

You can't add website permisions via the settings dialog in "Options/Preferences -> Privacy & Security" like you show in your screenshot (there is only a search bar). You can only edit and remove existing permissions. If Firefox doesn't show the doorhanger asking for permission then you need to use "Tools -> Page Info -> Permissions" to add this permission yourself like I posted above.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.