Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

quotation marks added to email address when sending.

  • 6 replies
  • 2 have this problem
  • Last reply by TOYVAN

more options

I am using Xero accounting software and they have given us an email address to send bills to (so they appear in Xero).

The email address is: bills.!51!2r.ctftoyq2dkioxxto@xerofiles.com (nb. I have changed some alpha characters only to maintain security)

Thunderbird adds quotation marks to the first part of the email address when sending the email, so in the sent folder it appears as "bills.!51!2r.ctftoyq2dkioxxto"@xerofiles.com. It looks like the email is sent but it is never received by Xero.

There are no spaces before or after the email address. I have tried copying & pasting and typing it out manually etc. Nothing works.

It appears to be the "!" in the email address that is causing issue. If I delete the two "!" from the email address it appears in the sent box as bills.512r.ctftoyq2dkioxxto@xerofiles.com not as "bills.512r.ctftoyq2dkioxxto"@xerofiles.com.

Xero won't give me an email address without the "!".

Any fixes for this?

All Replies (6)

more options

Is there any way to lodge a bug or query directly with Mozilla as this support community doesn't look like it is much help. cheers

Helpful?

more options

It's a pain when people aka xero use a bang email address. I've been searching to see if this was previously mentioned as a bug and located the following. https://bugzilla.mozilla.org/show_bug.cgi?id=1213748

Helpful?

more options

I have a 'similar' problem. I have one email address that has an " added to it. It then becomes un-deliverable. I then found it in my address. (the correct address alongside) deleted the " address. BUT the TO box can still find this 'bad' address with" so If I don't watch it I can send to " again. Where/how is TB concocting this bad address from? I have checked ALL address books. There is no ! in the address but there is numbers(64). Any clues please or can this problem be posted to the rest of the community? ALAN

Helpful?

more options

re :BUT the TO box can still find this 'bad' address with"

The autocomplete can only display an email address/contact which exists in one or more of your address books and that also includes 'Collected Addresses'.

Numbers would not cause the issue. But if there is a space before the @ symbol then it would fail. Open Address Book, select 'All Address Books' Make sure the 'Address Book' column header is enabled and visible.

I'm not sure whether you have the bad email address for a particular contacts Name, so let's start with that - Sort by 'Name' to see if that contact comes up with more than one entry in more than one address book. It is possible, that contact could be entered more than once. For example: John Doe, or John or no name is entered but an email address is entered in the Name column.

So remember, you will not see that email address with " in it. You are looking for that email address which will at first glance look ok, but it is likely to have a space in the email address and it should not. eg: johndoe @email.com

Modified by Toad-Hall

Helpful?

more options

Toad-Hall Wonderful reply, many thanks I understood easily. Searched the address books for John-and his surname-nothing. Then I realised that the " was also right at the front of the address entry, so the address book had put it at the top of the 'a's' and in-fact I had half a dozen 'dodgy' addresses with this " at the front and all at the top of my address book and also inserted within the address-so it failed-all deleted now. I can't be sure where they came from but 6 months ago I had a PC change and transferred the address books- as it happens I did it twice so a had a lot of double entries which I have been steadily deleting. A good hit Sir. many Thanks.

Helpful?

more options

Another quick question. With a Mail group address list is there any way of marking the list such that it is BCC every time you use it (without you having to make this decision at the time of sending)?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.