Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ad Blacker Plus and Ad Blocker Ultimate but neither work!

  • 1 reply
  • 1 has this problem
  • 4 views
  • Last reply by jscher2000

more options

I have tried repeatedly to add an Ad Blocker to Firefox (as I have in the past) but they do not work. I have looked for them after downloading but cannot find them on Firefox. Can anyone help me with this? Ad Blacker worked fine on my old iMac but not on the new one. I am not getting ads on my home page but I am getting two blocks of "code" where the ads would normally appear.

Thank you.

Chosen solution

Hi Alan, one common reason for this in recent months is users switching Firefox to using Automatic private browsing ("Never Remember History") without setting all their extensions to run in private windows. (Extensions in Private Browsing)

To check on that, open the Add-ons page. Either:

  • Command+Shift+a (on Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Each extension title can have zero or more icons next to it. The one indicating that the extension is allowed to run in private windows is a purple circle with a white mask:

If there are extensions that you want to run in private windows that don't have the mask icon, click the title and scroll the Details panel down to where you can adjust the permission:

Does that help or are the extensions still not appearing? You also can check whether the buttons are available to add from the Customize tab:

Customize Firefox controls, buttons and toolbars

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Hi Alan, one common reason for this in recent months is users switching Firefox to using Automatic private browsing ("Never Remember History") without setting all their extensions to run in private windows. (Extensions in Private Browsing)

To check on that, open the Add-ons page. Either:

  • Command+Shift+a (on Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Each extension title can have zero or more icons next to it. The one indicating that the extension is allowed to run in private windows is a purple circle with a white mask:

If there are extensions that you want to run in private windows that don't have the mask icon, click the title and scroll the Details panel down to where you can adjust the permission:

Does that help or are the extensions still not appearing? You also can check whether the buttons are available to add from the Customize tab:

Customize Firefox controls, buttons and toolbars

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.