Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MQTT (wss) Not Connecting in Firefox, Works in Other Browsers

  • 6 replies
  • 1 has this problem
  • 85 views
  • Last reply by GHammer

more options

I have a website that uses live data from an MQTT server. The server has proper certs, and works fine with Chrome, Opera, Edge on various platforms (mobile, Windows, Linux). The live data does not display in Firefox and has not in several months/FF builds.

The console shows The connection to wss://weather.ghammer.net:9001/mqtt was interrupted while the page was loading.

No further info is available. In order to continue to use and recommend Firefox, this needs to work as in other browsers.

Any ideas?

Attached screenshots

Chosen solution

Your page's behavior seems to match a pattern of problems with Firefox attempting to make an SSL connection to MQTT servers via HTTP/2. Users can disable HTTP/2 for Websockets --

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste websockets and pause while the list is filtered

(3) Double-click the network.http.spdy.websockets preference to switch the value from true to false (switches Firefox from using HTTP/2 to HTTP/1.1 for WebSockets)

-- but that isn't something the server could dictate to Firefox users.

What makes this even stranger is that the Websocket connection the page is making to the radar server is working just fine with the standard setting. ??

Read this answer in context 👍 1

All Replies (6)

more options

I'm not very familiar with WebSocket connections. This question might be more suited for another venue:

Where to go for developer support

Helpful?

more options

No, not a developer thing, this is just a Firefox not displaying what others do. wss is fairly common.

Helpful?

more options

I see errors in the Web Console.

Failed to create WebGL context: WebGL creation failed:

  • WebglAllowWindowsNativeGl:false restricts context creation on this system.

Modified by cor-el

Helpful?

more options

That could easily be, but it would be your system. It also would not impact MQTT connecting.

Helpful?

more options

Chosen Solution

Your page's behavior seems to match a pattern of problems with Firefox attempting to make an SSL connection to MQTT servers via HTTP/2. Users can disable HTTP/2 for Websockets --

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste websockets and pause while the list is filtered

(3) Double-click the network.http.spdy.websockets preference to switch the value from true to false (switches Firefox from using HTTP/2 to HTTP/1.1 for WebSockets)

-- but that isn't something the server could dictate to Firefox users.

What makes this even stranger is that the Websocket connection the page is making to the radar server is working just fine with the standard setting. ??

Modified by jscher2000

Helpful?

more options

@jscher2000

Thanks for the pointers to the issue on github and for the workaround. I agree that the fact the same type connection works for one service but not another is odd. Makes for difficult troubleshooting for sure.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.