Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

is firefox version 52 compatible with Elementor?

  • No replies
  • 1 has this problem
  • 2 views
more options

is Firefox version 52 (windows XP) compatible with Elementor (Wordpress website design software)

building a web site with Wordpress Elementor and Elementor no longer opens in safemode. No progress in solving this – could it be the browser? 52 is the latest version of Mozilla that runs on windows XP.

Thanks!

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.