Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox not playing html5 videos

more options

Hi! I have got a big problem that took hours of my patient attention, but nothing helped(or I have done something incorrectly).

I am unable to play most videos on the internet. For example, i can watch video in youtube, but when i play stream on the same platform, youtube complains that currently my firefox browser does not recognize any html5 video formats.

Plugins installed: OpenH264, Shockwave Flash, and... while writing this question i've found that there's also widevine cdm that i tried earlier to install in my browser, 'cause by default in my Ubuntu 20.04.1 LTS there's no such extension.

I tried this to install widevine. Maybe I have done something in the way it shouldn't. 1)https://support.mozilla.org/en-US/questions/1207502 2)Reinstall firefox 3)Trying disabling any combination of installed extensions to find the "wrong".

Hi! I have got a big problem that took hours of my patient attention, but nothing helped(or I have done something incorrectly). I am unable to play most videos on the internet. For example, i can watch video in youtube, but when i play stream on the same platform, youtube complains that currently my firefox browser does not recognize any html5 video formats. Plugins installed: OpenH264, Shockwave Flash, and... while writing this question i've found that there's also widevine cdm that i tried earlier to install in my browser, 'cause by default in my Ubuntu 20.04.1 LTS there's no such extension. I tried this to install widevine. Maybe I have done something in the way it shouldn't. 1)https://support.mozilla.org/en-US/questions/1207502 2)Reinstall firefox 3)Trying disabling any combination of installed extensions to find the "wrong".

Chosen solution

Make sure you have the latest FFmpeg and libavcodec packages installed.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Make sure you have the latest FFmpeg and libavcodec packages installed.

more options

Yes, downloading the ffmpeg package solved the problem!(apt install ffmpeg) Thanks!