X
Tap here to go to the mobile version of the site.

Support Forum

How do I disable automatic updates in 68.1.1 32bit?

Posted

How do I disable automatic updates in 68.1.1 32bit? There is no option for turning off the automatic updates anymore. I cant find any documentation for config editor that applies to the latest version!

How do I disable automatic updates in 68.1.1 32bit? There is no option for turning off the automatic updates anymore. I cant find any documentation for config editor that applies to the latest version!

Chosen solution

I asked about this in a bug report. Full details here: https://bugzilla.mozilla.org/show_bug.cgi?id=1582427

Information says: you need to set this up in the policies. The info at following link relates to Firefox, but apparently the same applies for Thunderbird. https://winaero.com/blog/disable-updates-firefox-63-above/


Exit Thunderbird.

  • Type 'Run' in search and select 'Run' app
  • In 'Run' app type regedit and click on Ok
  • HKEY_LOCAL_MACHINE\Software\Policies
  • Create new subkey called 'Mozilla'
  • HKEY_LOCAL_MACHINE\Software\Policies\Mozilla
  • Then create new subkey called 'Thunderbird'
  • HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Thunderbird
  • On the right, create a new 32-Bit DWORD value DisableAppUpdate.
  • Note: Even if you are running 64-bit Windows you must still create a 32-bit DWORD value.
  • Set its value to 1.

Start Thunderbird

Menu icon > Options > Options > Advanced > 'Updates' tab Thunderbird updates It will state current version number. Options are removed and replaced by: 'Updates disabled by your system administrator'

To undo the change, remove the DisableAppUpdate 32-bit DWORD value you have created, then restart Thunderbird.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

sfhowes
  • Top 10 Contributor
1915 solutions 9584 answers

See the attached picture.

See the attached picture.

Question owner

I want it disabled! Not postponed!

I want it disabled! Not postponed!
sfhowes
  • Top 10 Contributor
1915 solutions 9584 answers

The 'Check... let me choose' setting will not update unless you choose to. Having a option to disable updates as well as notifications would probably not be best as far as security is concerned.

The 'Check... let me choose' setting will not update unless you choose to. Having a option to disable updates as well as notifications would probably not be best as far as security is concerned.

Question owner

I am looking for a config setting that used to be there but has been removed or replaced by another setting to disable all updates. The old setting is app.update.enable which is no longer an option. But there are several config update options but I dont find a resource explaining each ones function.

I am looking for a config setting that used to be there but has been removed or replaced by another setting to disable all updates. The old setting is app.update.enable which is no longer an option. But there are several config update options but I dont find a resource explaining each ones function.
sfhowes
  • Top 10 Contributor
1915 solutions 9584 answers

You can find app.* preferences here. Some apply to Firefox or TB, or both, and some may be obsolete.

You can find app.* preferences [http://kb.mozillazine.org/Category:Preferences here]. Some apply to Firefox or TB, or both, and some may be obsolete.

Question owner

Thanks! The list is not up to date but I was able to find some perfs that might work. Will see.

Thanks! The list is not up to date but I was able to find some perfs that might work. Will see.
Toad-Hall
  • Top 10 Contributor
1864 solutions 12646 answers

Chosen Solution

I asked about this in a bug report. Full details here: https://bugzilla.mozilla.org/show_bug.cgi?id=1582427

Information says: you need to set this up in the policies. The info at following link relates to Firefox, but apparently the same applies for Thunderbird. https://winaero.com/blog/disable-updates-firefox-63-above/


Exit Thunderbird.

  • Type 'Run' in search and select 'Run' app
  • In 'Run' app type regedit and click on Ok
  • HKEY_LOCAL_MACHINE\Software\Policies
  • Create new subkey called 'Mozilla'
  • HKEY_LOCAL_MACHINE\Software\Policies\Mozilla
  • Then create new subkey called 'Thunderbird'
  • HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Thunderbird
  • On the right, create a new 32-Bit DWORD value DisableAppUpdate.
  • Note: Even if you are running 64-bit Windows you must still create a 32-bit DWORD value.
  • Set its value to 1.

Start Thunderbird

Menu icon > Options > Options > Advanced > 'Updates' tab Thunderbird updates It will state current version number. Options are removed and replaced by: 'Updates disabled by your system administrator'

To undo the change, remove the DisableAppUpdate 32-bit DWORD value you have created, then restart Thunderbird.

I asked about this in a bug report. Full details here: https://bugzilla.mozilla.org/show_bug.cgi?id=1582427 Information says: you need to set this up in the policies. The info at following link relates to Firefox, but apparently the same applies for Thunderbird. https://winaero.com/blog/disable-updates-firefox-63-above/ Exit Thunderbird. * Type 'Run' in search and select 'Run' app * In 'Run' app type '''regedit''' and click on Ok * HKEY_LOCAL_MACHINE\Software\Policies * Create new subkey called 'Mozilla' * HKEY_LOCAL_MACHINE\Software\Policies\Mozilla * Then create new subkey called 'Thunderbird' * HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Thunderbird * On the right, create a new 32-Bit DWORD value DisableAppUpdate. * Note: Even if you are running 64-bit Windows you must still create a 32-bit DWORD value. * Set its value to 1. Start Thunderbird Menu icon > Options > Options > Advanced > 'Updates' tab Thunderbird updates It will state current version number. Options are removed and replaced by: 'Updates disabled by your system administrator' To undo the change, remove the DisableAppUpdate 32-bit DWORD value you have created, then restart Thunderbird.
Toad-Hall
  • Top 10 Contributor
1864 solutions 12646 answers

Helpful Reply

Added an image as a guide for users.

Windows 10 OS Image helps users to set a policy for stopping updates in version 68*.

Added an image as a guide for users. Windows 10 OS Image helps users to set a policy for stopping updates in version 68*.
djeepee1 0 solutions 1 answers

I've completely fed up with auto updates. Lost all my addons and can't revert to 60.9.1. I need my addons working and your stupid decision to auto update screws up everything. Looking for another email program because of this.

EDIT: This works! On the top menu, click on Tools->Options to enter the Options window, then click on Advanced and select the General tab. Click on the Config Editor… button and the scary window saying “This might void you warranty !” should appear again. Just click on “I’ll be careful I promise!” to carry on.

Then in the Filter filed type app.update.enabled. It should be set to true, double-click on the line to set it to false.


[Profanity removed by moderator. Please read Forum rules and guidelines, thanks.]

I've completely fed up with<!-- fucking --> auto updates. Lost all my addons and can't revert to 60.9.1. I need my addons working and your stupid decision to auto update <!-- fucks -->screws up everything. Looking for another email program because of this<!-- shit -->. EDIT: This works! On the top menu, click on Tools->Options to enter the Options window, then click on Advanced and select the General tab. Click on the Config Editor… button and the scary window saying “This might void you warranty !” should appear again. Just click on “I’ll be careful I promise!” to carry on. Then in the Filter filed type app.update.enabled. It should be set to true, double-click on the line to set it to false. ''[Profanity removed by moderator. Please read [[Forum rules and guidelines]], thanks.]''

Modified by Chris Ilias

Wayne Mery
  • Top 25 Contributor
  • Moderator
602 solutions 5776 answers

djeepee1 said

I've completely fed up ...

If you really want assistance with your add-ons situation you should post in your own topic with details and your list of addons rather than hijack someone else's topic with generalities and foul language.

''djeepee1 [[#answer-1280861|said]]'' <blockquote> I've completely fed up ... </blockquote> If you really want assistance with your add-ons situation you should post in your own topic with details and your list of addons rather than hijack someone else's topic with generalities and foul language.