X
Tap here to go to the mobile version of the site.

Support Forum

Empty address bar appears when new tab opens

Posted

When I share a link to Firefox from another app so that it opens in a new tab, the address bar starts out focused for searching instead of showing the URL for the current page. Is this just a bug? I am pretty sure this did not happen in older versions... I want all tabs to show their URL by default, and then only clear for searching if I tap the address bar.

When I share a link to Firefox from another app so that it opens in a new tab, the address bar starts out focused for searching instead of showing the URL for the current page. Is this just a bug? I am pretty sure this did not happen in older versions... I want all tabs to show their URL by default, and then only clear for searching if I tap the address bar.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 12_4_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) FxiOS/19.0b16042 Mobile/15E148 Safari/605.1.15

More Information

Question owner

Here is a screenshot of what I see when a new tab opens. You can see how the address bar is (incorrectly) focused.

Here is a screenshot of what I see when a new tab opens. You can see how the address bar is (incorrectly) focused.
Was this helpful to you?
Quote
Null User Value 0 solutions 4 answers

I’m trying to reproduce it on my side by sharing a link from Chrome, but the URL is populating for me.

My first thought is a custom keyboard being installed/enabled (i.e. not the default iOS keyboard). I would check that first. If there’s a custom keyboard try disabling it.

After that, the standard steps: -Restart the phone, see if the issue persists -If it does, please post what version of iOS you’re running, the version of Firefox you’re running, the app you’re using to share the page and the page you’re sharing

With a clean OS boot, custom keyboards eliminated, and your steps to reliably reproduce the issue we can start helping you narrow down the UI issue!

I’m trying to reproduce it on my side by sharing a link from Chrome, but the URL is populating for me. My first thought is a custom keyboard being installed/enabled (i.e. not the default iOS keyboard). I would check that first. If there’s a custom keyboard try disabling it. After that, the standard steps: -Restart the phone, see if the issue persists -If it does, please post what version of iOS you’re running, the version of Firefox you’re running, the app you’re using to share the page and the page you’re sharing With a clean OS boot, custom keyboards eliminated, and your steps to reliably reproduce the issue we can start helping you narrow down the UI issue!
Was this helpful to you?
Quote

Question owner

No custom keyboards. Only English (UK) and Emoji are enabled.

Yes, this continues to happen across reboots.

iOS 12.4.1 Firefox for iOS 19.0

To reproduce:

1. Long press on any link in Gmail for iOS 2. Choose Share... 3. Choose Firefox 4. Choose Open in Firefox

No custom keyboards. Only English (UK) and Emoji are enabled. Yes, this continues to happen across reboots. iOS 12.4.1 Firefox for iOS 19.0 To reproduce: 1. Long press on any link in Gmail for iOS 2. Choose Share... 3. Choose Firefox 4. Choose Open in Firefox
Was this helpful to you?
Quote

Question owner

I think I have isolated the issue: it only happens when Firefox settings have New Tab set to Blank Page.

If it’s the default Firefox Home, the issue does not happen.

I think I have isolated the issue: it only happens when Firefox settings have New Tab set to Blank Page. If it’s the default Firefox Home, the issue does not happen.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.