X
Tap here to go to the mobile version of the site.

Support Forum

Samsung J5 Pro Oreo 8.1 Firefox Copy & paste broken on (eg) smh.com.au

Posted

Using current FF on both a J1mini on android 5.1.1 and the J5 Pro on 8.1, all up to date.

Previously marking text brought up a menu on top line; copy / select all / paste etc. This worked everywhere. Still does on the J1mini.

On Oreo instead it brings up a floating box (copy chit paste share select all), but this doesn't work on my favourite news site on the comments section - I can neither copy useful postings nor paste text written elsewhere (e.g. a text editor) as my own posting.

This makes Firefox, long my favourite browser, useless for one of my main daily activities.

In this mode, you can select text ok, but when you do there's no way to cut or copy or paste; that popup menu simply fails to appear. Very frustratingl

The ForceCopy add-on makes no difference.

If you need an example, try

... ah no, I can't even paste an example url here now :(

You can try https://smh.com.au and look for an article with comments. At the top of comments section it works but once you zcroll down a page or further, you can't copy selected text, nor paste a reply.

Hopefully this is not only happening to me.

Ian

Using current FF on both a J1mini on android 5.1.1 and the J5 Pro on 8.1, all up to date. Previously marking text brought up a menu on top line; copy / select all / paste etc. This worked everywhere. Still does on the J1mini. On Oreo instead it brings up a floating box (copy chit paste share select all), but this doesn't work on my favourite news site on the comments section - I can neither copy useful postings nor paste text written elsewhere (e.g. a text editor) as my own posting. This makes Firefox, long my favourite browser, useless for one of my main daily activities. In this mode, you can select text ok, but when you do there's no way to cut or copy or paste; that popup menu simply fails to appear. Very frustratingl The ForceCopy add-on makes no difference. If you need an example, try ... ah no, I can't even paste an example url here now :( You can try https://smh.com.au and look for an article with comments. At the top of comments section it works but once you zcroll down a page or further, you can't copy selected text, nor paste a reply. Hopefully this is not only happening to me. Ian
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 8.1.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

More Information

Question owner

https://www.smh.com.au/environment/climate-change/the-amazon-fires-and-the-dilemma-for-climate-scientists-20190825-p52kiq.html#comments

Ok, _sometimes_ paste works, so there's my example URL.

There's another possible factor here: I'm using the Samsung keyboard with mostly English (AU) language, though with US and UK variants selectable. It also has a symbol for the Paste Buffer (as I'll call it) whch works in some places but not others ... it isn't working typing this, nor in the circumstances reported above. The paste buffer is new, or at least wasn't available in Lollipop (5.1.1)

If nothing here triggers anything for anyone, tomorrow I'll try a couple of screenshots to clarify my description.

https://www.smh.com.au/environment/climate-change/the-amazon-fires-and-the-dilemma-for-climate-scientists-20190825-p52kiq.html#comments Ok, _sometimes_ paste works, so there's my example URL. There's another possible factor here: I'm using the Samsung keyboard with mostly English (AU) language, though with US and UK variants selectable. It also has a symbol for the Paste Buffer (as I'll call it) whch works in some places but not others ... it isn't working typing this, nor in the circumstances reported above. The paste buffer is new, or at least wasn't available in Lollipop (5.1.1) If nothing here triggers anything for anyone, tomorrow I'll try a couple of screenshots to clarify my description.
Was this helpful to you? 0
Quote

Question owner

Ok, in the first screenshot the article is still visible above, so marking text gets the popup dialg box, and can be copied.

The second (right hand) image shows the comment below, with selected text but NO popup dialog box, so NO way to copy text. Same for anywhere further down in comments. Also, replies cannot be pasted in, when they are enabled.

Could downgrading to Android 7 - if that's possible? - help with this. I really, really don't want to lose Firefox, but I have work needing doing that is on hold till this is fixd.

Cheers, Ian

Ok, in the first screenshot the article is still visible above, so marking text gets the popup dialg box, and can be copied. The second (right hand) image shows the comment below, with selected text but NO popup dialog box, so NO way to copy text. Same for anywhere further down in comments. Also, replies cannot be pasted in, when they are enabled. Could downgrading to Android 7 - if that's possible? - help with this. I really, really don't want to lose Firefox, but I have work needing doing that is on hold till this is fixd. Cheers, Ian

Modified by smithi7

Was this helpful to you?
Quote
Heather h 0 solutions 1 answers

gdftt

gdftt
Was this helpful to you? 0
Quote

Question owner

Has noone else seen this problem, at all?

Has noone else seen this problem, at all?
Was this helpful to you?
Quote
Seburo
  • Top 10 Contributor
  • Moderator
775 solutions 5669 answers

Helpful Reply

Hi

Thank you for your question and apologies for the delay in responding.

I have seen this issue in my Android 8 device using Firefox Preview (our new browser available from the Google Play Store. I think it may be a small unresolved issue with the Android copy and paste funcationality that should be fixed in a future update.

Hi Thank you for your question and apologies for the delay in responding. I have seen this issue in my Android 8 device using Firefox Preview (our new browser available from the Google Play Store. I think it may be a small unresolved issue with the Android copy and paste funcationality that should be fixed in a future update.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8692 solutions 71041 answers

Helpful Reply

It's not just you, there's another thread:

https://support.mozilla.org/questions/1267979

The comments are in a framed (embedded) page, and I suspect that is related to the problem in some manner.

I posted a link to the two threads in a closed bug suggesting they re-open it since we now have a better understanding of how to reproduce it.

https://bugzilla.mozilla.org/show_bug.cgi?id=1539930

It's not just you, there's another thread: https://support.mozilla.org/questions/1267979 The comments are in a framed (embedded) page, and I suspect that is related to the problem in some manner. I posted a link to the two threads in a closed bug suggesting they re-open it since we now have a better understanding of how to reproduce it. https://bugzilla.mozilla.org/show_bug.cgi?id=1539930 * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting]

Modified by jscher2000

Was this helpful to you? 1
Quote

Question owner

Thanks to you both, and my turn to apologise - I hadn't checked my gmail account at all last week.

I failed to follow the dense page source but an iframe sounds very plausible, and yes quite likely a remote site as the comments are known to be externally moderated by another company. This also explains earlier failures to find text I wanted to copy in the page source :)

FWIW I'm having similar but different problems marking text on this page, except within this response box. Tap and hold, singly or repeatedly, in earlier comments does nothing at all; won't mark.

I did try earlier force stopping FF as suggested in the first other post, to no avail.

At times I've tried disabling all addons, but FTR I've currently available Cookie Manager, Onetab, ForceCopy (no help), Disable JavaScript (rarely invoked) and AdBlock Plus (but not active on the SMH.com.au site in question, nor on this site). I'd previously tried Don't Fuck With Paste; no help for this issue anyway.

Happy to try anything else, or any sites, if it might help.

cheers, Ian

Thanks to you both, and my turn to apologise - I hadn't checked my gmail account at all last week. I failed to follow the dense page source but an iframe sounds very plausible, and yes quite likely a remote site as the comments are known to be externally moderated by another company. This also explains earlier failures to find text I wanted to copy in the page source :) FWIW I'm having similar but different problems marking text on this page, except within this response box. Tap and hold, singly or repeatedly, in earlier comments does nothing at all; won't mark. I did try earlier force stopping FF as suggested in the first other post, to no avail. At times I've tried disabling all addons, but FTR I've currently available Cookie Manager, Onetab, ForceCopy (no help), Disable JavaScript (rarely invoked) and AdBlock Plus (but not active on the SMH.com.au site in question, nor on this site). I'd previously tried Don't Fuck With Paste; no help for this issue anyway. Happy to try anything else, or any sites, if it might help. cheers, Ian
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.