X
Tap here to go to the mobile version of the site.

Support Forum

Download in private mode with basic http authentication fails

Posted

On one site i frequently use, i'm seeing that Firefox cannot download files in Private mode because it's not sending HTTP basic authentication information with the request. Switching to non-private mode works but is a horrible workaround. i've been doing this for years in Chrome's Incognito Mode, but was recently forced to switch when Chrome for Android recently removed all content download options for some braindead reason.

i consider this to be a bug in FF but cannot for the life of me find how to post a bug report around here.

Is there a workaround to force FF to send basic http authentication info with private-mode requests? Failing that, how does one file a ticket via the Android version of FF?

On one site i frequently use, i'm seeing that Firefox cannot download files in Private mode because it's not sending HTTP basic authentication information with the request. Switching to non-private mode works but is a horrible workaround. i've been doing this for years in Chrome's Incognito Mode, but was recently forced to switch when Chrome for Android recently removed all content download options for some braindead reason. i consider this to be a bug in FF but cannot for the life of me find how to post a bug report around here. Is there a workaround to force FF to send basic http authentication info with private-mode requests? Failing that, how does one file a ticket via the Android version of FF?

Chosen solution

i posted a response to this shortly after my original post with a workaround but it apparently did not actually get posted. Through trial and error i discovered that there's a setting which needs to be toggled to enable what my top post mentions:

network.auth.non-web-content-triggered-resources-http-auth-allow

needs to be toggled to true.

i did indeed try FF Preview but it's unusable for me because it doesn't support about:config (just leads to a blank page), which means that i can neither set the above setting nor disable animated images (which are one of my biggest pet peeves on the internet).

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 8.1.0; Tablet; rv:67.0) Gecko/67.0 Firefox/67.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
820 solutions 6063 answers

HI

If you would like to file a bug about this issue, that would be awesome. You can do this openly here (you will need to set up an account on our bug tracking system first).

Alternatively, you may wish to try our new (and still being developed) Firefox Preview (available from the Google Play Store).

HI If you would like to file a bug about this issue, that would be awesome. You can do this openly [https://bugzilla.mozilla.org/enter_bug.cgi?format=guided#h=dupes|Firefox%20for%20Android| here] (you will need to set up an account on our bug tracking system first). Alternatively, you may wish to try our new (and still being developed) Firefox Preview (available from the Google Play Store).

Modified by Seburo

Was this helpful to you?
Quote

Chosen Solution

i posted a response to this shortly after my original post with a workaround but it apparently did not actually get posted. Through trial and error i discovered that there's a setting which needs to be toggled to enable what my top post mentions:

network.auth.non-web-content-triggered-resources-http-auth-allow

needs to be toggled to true.

i did indeed try FF Preview but it's unusable for me because it doesn't support about:config (just leads to a blank page), which means that i can neither set the above setting nor disable animated images (which are one of my biggest pet peeves on the internet).

i posted a response to this shortly after my original post with a workaround but it apparently did not actually get posted. Through trial and error i discovered that there's a setting which needs to be toggled to enable what my top post mentions: network.auth.non-web-content-triggered-resources-http-auth-allow needs to be toggled to true. i did indeed try FF Preview but it's unusable for me because it doesn't support about:config (just leads to a blank page), which means that i can neither set the above setting nor disable animated images (which are one of my biggest pet peeves on the internet).
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.