X
Tap here to go to the mobile version of the site.

Support Forum

In sending an invitation lightning sends from "user@local.host" rather than the email i entered e.g. "user@yyy.com. That makes it impossibe to reply."

Posted

I'm trying to use Lightning with my Synology Caldav server. I've been able to set up a Caldav calendar in Lightning and get it to sync successfully with the server, and through the server to other devices. I've specified an email to use with the calendar, let's call it joe@myserver.com. I've also checked the "Prefer client-side email scheduling". The one problem I've come up against that I can't figure out is that when I set up a meeting inside Lightning and invite others, the invitation gets sent out with a return address of "joe@local.host" versus "joe@myserver.com" That makes it impossible for others to reply successfully to any invitations they might receive. This seems like a bug within Lightning, since it's supposed to be handling the email invitations. Perhaps it somehow isn't picking up the right email address, even though I specified it? Thanks in advance!

I'm trying to use Lightning with my Synology Caldav server. I've been able to set up a Caldav calendar in Lightning and get it to sync successfully with the server, and through the server to other devices. I've specified an email to use with the calendar, let's call it joe@myserver.com. I've also checked the "Prefer client-side email scheduling". The one problem I've come up against that I can't figure out is that when I set up a meeting inside Lightning and invite others, the invitation gets sent out with a return address of "joe@local.host" versus "joe@myserver.com" That makes it impossible for others to reply successfully to any invitations they might receive. This seems like a bug within Lightning, since it's supposed to be handling the email invitations. Perhaps it somehow isn't picking up the right email address, even though I specified it? Thanks in advance!
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

check the outgoing server (SMTP) entry in the account settings, but also make sure that any .local identity is not the default for the selected account. (the reply-to: and email both derive from the default identity of the account is my understanding. But I am no expert in calendar.

check the outgoing server (SMTP) entry in the account settings, but also make sure that any .local identity is not the default for the selected account. (the reply-to: and email both derive from the default identity of the account is my understanding. But I am no expert in calendar.
Was this helpful to you? 0
Quote

Question owner

Matt, thanks for your reply! Unfortunately, I don't think this is the answer to the problem. What I forgot to mention is that the default (non-Caldav) calendar that is created initially by Lightning works correctly -- that is, the right email address is used to create invitations and replies work correctly. So, the system does find the right email information for that calendar. The reason why I can't use that calendar on a long-term basis is that it doesn't sync with my Caldav server. When I create a new calendar that does sync with the Caldav server, it doesn't get the right email information for the reply.

Matt, thanks for your reply! Unfortunately, I don't think this is the answer to the problem. What I forgot to mention is that the default (non-Caldav) calendar that is created initially by Lightning works correctly -- that is, the right email address is used to create invitations and replies work correctly. So, the system does find the right email information for that calendar. The reason why I can't use that calendar on a long-term basis is that it doesn't sync with my Caldav server. When I create a new calendar that does sync with the Caldav server, it doesn't get the right email information for the reply.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

Helpful Reply

each calendar has it's own "email address"

Right click the calendar name on the left of the screen under the small month calendar. Select properties

Do that with both calendars and determine the difference in Email selected. If the default local one works, then there is clearly a different one being selected for the remote calendar.

each calendar has it's own "email address" Right click the calendar name on the left of the screen under the small month calendar. Select properties Do that with both calendars and determine the difference in Email selected. If the default local one works, then there is clearly a different one being selected for the remote calendar.
Was this helpful to you? 1
Quote

Question owner

Thanks Matt. I tried checking the properties as you suggested. Both calendars have the same fully formed correct email selected. The problem is that for the remote calendar, when an invitation is sent, that correct email gets changed to the form "user@local.host" rather than the original, correct email.

Thanks Matt. I tried checking the properties as you suggested. Both calendars have the same fully formed correct email selected. The problem is that for the remote calendar, when an invitation is sent, that correct email gets changed to the form "user@local.host" rather than the original, correct email.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

that address has to be in your local settings somewhere.

Open the Config Editor and search for the address.... what "fields" does it appear in.

that address has to be in your local settings somewhere. Open the [[config editor]] and search for the address.... what "fields" does it appear in.
Was this helpful to you? 0
Quote

Question owner

Good thought, but the email address "user@local.host" doesn't appear anywhere in the configs, in fact, "local.host" doesn't appear, but this string "devtools.debugger.chrome-debugging-host" has the value "localhost"

That's it....

Good thought, but the email address "user@local.host" doesn't appear anywhere in the configs, in fact, "local.host" doesn't appear, but this string "devtools.debugger.chrome-debugging-host" has the value "localhost" That's it....
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

ok, so you say these mails appear in your sent items. Is the account IMAP?

ok, so you say these mails appear in your sent items. Is the account IMAP?
Was this helpful to you?
Quote

Question owner

Yes, it's IMAP. And I can see the sent message, as coming from my email. The problem is that in the invitation itself, the organizer of the meeting is identified as bill@local.host rather than as my email, so when you do a reply it tries to go to bill@local.host which fails. I also see this behavior in the window for inviting participants in Lightning --- when the invitation table comes up, the organizer is identified as bill@local.host which is also grayed out. The funny thing is it all works correctly for a local calendar -- the invite attendees window shows my email correctly as the organizer --- but it does not work for a remote calendar.

Yes, it's IMAP. And I can see the sent message, as coming from my email. The problem is that in the invitation itself, the organizer of the meeting is identified as bill@local.host rather than as my email, so when you do a reply it tries to go to bill@local.host which fails. I also see this behavior in the window for inviting participants in Lightning --- when the invitation table comes up, the organizer is identified as bill@local.host which is also grayed out. The funny thing is it all works correctly for a local calendar -- the invite attendees window shows my email correctly as the organizer --- but it does not work for a remote calendar.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

are you hosting your own local mail server by any chance?

are you hosting your own local mail server by any chance?
Was this helpful to you?
Quote

Question owner

Yes, on my Synology NAS.

Yes, on my Synology NAS.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3220 solutions 22044 answers

I thought it might be that, when I had a local mail server it was configured for a .local domain and an internet domain. I think the issue is there,or in your local DNS. Not in Thunderbird

If you open a command prompt (Windows key+X get the menu) and type

tracert local.host

Does it resolve the domain to your synology device?

I thought it might be that, when I had a local mail server it was configured for a .local domain and an internet domain. I think the issue is there,or in your local DNS. Not in Thunderbird If you open a command prompt (Windows key+X get the menu) and type tracert local.host Does it resolve the domain to your synology device?
Was this helpful to you?
Quote

Question owner

I'm on Macs and a Raspberry Pi, so used traceroute rather than tracert, but both from the Mac and the Raspberry Pi I got unknown host errors. Here's from the Raspberry PI:

pi@raspberrypi3:~ $ traceroute local.host local.host: Name or service not known

and from the Mac a similar unknown host message.

Traceroute does find the Raspberry as raspberrypi3.local as well as other computers on my local network, and externally of course, so all that seems to be working....

BTW, thanks for all your help!

I'm on Macs and a Raspberry Pi, so used traceroute rather than tracert, but both from the Mac and the Raspberry Pi I got unknown host errors. Here's from the Raspberry PI: pi@raspberrypi3:~ $ traceroute local.host local.host: Name or service not known and from the Mac a similar unknown host message. Traceroute does find the Raspberry as raspberrypi3.local as well as other computers on my local network, and externally of course, so all that seems to be working.... BTW, thanks for all your help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.