X
Tap here to go to the mobile version of the site.

Support Forum

Add-on stopped working and can't reinstall

Posted

Add-ons were suddenly disabled after receiving Firefox pop-up messages saying the add-ons were not verified. Remove them and tried to reinstall but Firefox didn't allow. Tried reinstalling Firefox but no avail. The error message kept popping

Add-ons were suddenly disabled after receiving Firefox pop-up messages saying the add-ons were not verified. Remove them and tried to reinstall but Firefox didn't allow. Tried reinstalling Firefox but no avail. The error message kept popping
Attached screenshots
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 7.0; Tablet; rv:66.0) Gecko/66.0 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8568 solutions 70078 answers

Helpful Reply

On Android, I heard you can disable the add-on verification. Not recommended for long-term use, but to bridge this hopefully brief crisis...

(1) In a new tab, type or paste about:config in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) Tap the xpinstall.signatures.required preference to trigger a Toggle button and tap Toggle to switch the value from true to false

Does that work on yours?

** EDIT **

Unfortunately, this creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation:

(4) In the search box above the list, type or paste autoup and pause while the list is filtered

(5) Tap the extensions.update.autoUpdateDefault preference to show a Toggle button, then tap Toggle to switch the value from true to false

Hopefully this won't be needed for very long.

On Android, I heard you can disable the add-on verification. Not recommended for long-term use, but to bridge this hopefully brief crisis... (1) In a new tab, type or paste '''about:config''' in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented. (2) In the search box above the list, type or paste '''xpin''' and pause while the list is filtered (3) Tap the '''xpinstall.signatures.required''' preference to trigger a Toggle button and tap Toggle to switch the value from true to false Does that work on yours? '''** EDIT **''' Unfortunately, this creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation: (4) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (5) Tap the '''extensions.update.autoUpdateDefault''' preference to show a Toggle button, then tap Toggle to switch the value from true to false Hopefully this won't be needed for very long.

Modified by jscher2000

Was this helpful to you? 1
Quote

Helpful Reply

Thanks for the help. It's working fine now.

Thanks for the help. It's working fine now.
Was this helpful to you? 1
Quote
DrSNAFU 0 solutions 1 answers

I've just had this exact same problem. I had uBlock Origin flagged as incompatible and I removed it. Tried to re-download it and every time I tried it I got the same error message as above. This applied to EVERY add-on I tried to install.

I deleted Firefox Beta and reinstalled, no go. Installed Firefox standard, same issue. Rebooted phone, same.

The above instructions fixed the issue for me.

I've just had this exact same problem. I had uBlock Origin flagged as incompatible and I removed it. Tried to re-download it and every time I tried it I got the same error message as above. This applied to EVERY add-on I tried to install. I deleted Firefox Beta and reinstalled, no go. Installed Firefox standard, same issue. Rebooted phone, same. The above instructions fixed the issue for me.
Was this helpful to you?
Quote
BigBadBish 1 solutions 8 answers

jscher2000 said

On Android, I heard you can disable the add-on verification. Not recommended for long-term use, but to bridge this hopefully brief crisis... (1) In a new tab, type or paste about:config in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented. (2) In the search box above the list, type or paste xpin and pause while the list is filtered (3) Tap the xpinstall.signatures.required preference to trigger a Toggle button and tap Toggle to switch the value from true to false Does that work on yours?

Hi I've had issues for both my laptop and my android phone, My Firefox on windows 10 seems to be all up and running now BUT the Add - ons for my Firefox Android are still not, I've not tried this fix yet, Is there a ETA on a fix for us android users ? If the fix is nearly complete then i will hold out on this temp fix you've suggested on trying.

Many Thanks

''jscher2000 [[#answer-1218048|said]]'' <blockquote> On Android, I heard you can disable the add-on verification. Not recommended for long-term use, but to bridge this hopefully brief crisis... (1) In a new tab, type or paste '''about:config''' in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented. (2) In the search box above the list, type or paste '''xpin''' and pause while the list is filtered (3) Tap the '''xpinstall.signatures.required''' preference to trigger a Toggle button and tap Toggle to switch the value from true to false Does that work on yours? </blockquote> '''Hi I've had issues for both my laptop and my android phone, My Firefox on windows 10 seems to be all up and running now BUT the Add - ons for my Firefox Android are still not, I've not tried this fix yet, Is there a ETA on a fix for us android users ? If the fix is nearly complete then i will hold out on this temp fix you've suggested on trying. Many Thanks'''
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70078 answers

Hi BigBadBish, I don't know the timeline for a fix on Android. The Add-ons team is regularly updating this post:

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

Hi BigBadBish, I don't know the timeline for a fix on Android. The Add-ons team is regularly updating this post: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
Was this helpful to you?
Quote
BigBadBish 1 solutions 8 answers

Hi Again and thanks for the quick reply, So do we have to keep checking the the blog link you attached ?

Is there not a way that we can get notified via email when the fix for Android has been completed rather than keep checking online to see what the latest is .

Many Thanks

'''Hi Again and thanks for the quick reply, So do we have to keep checking the the blog link you attached ? '''Is there not a way that we can get notified via email when the fix for Android has been completed rather than keep checking online to see what the latest is . '''Many Thanks'''

Modified by BigBadBish

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70078 answers

Hi BigBadBish, when a fix is available it should be pushed out automatically, probably through Google Play. I don't know if there is anywhere to subscribe for updates on that, but there's a reasonable chance updates will be mentioned on this forum and maybe even in this thread.

Hi BigBadBish, when a fix is available it should be pushed out automatically, probably through Google Play. I don't know if there is anywhere to subscribe for updates on that, but there's a reasonable chance updates will be mentioned on this forum and maybe even in this thread.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70078 answers

As pointed out elsewhere, this settings change creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation. This would be added to the above:

(4) In the search box above the list, type or paste autoup and pause while the list is filtered

(5) Tap the extensions.update.autoUpdateDefault preference to show a Toggle button, then tap Toggle to switch the value from true to false

Hopefully this won't be needed for very long.

As pointed out elsewhere, this settings change creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation. This would be added to the above: (4) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (5) Tap the '''extensions.update.autoUpdateDefault''' preference to show a Toggle button, then tap Toggle to switch the value from true to false Hopefully this won't be needed for very long.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.