X
Tap here to go to the mobile version of the site.

Support Forum

Download Pop-Up Despite Setting Auto Action

Posted

The "Do this automatically for files like this from now on." option is not working.

What I expect to happen: Click on (e.g.) a PDF link to download. The pop-up dialogue box appears asking "What should Firefox do with this file?", including two radio buttons "Open with" and "Save File" and a checkbox for "Do this automatically for files like this from now on.". I choose "Open with" and select "Adobe Acrobat Reader DC (default)" from the adjacent drop-down menu. I also tick the checkbox to "Do this automatically for like this from now on." From now on I expect to click a PDF download link and for Adobe Acrobat to open and display the document.

What actually happens: The pop-up dialogue box appears again, albeit with the setting I had selected previously.

I'm assuming my expectation is correct - why would I want to see the pop-up again if I've set a default action.

I would be grateful for any advice; including whether Firefox does the same for others (i.e. is it just me).

Thanks

The "Do this automatically for files like this from now on." option is not working. What I expect to happen: Click on (e.g.) a PDF link to download. The pop-up dialogue box appears asking "What should Firefox do with this file?", including two radio buttons "Open with" and "Save File" and a checkbox for "Do this automatically for files like this from now on.". I choose "Open with" and select "Adobe Acrobat Reader DC (default)" from the adjacent drop-down menu. I also tick the checkbox to "Do this automatically for like this from now on." From now on I expect to click a PDF download link and for Adobe Acrobat to open and display the document. What actually happens: The pop-up dialogue box appears again, albeit with the setting I had selected previously. I'm assuming my expectation is correct - why would I want to see the pop-up again if I've set a default action. I would be grateful for any advice; including whether Firefox does the same for others (i.e. is it just me). Thanks

Chosen solution

By the way, this is the setting I was referring to on the Options page, Applications section:

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8427 solutions 68762 answers

Helpful Reply

Sometimes this is a Firefox settings file problem: the file which stores download actions can't be updated or becomes corrupted with nonsensical values. You can dump the current file and have Firefox build a new one. Steps below.

Sometimes this is a website problem: the server sends a generic Content-Type indicating it is a binary file. Firefox doesn't associate a specific action with that generic indicator. Assuming it isn't your server, a potential workaround would be to use an add-on. Details below.

Triggering a Rebuild of handlers.json

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, you can remove it.

Start Firefox back up again. Any improvement?

Workaround for General or Wrong Content-Type

I created an extension which recognizes common file extensions like .pdf, .xlsx and .zip and assigns "correct" Content-Type headers to them. It also lets you assign content types to more exotic file extensions. If you want to give it a try:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

When you first it install it, the extension is snoozing (Zzzz button). Click the button to turn it on. From that point, all .pdf files should be associated with the proper Content-Type, which is "application/pdf". Then Firefox should apply the behavior assigned on the Options page.

Any improvement?

Since the extension intercepts all page requests and downloads, it can slightly slow down browsing, so I suggest snoozing it until you find a site where you need it.

Sometimes this is a Firefox settings file problem: the file which stores download actions can't be updated or becomes corrupted with nonsensical values. You can dump the current file and have Firefox build a new one. Steps below. Sometimes this is a website problem: the server sends a generic Content-Type indicating it is a binary file. Firefox doesn't associate a specific action with that generic indicator. Assuming it isn't your server, a potential workaround would be to use an add-on. Details below. '''''Triggering a Rebuild of handlers.json''''' Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit/Quit * (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then rename '''handlers.json''' to something like '''handlersOLD.json'''. If you see a file named '''mimeTypes.rdf''', you can remove it. Start Firefox back up again. Any improvement? '''''Workaround for General or Wrong Content-Type''''' I created an extension which recognizes common file extensions like .pdf, .xlsx and .zip and assigns "correct" Content-Type headers to them. It also lets you assign content types to more exotic file extensions. If you want to give it a try: https://addons.mozilla.org/firefox/addon/content-type-fixer/ When you first it install it, the extension is snoozing (Zzzz button). Click the button to turn it on. From that point, all .pdf files should be associated with the proper Content-Type, which is "application/pdf". Then Firefox should apply the behavior assigned on the Options page. Any improvement? Since the extension intercepts all page requests and downloads, it can slightly slow down browsing, so I suggest snoozing it until you find a site where you need it.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8427 solutions 68762 answers

Chosen Solution

By the way, this is the setting I was referring to on the Options page, Applications section:

By the way, this is the setting I was referring to on the Options page, Applications section: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-04-27-14-21-02-72ae55.png" width="500">
Was this helpful to you?
Quote

Question owner

It worked! Thank you!

It worked! Thank you!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.