Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Connection not secure" message on Firefox for MAC - issue on subpages of my website

  • 3 replies
  • 1 has this problem
  • 53 views
  • Last reply by gaetano77

more options

Good morning,

I'm the owner of the following website: horbiter.com

In the last few days each time I surf my website's subpages like this one, for example:

https://www.horbiter.com/patek-philippe-nautilus-5726-1a-014-recensioni-orologi/

I get a non-secure connection message back. It is quite strange since the https certificate is correctly installed.

Moreover, for your further information, I get this message while using Firefox on Mac, weheras everything is working correctly on Firefox for Windows.

Please find enclosed a print screen of the page cited above too.

I look forward to your feedback

Kind regards Gaetano Cimmino

Chosen solution

A certificate check shows some problems with a second certificate that might be used for client that do not support SNI. The second certificate has expired years ago, so maybe look into this.

This website uses the "Let's Encrypt Authority X3" intermediate certificate. There might be a problem with this certificate and you can try to remove it in the Certificate Manager under the "Authorities" tab (labeled as "Software Security Device").

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates

If you can't find this certificate then try to rename the cert9.db (cert9.db.old) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has stored. Note that current Firefox releases use a cert9.db SQLite database file.

If that has helped to solve the problem then you can remove the renamed cert9.db.old file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

Read this answer in context 👍 1

All Replies (3)

more options
more options

Chosen Solution

A certificate check shows some problems with a second certificate that might be used for client that do not support SNI. The second certificate has expired years ago, so maybe look into this.

This website uses the "Let's Encrypt Authority X3" intermediate certificate. There might be a problem with this certificate and you can try to remove it in the Certificate Manager under the "Authorities" tab (labeled as "Software Security Device").

  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates

If you can't find this certificate then try to rename the cert9.db (cert9.db.old) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has stored. Note that current Firefox releases use a cert9.db SQLite database file.

If that has helped to solve the problem then you can remove the renamed cert9.db.old file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

more options

Many thanks

Gaetano