X
Tap here to go to the mobile version of the site.

Support Forum

Failed to read the configuration file - FireFox ESR

Posted

Hi, using the latest FireFox ESR I cannot get this customization to work. The error is "Failed to read the configuration file"

The file is:

//Firefox Default Settings

// set Firefox Default homepage pref("browser.startup.homepage","http://www.google.co.uk/”);

// disable default browser check pref("browser.shell.checkDefaultBrowser", false); pref("browser.startup.homepage_override.mstone”, “ignore”);

// disable application updates pref("app.update.auto", false) pref("app.update.enabled", false)

// disables the ‘know your rights’ button from displaying on first run pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true);

// disable history, download, cache, password and settings pref("browser.privatebrowsing.autostart", true)

// clear cookies pref("privacy.clearOnShutdown.cookies", true)

This has worked before, using the local-settings.js this file is:

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

Any ideas?

Alex

Hi, using the latest FireFox ESR I cannot get this customization to work. The error is "Failed to read the configuration file" The file is: //Firefox Default Settings // set Firefox Default homepage pref("browser.startup.homepage","http://www.google.co.uk/”); // disable default browser check pref("browser.shell.checkDefaultBrowser", false); pref("browser.startup.homepage_override.mstone”, “ignore”); // disable application updates pref("app.update.auto", false) pref("app.update.enabled", false) // disables the ‘know your rights’ button from displaying on first run pref("browser.rights.3.shown", true); // disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true); // disable history, download, cache, password and settings pref("browser.privatebrowsing.autostart", true) // clear cookies pref("privacy.clearOnShutdown.cookies", true) This has worked before, using the local-settings.js this file is: pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); Any ideas? Alex

Chosen solution

Where is the mozilla.cfg file located?

The mozilla.cfg file should be in the main Firefox program folder and not in the same folder as local-settings.js

Also make sure mozilla.cfg is a plain text file and doesn't have a hidden .txt file extension.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

If you take a look at these lines then yo notice wrong quotation marks. Only the first is a ", the others are Unicode quotes (“ and ”) and this throws an exception.

  • pref("browser.startup.homepage","http://www.google.co.uk/);
  • pref("browser.startup.homepage_override.mstone, ignore);

Some lines lack a trailing ';'.

Note that app.update.enabled is no longer supported in Firefox 63+, there is only app.update.auto left (bug 1420514).

//Firefox Default Settings

// set Firefox Default homepage
pref("browser.startup.homepage","http://www.google.co.uk/");

// disable default browser check
pref("browser.shell.checkDefaultBrowser", false);
pref("browser.startup.homepage_override.mstone", "ignore");

// disable application updates
pref("app.update.auto", false);
pref("app.update.enabled", false);

// disables the ‘know your rights’ button from displaying on first run
pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying
pref("toolkit.telemetry.prompted", 2);
pref("toolkit.telemetry.rejected", true);

// disable history, download, cache, password and settings
pref("browser.privatebrowsing.autostart", true);

// clear cookies
pref("privacy.clearOnShutdown.cookies", true);
If you take a look at these lines then yo notice wrong quotation marks. Only the first is a ", the others are Unicode quotes (&amp;#x201c; and &amp;#x201d;) and this throws an exception. *pref("browser.startup.homepage","http://www.google.co.uk/<u>”</u>); *pref("browser.startup.homepage_override.mstone<u>”</u>, <u>“</u>ignore<u>”</u>); Some lines lack a trailing ';'. Note that app.update.enabled is no longer supported in Firefox 63+, there is only app.update.auto left (bug 1420514). <pre><nowiki>//Firefox Default Settings // set Firefox Default homepage pref("browser.startup.homepage","http://www.google.co.uk/"); // disable default browser check pref("browser.shell.checkDefaultBrowser", false); pref("browser.startup.homepage_override.mstone", "ignore"); // disable application updates pref("app.update.auto", false); pref("app.update.enabled", false); // disables the ‘know your rights’ button from displaying on first run pref("browser.rights.3.shown", true); // disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true); // disable history, download, cache, password and settings pref("browser.privatebrowsing.autostart", true); // clear cookies pref("privacy.clearOnShutdown.cookies", true);</nowiki></pre>
Was this helpful to you? 2
Quote

Question owner

cor-el said

If you take a look at these lines then yo notice wrong quotation marks. Only the first is a ", the others are Unicode quotes (&#x201c; and &#x201d;) and this throws an exception.
  • pref("browser.startup.homepage","http://www.google.co.uk/);
  • pref("browser.startup.homepage_override.mstone, ignore);
Some lines lack a trailing ';'. Note that app.update.enabled is no longer supported in Firefox 63+, there is only app.update.auto left (bug 1420514).
//Firefox Default Settings

// set Firefox Default homepage
pref("browser.startup.homepage","http://www.google.co.uk/");

// disable default browser check
pref("browser.shell.checkDefaultBrowser", false);
pref("browser.startup.homepage_override.mstone", "ignore");

// disable application updates
pref("app.update.auto", false);
pref("app.update.enabled", false);

// disables the ‘know your rights’ button from displaying on first run
pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying
pref("toolkit.telemetry.prompted", 2);
pref("toolkit.telemetry.rejected", true);

// disable history, download, cache, password and settings
pref("browser.privatebrowsing.autostart", true);

// clear cookies
pref("privacy.clearOnShutdown.cookies", true);


Thanks for your responce, I tried the config you posted and this also didn't work, and I had the same error message. If I delete my xxx file then I still get the error, only deleting the local-settings file does the problem go away.

My local-settings js file is:

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

If i delete this file then it works ok, but we would like to do the customization's. I checked the file permissions and they were ok. I am pretty stomped!

Thanks for your help, Merry Christmas!

''cor-el [[#answer-1183889|said]]'' <blockquote> If you take a look at these lines then yo notice wrong quotation marks. Only the first is a ", the others are Unicode quotes (&amp;#x201c; and &amp;#x201d;) and this throws an exception. *pref("browser.startup.homepage","http://www.google.co.uk/<u>”</u>); *pref("browser.startup.homepage_override.mstone<u>”</u>, <u>“</u>ignore<u>”</u>); Some lines lack a trailing ';'. Note that app.update.enabled is no longer supported in Firefox 63+, there is only app.update.auto left (bug 1420514). <pre><nowiki>//Firefox Default Settings // set Firefox Default homepage pref("browser.startup.homepage","http://www.google.co.uk/"); // disable default browser check pref("browser.shell.checkDefaultBrowser", false); pref("browser.startup.homepage_override.mstone", "ignore"); // disable application updates pref("app.update.auto", false); pref("app.update.enabled", false); // disables the ‘know your rights’ button from displaying on first run pref("browser.rights.3.shown", true); // disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true); // disable history, download, cache, password and settings pref("browser.privatebrowsing.autostart", true); // clear cookies pref("privacy.clearOnShutdown.cookies", true);</nowiki></pre> </blockquote> Thanks for your responce, I tried the config you posted and this also didn't work, and I had the same error message. If I delete my xxx file then I still get the error, only deleting the local-settings file does the problem go away. My local-settings js file is: pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); If i delete this file then it works ok, but we would like to do the customization's. I checked the file permissions and they were ok. I am pretty stomped! Thanks for your help, Merry Christmas!
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

Chosen Solution

Where is the mozilla.cfg file located?

The mozilla.cfg file should be in the main Firefox program folder and not in the same folder as local-settings.js

Also make sure mozilla.cfg is a plain text file and doesn't have a hidden .txt file extension.

Where is the mozilla.cfg file located? The mozilla.cfg file should be in the main Firefox program folder and not in the same folder as local-settings.js Also make sure mozilla.cfg is a plain text file and doesn't have a hidden .txt file extension.
Was this helpful to you? 1
Quote

Question owner

cor-el said

The mozilla.cfg file should be in the main Firefox program folder and not in the same folder as local-settings.js

This was the issue! Thank you very much for your help, I greatly appreciate it. Thanks again,

Alexander

''cor-el [[#answer-1184033|said]]'' <blockquote> The mozilla.cfg file should be in the main Firefox program folder and not in the same folder as local-settings.js </blockquote> This was the issue! Thank you very much for your help, I greatly appreciate it. Thanks again, Alexander
Was this helpful to you? 0
Quote
MrToad 0 solutions 9 answers

When I started Firefox, the "failed to read the configuration file" msg popped up, I clicked OK, then Firefox loaded ok. I searched for non-standard .js files in the mozilla firefox subdirectory and found antibeacon.js in addition to the channel-prefs.js that's supposed to be there. That file is part of spybot antibeacon that's supposed to block primarily microsoft spying. Anyway, I moved that antibeacon.js file and when I next started firefox, no error msg appeared. Unfortunately when when I applied antibeacon protections, the file reappeared, Since antibeacon reapplies at startup this may be an ongoing annoyance.

When I started Firefox, the "failed to read the configuration file" msg popped up, I clicked OK, then Firefox loaded ok. I searched for non-standard .js files in the mozilla firefox subdirectory and found antibeacon.js in addition to the channel-prefs.js that's supposed to be there. That file is part of spybot antibeacon that's supposed to block primarily microsoft spying. Anyway, I moved that antibeacon.js file and when I next started firefox, no error msg appeared. Unfortunately when when I applied antibeacon protections, the file reappeared, Since antibeacon reapplies at startup this may be an ongoing annoyance.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17172 solutions 155209 answers

If your problem is caused by Spybot then you need to contact them for support. It is likely that this file is no longer compatible with Firefox.

You can check the Browser Console for more detail about what is wrong.

If your problem is caused by Spybot then you need to contact them for support. It is likely that this file is no longer compatible with Firefox. You can check the Browser Console for more detail about what is wrong. *https://developer.mozilla.org/en-US/Tools/Browser_Console
Was this helpful to you? 1
Quote
MrToad 0 solutions 9 answers

Per your suggestion, I reported the problem to spybot. Here's a link to that thread in case others want to pursue it. * https://support.mozilla.org/en-US/questions/1244793#answer-1184625

The issue appears to affect the 64bit version of firefox, but a brief experiment with an n=3 shows that 32-bit firefox opens without the "failed to read the configuration file" msg and there was no antibeacon.js file in the Mozilla Firefox x86 directory which is used by 32bit firefox.

Per your suggestion, I reported the problem to spybot. Here's a link to that thread in case others want to pursue it. * https://support.mozilla.org/en-US/questions/1244793#answer-1184625 The issue appears to affect the 64bit version of firefox, but a brief experiment with an n=3 shows that 32-bit firefox opens without the "failed to read the configuration file" msg and there was no antibeacon.js file in the Mozilla Firefox x86 directory which is used by 32bit firefox.

Modified by MrToad

Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.