X
Tap here to go to the mobile version of the site.

Support Forum

Font Issues on Thunderbird 60.2.1 for Linux Mint

Posted

I upgraded to Thunderbird 60.2.1 on Linux Mint and I'm having some trouble with fonts.

The first problem was that the size of fonts in my sent/received emails became much larger. I had it set to 14 but it looked like it was 16. Changing the font size under Preferences -> Display -> Default font -> Size had no effect, and the font size remained the same size whatever I set it to. Checking in the Config Editor I found the setting that changed by Default font -> Size is font.size.variable.x-western. After messing around for a while I tried changing font.size.variable.x-unicode and found this is what changes the font size in sent/received emails. It therefore seems that Thunderbird 60 is now using the x-unicode font while the Default font -> Size settings are still changing the x-western font. Is this a bug or has something gone wrong on my system?

The second issue I have is that many emojis are now showing as the simple monochrome versions instead of the full colour versions, so there seems to be another font issue. Looking at the values of font.name.sans-serif.x-western and font.name.sans-serif.x-unicode I found both of them are set to the default and that the Value box is empty. Checking another machine that still had Thunderbird 52.9.1 on I found that font.name.sans-serif.x-western and font.name.sans-serif.x-unicode where also set to the default on that, but the Value box contained sans-serif. I tried setting the two values manually to sans-serif on Thunderbird 60.2.1 but emojis continued not to display correctly. I also looked what font Firefox uses, since emojis display correctly in that, and found it uses DejaVu Serif. Out of interest I tried setting font.name.sans-serif.x-unicode to DejaVu Serif, but while the appearance of the font changed to a serif font, many emojis remained monochrome. What's the best way to get emojis displaying correctly in Thuderbird 60 on Linux?

Thanks for any advice you can offer.

I upgraded to Thunderbird 60.2.1 on Linux Mint and I'm having some trouble with fonts. The first problem was that the size of fonts in my sent/received emails became much larger. I had it set to 14 but it looked like it was 16. Changing the font size under Preferences -> Display -> Default font -> Size had no effect, and the font size remained the same size whatever I set it to. Checking in the Config Editor I found the setting that changed by Default font -> Size is font.size.variable.x-western. After messing around for a while I tried changing font.size.variable.x-unicode and found this is what changes the font size in sent/received emails. It therefore seems that Thunderbird 60 is now using the x-unicode font while the Default font -> Size settings are still changing the x-western font. Is this a bug or has something gone wrong on my system? The second issue I have is that many emojis are now showing as the simple monochrome versions instead of the full colour versions, so there seems to be another font issue. Looking at the values of font.name.sans-serif.x-western and font.name.sans-serif.x-unicode I found both of them are set to the default and that the Value box is empty. Checking another machine that still had Thunderbird 52.9.1 on I found that font.name.sans-serif.x-western and font.name.sans-serif.x-unicode where also set to the default on that, but the Value box contained sans-serif. I tried setting the two values manually to sans-serif on Thunderbird 60.2.1 but emojis continued not to display correctly. I also looked what font Firefox uses, since emojis display correctly in that, and found it uses DejaVu Serif. Out of interest I tried setting font.name.sans-serif.x-unicode to DejaVu Serif, but while the appearance of the font changed to a serif font, many emojis remained monochrome. What's the best way to get emojis displaying correctly in Thuderbird 60 on Linux? Thanks for any advice you can offer.

Chosen solution

For the font sizes, open Pref./Display/Formatting/Fonts & Colors, click the Advanced button, and set the fonts and sizes for Latin and Other Writing Systems:

https://support.mozilla.org/en-US/questions/1239826

For the emoji question, see if this discussion helps:

https://ubuntuforums.org/showthread.php?t=2390875

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

sfhowes
  • Top 10 Contributor
1438 solutions 6814 answers

Chosen Solution

For the font sizes, open Pref./Display/Formatting/Fonts & Colors, click the Advanced button, and set the fonts and sizes for Latin and Other Writing Systems:

https://support.mozilla.org/en-US/questions/1239826

For the emoji question, see if this discussion helps:

https://ubuntuforums.org/showthread.php?t=2390875

For the font sizes, open Pref./Display/Formatting/Fonts & Colors, click the Advanced button, and set the fonts and sizes for Latin and Other Writing Systems: https://support.mozilla.org/en-US/questions/1239826 For the emoji question, see if this discussion helps: https://ubuntuforums.org/showthread.php?t=2390875

Question owner

Thanks, I didn't think to change the "Other Writing System" font size. Since my system is set to English UK I thought Latin was the one to change. It was a bit confusing that Preferences -> Display -> Default font -> Size didn't change the size, but as long as I know how to do it, that's great.

As for the Emojis, the last post linked in the forum answered the question:

https://askubuntu.com/questions/1030609/ubuntu-18-04-fresh-installation-thunderbird-inbox-invaded-by-large-icons-col/1030634#1030634

The Emojis are in full colour now. Thanks a lot for the help.

Thanks, I didn't think to change the "Other Writing System" font size. Since my system is set to English UK I thought Latin was the one to change. It was a bit confusing that Preferences -> Display -> Default font -> Size didn't change the size, but as long as I know how to do it, that's great. As for the Emojis, the last post linked in the forum answered the question: https://askubuntu.com/questions/1030609/ubuntu-18-04-fresh-installation-thunderbird-inbox-invaded-by-large-icons-col/1030634#1030634 The Emojis are in full colour now. Thanks a lot for the help.