X
Tap here to go to the mobile version of the site.

Support Forum

Firefox adds "www." in front of url which causes problems

Posted

For example I want to visit "http://3g2upl4pq6kufc4m.onion/" and type that in the URL bar. Firefox adds "www." in front of it (after "http://") which becomes an invalid url. With DuckDuckGo browser it doesn't add "www." so it loads fine. How to visit this .onion site with Firefox? Shouldn't "www." not be added?

For example I want to visit "http://3g2upl4pq6kufc4m.onion/" and type that in the URL bar. Firefox adds "www." in front of it (after "http://") which becomes an invalid url. With DuckDuckGo browser it doesn't add "www." so it loads fine. How to visit this .onion site with Firefox? Shouldn't "www." not be added?

Chosen solution

Open about:config and search dotonion. Change network.dns.blockDotOnion to false.

But keep in mind, that this option is there to prevent any unsafe websites or data leaks.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 6.0.1; Mobile; rv:62.0) Gecko/62.0 Firefox/62.0

More Information

Erecik 2 solutions 9 answers

Chosen Solution

Open about:config and search dotonion. Change network.dns.blockDotOnion to false.

But keep in mind, that this option is there to prevent any unsafe websites or data leaks.

Open'' about:config'' and search ''dotonion''. Change ''network.dns.blockDotOnion'' to false. But keep in mind, that this option is there to prevent any unsafe websites or data leaks.

Modified by Erecik

Was this helpful to you? 1
Quote

Helpful Reply

Thank you!

Thank you!
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.