X
Tap here to go to the mobile version of the site.

Support Forum

Firefox for Android doesn't load webassembly

Posted

I'm programming a webassembly site (http://ictz.net) with .Net Core & Blazor.net.

It does load in Firefox for Windows not in Firefox for Android, on my mobile phone & tablet.

It does in other browsers for Android.

I'm programming a webassembly site (http://ictz.net) with .Net Core & Blazor.net. It does load in Firefox for Windows not in Firefox for Android, on my mobile phone & tablet. It does in other browsers for Android.
Attached screenshots

Modified by Jaap

Chosen solution

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758

Let's wait, what devs say about it.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
746 solutions 5447 answers

Hi

This does not sound like an issue with Firefox for Android, but more like a web development query. I would recomend asking about this issue at https://stackoverflow.com/.

Hi This does not sound like an issue with Firefox for Android, but more like a web development query. I would recomend asking about this issue at [https://stackoverflow.com/ https://stackoverflow.com/].

Question owner

You think?

Why?

You think? Why?

Question owner

Blazor works in Firefox for Windows. Blazor works in other mobile browsers

Blazor doesn't work in Firefox for Android.

That's why I come here first.

"Sounds like"? Well, it sounds like a Firefox for Android problem to me. But hey, that's me. And I'm #nobody.

Blazor works in Firefox for Windows. Blazor works in other mobile browsers Blazor doesn't work in Firefox for Android. That's why I come here first. "Sounds like"? Well, it sounds like a Firefox for Android problem to me. But hey, that's me. And I'm #nobody.

Question owner

But then again, if no 'Firefoxer' is listening here, I wasted my time here.

But then again, if no 'Firefoxer' is listening here, I wasted my time here.

Question owner

Oh, and one more thing: where it works and where it doesn't work was stated in my initial post here.

I really don't like to repeat myself.

Oh, and one more thing: where it works and where it doesn't work was stated in my initial post here. I really don't like to repeat myself.

Question owner

"Sounds like" ... With no further explanation whatsoever.

Yeah right!

"Sounds like" ... With no further explanation whatsoever. Yeah right!
Seburo
  • Top 10 Contributor
  • Moderator
746 solutions 5447 answers

Hi

I have seen similar issues to this in the past causing errors due to the site and not Firefox for Android. The experts at Stackoverflow should be able to help you with this.

Hi I have seen similar issues to this in the past causing errors due to the site and not Firefox for Android. The experts at Stackoverflow should be able to help you with this.

Question owner

Similar issues? Really?

Why don't I believe you ...

https://www.google.com/search?q=firefox+android+webassembly+loading

Okay, this is a waste of my time.

Similar issues? Really? Why don't I believe you ... https://www.google.com/search?q=firefox+android+webassembly+loading Okay, this is a waste of my time.

Question owner

Just Remember this: "webassembly" & "firefox for android"

Hell, see if I care.

Just Remember this: "webassembly" & "firefox for android" Hell, see if I care.
Seburo
  • Top 10 Contributor
  • Moderator
746 solutions 5447 answers

Hi

I am not sugguesting that Firefox for Android has a problem with WebAssemby, but it might be a per site issue that needs to be rectified.

Hi I am not sugguesting that Firefox for Android has a problem with WebAssemby, but it might be a per site issue that needs to be rectified.

Question owner

I AM suggesting that it (ffa) has a problem with webassembly.

That's why I posted the issue here, and _not_ on stackoverflow.

Found _any_ similar issues already? Or does it still sounds like a website problem to you?

Do you actually have any clue why I posted it here? Any experience with webassembly?

I AM suggesting that it (ffa) has a problem with webassembly. That's why I posted the issue here, and _not_ on stackoverflow. Found _any_ similar issues already? Or does it still sounds like a website problem to you? Do you actually have any clue why I posted it here? Any experience with webassembly?

Question owner

FYI:

It's not my code.

Perhaps it's the .Net Core Blazor webassembly compiler OR Firefox for Android has a problem with (compiled) Blazor webassembly. And there isn't such a thing as Blazor webassembly, Blazor websassembly = webassembly. Compiled binary code which runs in _all_ browsers.

The site runs in Firefox for Windows. And that's the _only_ reason I first posted a message about it here. You could think the webassembly engines would be the same. At least, that's is what I'm thinking.

At last, it could even be a problem with the platform it runs on (Ubuntu) or the webserver I'm using (Kestrel), but still, it runs perfectly in Firefox for Windows. Alas, my question here.

It's great if you try to help, but if you do not understand my question it's not very helpful.

And that's why "sounds like" & "similar issues" aren't helpful at all.

FYI: It's not my code. Perhaps it's the .Net Core Blazor webassembly compiler OR Firefox for Android has a problem with (compiled) Blazor webassembly. And there isn't such a thing as Blazor webassembly, Blazor websassembly = webassembly. Compiled binary code which runs in _all_ browsers. The site runs in Firefox for Windows. And that's the _only_ reason I first posted a message about it here. You could think the webassembly engines would be the same. At least, that's is what I'm thinking. At last, it could even be a problem with the platform it runs on (Ubuntu) or the webserver I'm using (Kestrel), but still, it runs perfectly in Firefox for Windows. Alas, my question here. It's great if you try to help, but if you do not understand my question it's not very helpful. And that's why "sounds like" & "similar issues" aren't helpful at all.

Question owner

Just installed Firefox Focus (Android) and guess what ..

It runs in Firefox Focus.

Sounds like a Firefox (for Android) problem to me.

Hello? Anyone?

Just installed Firefox Focus (Android) and guess what .. It runs in Firefox Focus. Sounds like a Firefox (for Android) problem to me. Hello? Anyone?

Question owner

Screenshot (Firefox Focus)

Screenshot (Firefox Focus)
TyDraniu
  • Top 25 Contributor
310 solutions 1728 answers

Chosen Solution

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758

Let's wait, what devs say about it.

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

Question owner

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

Thank you!

I thought the devs were monitoring this forum as well, didn't yet know about 'bugzilla'.

''TyDraniu [[#answer-1151384|said]]'' <blockquote> This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it. </blockquote> Thank you! I thought the devs were monitoring this forum as well, didn't yet know about 'bugzilla'.

Question owner

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android.

I've uploaded another screenshot with the Focus result, see above.

''TyDraniu [[#answer-1151384|said]]'' <blockquote> This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it. </blockquote> FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android. I've uploaded another screenshot with the Focus result, see above.

Modified by Jaap

TyDraniu
  • Top 25 Contributor
310 solutions 1728 answers

Helpful Reply

FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android.

I know, but this is a chromium/blink engine.

I thought the devs were monitoring this forum as well

No, not really.

<blockquote> FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android. </blockquote> I know, but this is a chromium/blink engine. <blockquote> I thought the devs were monitoring this forum as well </blockquote> No, not really.

Question owner

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

Thank you so much for your answer TyDraniu, and for posting it at Bugzilla. Somebody else encountered the same problem, just 4 days ago, and Firefox devs at Bugzilla are picking it up.

Thanks again.

''TyDraniu [[#answer-1151384|said]]'' <blockquote> This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it. </blockquote> Thank you so much for your answer TyDraniu, and for posting it at Bugzilla. Somebody else encountered the same problem, just 4 days ago, and Firefox devs at Bugzilla are picking it up. Thanks again.