Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I erase SOME of the auto-fill email addresses?

  • 1 reply
  • 1 has this problem
  • 723 views
  • Last reply by MDR

more options

I am having a bizarre problem: I have been noticing that whenever I visit some web sites in which I can or need to enter an email address I am given a list of auto fill email addresses to choose. Along with my known email addresses there are few that are unfamiliar and unwanted. I am unsure how to eliminate the unwanted ibes and ONLY THE UNWANTED ONES (meeaning I wish to keep the known email addresses while erasing the unknown ones). I have a Firefox account which I sync to 3 devices: 2 Windows 10 PC's and one Android phone. I also use an Amazon Fire stick as well which I guess makes 4 devices in total. Any advice is greatly appreciated.

Chosen solution

Well, I seem to have been able to answer my own question....sort of:

While doing further research on how to correct this information I stumbled upon the following information in the Mozilla help pages:


Deleting individual form entries

If you want to remove one of your previous form entries from Firefox's history:

   Click on the form field and press the ↓ key to display all the saved entries. You may type the first few letters of the entry to limit the number of entries displayed.
   Use the ↓ key or the mouse pointer to highlight the entry you wish to delete.
   Press Delete. The entry will be removed. 

Repeat the process for each entry that you'd like to delete.


Unfortunately, pressing the down arrow key didn't yield these results for me - but I admit it's possible I was doing something wrong. But I did manage to finally rid myself of the unwanted email addresses from appearing by going to options>privacy & security>clear history> I set the time range to clear to "EVERYTHING" and made sure to ONLY check the box for FORM AND SEARCH HISTORY (and ONLY for FORM AND SEARCH HISTORY) and then clicked CLEAR NOW. That resolved my problem although I will have to re-enter my email address(es) in other web pages which I don't mind redoing - this is, for me, preferable over seeing those unwanted and unfamiliar web addresses that kept popping up.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Well, I seem to have been able to answer my own question....sort of:

While doing further research on how to correct this information I stumbled upon the following information in the Mozilla help pages:


Deleting individual form entries

If you want to remove one of your previous form entries from Firefox's history:

   Click on the form field and press the ↓ key to display all the saved entries. You may type the first few letters of the entry to limit the number of entries displayed.
   Use the ↓ key or the mouse pointer to highlight the entry you wish to delete.
   Press Delete. The entry will be removed. 

Repeat the process for each entry that you'd like to delete.


Unfortunately, pressing the down arrow key didn't yield these results for me - but I admit it's possible I was doing something wrong. But I did manage to finally rid myself of the unwanted email addresses from appearing by going to options>privacy & security>clear history> I set the time range to clear to "EVERYTHING" and made sure to ONLY check the box for FORM AND SEARCH HISTORY (and ONLY for FORM AND SEARCH HISTORY) and then clicked CLEAR NOW. That resolved my problem although I will have to re-enter my email address(es) in other web pages which I don't mind redoing - this is, for me, preferable over seeing those unwanted and unfamiliar web addresses that kept popping up.