Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox continues to refuse to show google.com

  • 10 replies
  • 1 has this problem
  • 95 views
  • Last reply by Murphy

more options

Yesterday, for some reason, Firefox would not open. At all. I downloaded and installed the latest version and since then I cannot open google.com or google.nl. I keep getting this error: SEC_ERROR_UNKNOWN_ISSUER

I have tried the instructions with regards to renewing certificates for my AV, but that did not yield a lasting solution. After I rebooted, FF would open google.nl but some 20 or 30 minutes later, FF would give the same error again....

I am drowning in an overload of useless information on the FF forums. I am at my wits end and about to give up on FF altogether and switch to Chrome or even IE (yeah, I'm THAT desperate atm) . And on top of all this, just as I was typing this text and trying to copy-paste the extra info (see down below), FF decided to close this particular tab... FML.. SMH

I used to love FF but now my feelings are about to make a 180 degree turn towards the negative... Can someone please help me without linking me to 16 different pages with confusing and useless info? Thanks in advance!



https://www.google.nl/

Uitgever van certificaat van peer wordt niet herkend.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificaatketen:


BEGIN CERTIFICATE-----

MIIDiDCCAnCgAwIBAgINAN4gbRlkp1dydEw6wzANBgkqhkiG9w0BAQsFADBUMRkw FwYDVQQKDBBBTyBLYXNwZXJza3kgTGFiMTcwNQYDVQQDDC5LYXNwZXJza3kgQW50 aS1WaXJ1cyBQZXJzb25hbCBSb290IENlcnRpZmljYXRlMB4XDTE4MDQxNzEzMzcx NloXDTE4MDcxMDEyMzkwMFowZTELMAkGA1UEBhMCVVMxEzARBgNVBAgMCkNhbGlm b3JuaWExFjAUBgNVBAcMDU1vdW50YWluIFZpZXcxEzARBgNVBAoMCkdvb2dsZSBJ bmMxFDASBgNVBAMMCyouZ29vZ2xlLm5sMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8A MIIBCgKCAQEAlrNpZwhARc/gAXyfBk59zS64L4ZACLO6RYYEHNDr2e3kDUHJDzCH XEGjNWIxO70bg4o/9AnDFD1lgjlyoiGhbdF+R6cLQ1AtKaaE/21n5fQOUPYYrCbb bufJ8X9/4GtkNKy1Xo35FnOpwzgbyWiFMFoFMW+HnB+li+bQcSEcljdTFnOXbJyU Dmx2LT99YYUBdv1q7nBXu4rEB1iSeER+JZwe9Knb4blVvTTj3bMyjw5SjX7iqSgx jOkiQNc9Odhjr6ab6bCHZBa2bOvxNJ07lmwvyub/8FoOFV+KTo6emT5ee+8+Kx7l P0b8iywbBRKtrJWUp/hoXxuRNCKLqnQidwIDAQABo0gwRjAhBgNVHREEGjAYggsq Lmdvb2dsZS5ubIIJZ29vZ2xlLm5sMAwGA1UdEwEB/wQCMAAwEwYDVR0lBAwwCgYI KwYBBQUHAwEwDQYJKoZIhvcNAQELBQADggEBAHa2y4r+wopp4gDLCAx+urepd3C3 ECgwy98YzXMaCI+JreOtd2LYb3xrk0Do0aV4Mx4mloz4/F+3gAowD77Zd1teB1og JR2S0+ws1DrgqG33NRfCHaxoGQz6OVPEZKvDEEo5q4j0bfUuQKXZ7UfQi2W3EX/W SS5fnaJ2xGliKTfC/mEQJrfIF9VUBLSmcRPj5+9qUlCQH0tTwGFgb9fxiGV+Q7+I 5/rQlxoa/dtG1ISJEXbk9HIIg+sjKr3V9zWE4rlqXmzb/shDMqghf6BuqFD6l2NC FJStvpr+dvOG4sZVjYLiH5ddNcyZap4+F9YGh7opQg4Ebc1iwOL/dpUalNk=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIDPjCCAiagAwIBAgIJAPK1T1dmrjK1MA0GCSqGSIb3DQEBCwUAMFQxGTAXBgNV BAoMEEFPIEthc3BlcnNreSBMYWIxNzA1BgNVBAMMLkthc3BlcnNreSBBbnRpLVZp cnVzIFBlcnNvbmFsIFJvb3QgQ2VydGlmaWNhdGUwHhcNMTYwNjAyMDQyODM0WhcN MjYwNTMxMDQyODM0WjBUMRkwFwYDVQQKDBBBTyBLYXNwZXJza3kgTGFiMTcwNQYD VQQDDC5LYXNwZXJza3kgQW50aS1WaXJ1cyBQZXJzb25hbCBSb290IENlcnRpZmlj YXRlMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAlrNpZwhARc/gAXyf Bk59zS64L4ZACLO6RYYEHNDr2e3kDUHJDzCHXEGjNWIxO70bg4o/9AnDFD1lgjly oiGhbdF+R6cLQ1AtKaaE/21n5fQOUPYYrCbbbufJ8X9/4GtkNKy1Xo35FnOpwzgb yWiFMFoFMW+HnB+li+bQcSEcljdTFnOXbJyUDmx2LT99YYUBdv1q7nBXu4rEB1iS eER+JZwe9Knb4blVvTTj3bMyjw5SjX7iqSgxjOkiQNc9Odhjr6ab6bCHZBa2bOvx NJ07lmwvyub/8FoOFV+KTo6emT5ee+8+Kx7lP0b8iywbBRKtrJWUp/hoXxuRNCKL qnQidwIDAQABoxMwETAPBgNVHRMBAf8EBTADAQH/MA0GCSqGSIb3DQEBCwUAA4IB AQA+BN9OwTsjlBcmrPnlRSiTXpIpF4GsjW0C0/nJOsOCioFlNh37v6BLV1O0pX7m Z+OCnGEBVr4AIDFcLZ3G4ta315Q9Rw2ympVH9uIVUTZr9OdLivzA8gMsus0P9VnH +nmYXOdYjnPr8MLQH/U0nu0Qum0gTjetNxTVrtofIcuLEmisthhiJLaUKBiO3D5B beBE7u4fdbb7qLK32GzeSTAa89bTlfuLPf2Vs4/UQq0cAt8rIgzlie/bzAmnWuud xSOhLo7QTrajyYTnSqaZL4mCdLNlLYpvrWk11RI1iqmRqsqfkJqF0oaEEJh+OjKh IgovNVL5CKvoPe5YPyDtMPfO


END CERTIFICATE-----

Chosen solution

Note that the issuer of the certificate you posted above is your Kaspersky software.

Subject O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate
Issuer 	O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate

You will either have to disable this feature in Kaspersky or import the Kaspersky root certificate in the Firefox Certificate Manager and set the appropriate trust bit for website.

Read this answer in context 👍 2

All Replies (11)

more options

Hi, sorry having issues and yes it can get confusing as well as frustrating. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(Win10) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.3 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Did you make sure to disable SSL scanning in your AV product?

How to troubleshoot security error codes on secure websites

more options

Hmm... I was trying to quote but something went wrong...

Modified by ferryp

more options

Tonnes said

Did you make sure to disable SSL scanning in your AV product? How to troubleshoot security error codes on secure websites


Thanks for your response.

I have tried to to trigger a reinstallation of Kaspersky's certificate. That did not give a lasting solution.

I am NOT going to "not scan encrypted connections", because Kaspersky warns against it. It is needed for my online banking stuff. It really is NOT an option.

more options

Pkshadow said

Hi, sorry having issues and yes it can get confusing as well as frustrating. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(Win10) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 59.0.3 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

Thanks for your response, but this will not do for me.

It is too cumbersome for something of which I am not sure will be an adequate solution. Even you yourself are not sure it will be an adequate solution given the last line of your response.

I have a much quicker and easier solution: I'll switch to another browser.I will simply stop using FF.

I have not been content with FF performance since that last big update/upgrade where they claim FF to be quicker and more responsive than ever (which absolutely has not been the case for me). FF no longer provides me the user-friendly experience it promises.

Thanks for your help.

more options

ferryp said

Tonnes said
Did you make sure to disable SSL scanning in your AV product? How to troubleshoot security error codes on secure websites

Thanks for your response.

I have tried to to trigger a reinstallation of Kaspersky's certificate. That did not give a lasting solution.

I am NOT going to "not scan encrypted connections", because Kaspersky warns against it. It is needed for my online banking stuff. It really is NOT an option.

Well, now you know scanning SSL connections in the security product could very well be the culprit (as it is even documented and to be found all over the net), the least you could do is to temporarily try this while not logging in to your bank system. I would even uninstall the product entirely and reboot, then reinstall after the issue turned out to disappear. That would help you solving your question as well as others - there is no other solution.

Additionally, please accept that security software manufacturers always want their customers to fully use their products and features and blame anything else in case of issues, of course they do. Or users having purchased the product and think it’s sacred for some reason, either because they paid for it, or they think the cruel internet world will attack their system within a second even when not browsing. And looking at support questions here and elsewhere, those users are always the ones running into trouble related to connections and certificates.

Would you believe I never experience any certificate errors/issues, just because I don’t use any such product? My personal opinion is such software may have been required back in the days most users were connected to the internet in "bridged" mode, exposing their systems to the evil world all right. Ever since most are hardware-protected - and able to use brains a bit more - they no longer don’t. Security software products have become a marketing product, and sometimes bloated. I don’t want any piece of software to mess with my connection either, and Firefox is safe enough when using its own certificate store and security features. I wouldn’t have an additional 4-sided bumper construction mounted on my car just because I think all traffic is cruel and it costs money to do so, so to speak.

Also please accept this isn’t a matter of us and them. In most cases, Mozilla and AV product manufacturers actively work together in case of short-standing issues in order to fix them. In case of persistent issues or them being reluctant - something they tend to do more now there are more than 2 browsers - one should simply not use one of their features. And fwiw, switching to another browser (that doesn’t take security that serious) isn’t always the best solution, but Mozilla encourages free choice, so you’re free to do so.

more options

Tonnes said

ferryp said
Tonnes said
Did you make sure to disable SSL scanning in your AV product? How to troubleshoot security error codes on secure websites

Thanks for your response.

I have tried to to trigger a reinstallation of Kaspersky's certificate. That did not give a lasting solution.

I am NOT going to "not scan encrypted connections", because Kaspersky warns against it. It is needed for my online banking stuff. It really is NOT an option.

Well, now you know scanning SSL connections in the security product could very well be the culprit (as it is even documented and to be found all over the net), the least you could do is to temporarily try this while not logging in to your bank system. I would even uninstall the product entirely and reboot, then reinstall after the issue turned out to disappear. That would help you solving your question as well as others - there is no other solution.

Additionally, please accept that security software manufacturers always want their customers to fully use their products and features and blame anything else in case of issues, of course they do. Or users having purchased the product and think it’s sacred for some reason, either because they paid for it, or they think the cruel internet world will attack their system within a second even when not browsing. And looking at support questions here and elsewhere, those users are always the ones running into trouble related to connections and certificates.

Would you believe I never experience any certificate errors/issues, just because I don’t use any such product? My personal opinion is such software may have been required back in the days most users were connected to the internet in "bridged" mode, exposing their systems to the evil world all right. Ever since most are hardware-protected - and able to use brains a bit more - they no longer don’t. Security software products have become a marketing product, and sometimes bloated. I don’t want any piece of software to mess with my connection either, and Firefox is safe enough when using its own certificate store and security features. I wouldn’t have an additional 4-sided bumper construction mounted on my car just because I think all traffic is cruel and it costs money to do so, so to speak.

Also please accept this isn’t a matter of us and them. In most cases, Mozilla and AV product manufacturers actively work together in case of short-standing issues in order to fix them. In case of persistent issues or them being reluctant - something they tend to do more now there are more than 2 browsers - one should simply not use one of their features. And fwiw, switching to another browser (that doesn’t take security that serious) isn’t always the best solution, but Mozilla encourages free choice, so you’re free to do so.

Hi Tonnes,

Yesterday, after I posted my responses, I noticed my partner can use FF without any issues, so the problem clearly is NOT just something with SSL protection. I now suspect it has something to do with my profile getting messed up somehow. That happened before which I just accepted as part of the deal ("perhaps the worst deal in history of deals"). Back then I learned to live with the consequences, thinking it would be a one-time fluke.

3. I'd take advise on whether or not to use AV products from a friend of mine who works in IT (and who advised me to do so)

4. The advantage of having AV stuff is that I do not need to rely on just one browser. Like I wrote before: since the last overhaul FF has become slower and less responsive for me instead of what they promised. Add to that the not-so-userfriendly epxerience of messing up stuff for me but not for other users on the same PC, I'll just use another browser instead of jumping through burning hoops and no longer being able to use the secure online banking facilities that have been advised by my bank; and no, they did not advise that particular product but they provided a list of several brands which included my AV product, which was also advised by that friend I mentioned.

I thank you for your time.

I'd highly appreciate it if you would no longer contribute to this thread. Please, do not respond any more.

[Personal attack removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

more options

Chosen Solution

Note that the issuer of the certificate you posted above is your Kaspersky software.

Subject O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate
Issuer 	O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate

You will either have to disable this feature in Kaspersky or import the Kaspersky root certificate in the Firefox Certificate Manager and set the appropriate trust bit for website.

more options

cor-el said

Note that the issuer of the certificate you posted above is your Kaspersky software. Subject O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate Issuer O=AO Kaspersky Lab, CN=Kaspersky Anti-Virus Personal Root Certificate You will either have to disable this feature in Kaspersky or import the Kaspersky root certificate in the Firefox Certificate Manager and set the appropriate trust bit for website.

Hi cor-el, Disabling the feature is not an option. I have followed the info in the link you provided and so far it seems to be working. As I was going through the steps I realised I have done this before when my profile got messed up some time after that big FF overhaul. Thanks for your help!

more options

@ ferryp :

Your post, directed at Tonnes, is uncalled-for - he was only trying to help and gave you some good advice.

I used Kaspersky and had probems similar to yours (and others) - got rid of Kaspersky : no more problems since (and no more wasted money). With Windows Defender and the latest version of Firefox you're best off.

See : http://tech.firstpost.com/news-analysis/ex-mozilla-firefox-developer-says-anti-virus-software-does-more-harm-than-good-359798.html

And also :
https://www.howtogeek.com/239950/dont-use-your-antivirus-browser-extensions-they-can-actually-make-you-less-safe/

more options

Thanks for being pedantic yourself (and needlessly quoting). After reading your first posts, I somehow felt you would respond like this and were too reluctant to follow or even temporarily try suggestions from anyone if they did not meet your own thoughts and analysis (not necessarily because you’re Dutch), regardless of anyone including their personal opinion. There is no point in trying to "punish" helpers here like you did and behaving as such.

A for "some random anon online knowing nothing", you know nothing about me and would frankly be surprised if you would. Yet that comment explains your way of thinking and hence attitude - no wonder one or more people marked your post as abuse for not respecting the Mozilla Support rules and guidelines. I would suggest to behave better.

Good luck. ;)