Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I did set English as preferred language, but I get mostly Japanese

  • 4 replies
  • 1 has this problem
  • 28 views
  • Last reply by bart.1-9

more options

My wife and I share a PC. We both use English, and besides that I use mostly Dutch, French, German, and my wife often uses Japanese. Google is set as Default Search Engine. In the Firefox 'Options' menu > 'Content' we selected ENGLISH as our (only !) "preferred language for displaying pages". Nonetheless, recently searches usually - but not always - give results in JAPANESE, in Japanese writing ! Sometimes - again: but not always - followed by pages in other languages ( English, Dutch etc.) further down the list. Note: Japanese is the only non-Roman script appearing. No Arabic, Hebrew, Greek, Cyrillic or such. Clearly the Japanese used by my wife in e-mails and such lies at the root of this weird phenomenon. Does maybe Google on it's own accord select display languages based on their interpretation of such factors, neglecting the language setting in Firefox ? It goes so far that in Google Maps even map references (locality names, street names etc.) appear in Japanese writing ! For places in Europe !...

S0: how is this possible, and how do we stop this ? We want Japanese sites only when we use Japanese search terms ! Otherwise, languages in Roman letters are OK. On this PC our Firefox version is 52.7.3 (last version available for our old Windows Vista) but the same problem occurs on a second computer, under the latest version of Windows 10.

All Replies (4)

more options

Hi, search for anything in Google to open a results page, then click Settings > Languages.

You might also need to clear your cache How to clear the Firefox cache

Google is maybe scanning your searches etc. I use Startpage.com instead, which is like Google but without any snooping!

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

more options

Hi, Scribe

Thanks for your suggestions. We did already try the first one, but hat helped only for a very short time. Soon, the Japanese search results returned. B.T.W, problem: unless one is able to read the search result in that unwanted language and script, one is not able to read the mention of 'languages' in the settings list. So you would not know where to click !..

I did not try clearing the Firefox cache, not wishing to lose some very useful browsing details. But it seems to me that this would by itself not solve the problem, without Google cooperating. Anyway, new browsing would soon result in new Japanese browsing results. So where does it end?

It should not be necessary to clear the cache: the question is rather why the 'language' choice for English (in Firefox's Menu > Options > Contents) does NOT work c.q. is being ignored by Google. After all, this setting is supposed to specifically restrict the language shown in displaying search results from the search engine !

BTW: I will try Startpage.com, but is it also similar to Google in providing maps ??? I use that feature quit often.

more options

I don't know what your plugins Google Updater and Google Update are, but maybe they are interfering - you could try disabling to test: 3-bar menu > Add-ons > Plugins. (If you wanted to remove them altogether, you would have to do that in your PCs Programs).

more options

Sorry for the delay, Scribe. Very busy. I checked the Google plug-ins you mentioned (and which I didn't remember I had). One was as old as 2011 (so not useful anymore), the other from November 2017, so fresh enough. From the description it was not clear what their function was/is (keeping Google up-to-date, one should think), and what the difference between them is supposed to be. Anyway, both were marked as 'not activated'. To make sure, I changed this to 'never activate'. No appreciable effect as to the problem !

Thanks for your effort. Any other ideas? Regards, Bart BTW: will be out of communication for coming 2 weeks, so will not be able to react immediately to further suggestions.