Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

videos wont play on android

  • 13 replies
  • 88 have this problem
  • 3507 views
  • Last reply by jsissnon

more options

I try and play any video from any site and 3/4 of the video is covered with a grey block and the rest is scrambled. I haven't changed any settings or anything else for that matter. Ive uninstalled firefox and re added it 3 times and i've also done a full factory reset but it wont go away. Please help. Oh and this is on my samsung S4. It started about 2 weeks ago. Thanks Dan

Attached screenshots

Chosen solution

This is a known issue with Firefox 53. We did not hear about this until after we released. The team is working on fixing the issue.

Read this answer in context 👍 24

All Replies (13)

more options

Chosen Solution

This is a known issue with Firefox 53. We did not hear about this until after we released. The team is working on fixing the issue.

more options

Would you be able to supply the exact model number from the Android settings?

Android settings > more > about device > model number

more options

Hi. I have the same problem in Firefox 53.0.1 with my Galaxy S4, model number GT-I9515, Android 4.4.2. I'm sure this is bug 1360626 – so please handle it like the S3 in your next builds. Thank you.

Modified by wolf.gang

more options

I am not sure that we will get a new build for Firefox 53. We had some time constraints to get Firefox 53.0.2 out to users. At worst it will be in Firefox 54 which will be released in the second week of June.

There are beta builds of Firefox for Android v54 at https://play.google.com/store/apps/details?id=org.mozilla.firefox_beta the fix should be in when https://bugzilla.mozilla.org/show_bug.cgi?id=1362921 is resolved. Which should be this week's beta (~May-10) or the next (~May-17) .

more options

Thank you, I'm looking forward to the update. (Btw, in Firefox on my phone, this forum needs desktop mode to be fully readable.)

more options

Hi, my Galaxy S4 model GT-I9515 (Android 4.4.2) still has the video corruption bug caused by adaptive playback. I suppose you have forgotten it in your blacklist for Firefox 54. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1362921 See also: https://hg.mozilla.org/releases/mozilla-beta/rev/0884adb687d1 The GT-I9515 is not listed in the blacklist for 54.b08. It should have been mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1362918 , but it was forgotten. Please be so kind and include this model too. Thank you. And please forgive me that I have als posted this in a seperate thread: https://support.mozilla.org/en-US/questions/1160936

more options

I have the same problem still on build 54 on galaxy s3 android 4.4.2. I'm just going to stop using firefox all together, this is really ridiculous.

more options

There are different S3 models. You have to give the Mozilla folks your exact phone model number (and post it here, for example). You will find the model number for your S3 under: Settings/Options/About device/Model number. For my S4 the issue is fixed in Firefox 54, so I'm optimistic regarding your S3.

more options

wolf.gang said

There are different S3 models. You have to give the Mozilla folks your exact phone model number (and post it here, for example). You will find the model number for your S3 under: Settings/Options/About device/Model number. For my S4 the issue is fixed in Firefox 54, so I'm optimistic regarding your S3.

Firefox 54 did not resolve this issue for my device. Nor does the beta 55.

A browser that does not play video correctly is a pretty worthless browser.

How do I tell the Mozilla folks to fix this issue for my particular device? I am using a SM-T217.

more options

Your device is not on the current list: https://hg.mozilla.org/releases/mozilla-beta/rev/0884adb687d1 I have sent a PM to kbrosnan and I suppose he will bring this to bugzilla. It has worked quite ok for me to install the “Play Video externally” addon. You can use it for playing a video in the VLC player, while you wait for your fix to appear in the next beta. But this Addon won't work for Youtube.

more options

wolf.gang said

Your device is not on the current list: https://hg.mozilla.org/releases/mozilla-beta/rev/0884adb687d1 I have sent a PM to kbrosnan and I suppose he will bring this to bugzilla. It has worked quite ok for me to install the “Play Video externally” addon. You can use it for playing a video in the VLC player, while you wait for your fix to appear in the next beta. But this Addon won't work for Youtube.

That list is categorized under Galaxy S4 models, of which mine is not. Do you know how I can submit my model to the appropriate section so video will once again work on my device using Firefox?

There have been additional updates since I posted here and it has still not been fixed.

more options

Hm, I understand your frustration. The info from this user forum should reach the tech guys but it doesn't. Maybe holiday related? You can open a new thread here in this forum to make yourself heard. Or you can post it on bugzilla. https://bugzilla.mozilla.org/show_bug.cgi?id=1360626#c38

more options

Thank you