X
Tap here to go to the mobile version of the site.

Support Forum

Latest update (v 53) won't work on my tablet (Android 4.0.3)

Posted

When attempting to open Firefox after this morning's update, I received only a message saying this version (armeabi-v7a.15) won't work. I've searched the site for advice about what to do, but the only relevant stuff I've found indicates that it should work on Android 4.0. I don't know what to do next - other than give up.

When attempting to open Firefox after this morning's update, I received only a message saying this version (armeabi-v7a.15) won't work. I've searched the site for advice about what to do, but the only relevant stuff I've found indicates that it should work on Android 4.0. I don't know what to do next - other than give up.

Chosen solution

You need to uninstall it and reinstall the browser. I had this happen too.

Read this answer in context 13

Additional System Details

Installed Plug-ins

Adobe Flash Player 11

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

SleepyzzJohn 0 solutions 5 answers

oldchap47 said

...... I downloaded the last version of FF that worked, stopped the tablet updating apps/programs so you dont finish up with the same problem again,.....

Thanks  :-) That's worked a treat. I've now got FF 52 back, sync'd and working again. Just one thing though; how exactly can I stop this v52 from automatically updating and the same problem happening all over? Are you talking about changing a setting that stops all updates, or can they be stopped selectively for FF? Either way, where is the control?

''oldchap47 [[#answer-969041|said]]'' <blockquote> ...... I downloaded the last version of FF that worked, stopped the tablet updating apps/programs so you dont finish up with the same problem again,..... </blockquote> Thanks :-) That's worked a treat. I've now got FF 52 back, sync'd and working again. Just one thing though; how exactly can I stop this v52 from automatically updating and the same problem happening all over? Are you talking about changing a setting that stops all updates, or can they be stopped selectively for FF? Either way, where is the control?
oldchap47 0 solutions 8 answers

For my Tablet I opened 'play store' and in the top left are 3 horizontal bars. Clicking those showed me an option to stop auto updates. I am not a tablet expert, there may be a way to stop just FF updating but I havent looked for it as I dont want anything updating now as this old tablet is really only for browsing the internet. Hence games and all the other stuff is of no interest

For my Tablet I opened 'play store' and in the top left are 3 horizontal bars. Clicking those showed me an option to stop auto updates. I am not a tablet expert, there may be a way to stop just FF updating but I havent looked for it as I dont want anything updating now as this old tablet is really only for browsing the internet. Hence games and all the other stuff is of no interest
SleepyzzJohn 0 solutions 5 answers

oldchap47 said

..... I opened 'play store' and in the top left are 3 horizontal bars. Clicking those showed me an option to stop auto updates......

Ah yes, good! Found that thanks. Meanwhile, been looking around and found another option that looks as if it does the same trick. Settings -> System -> About device -> Software update -> uncheck Auto update. In the same place there's an "Update" option which when I press it, connects to the server and currently reports "No updates available". Given I'm now on FF52, was rather expecting that might show the 4.3 or 4.4 Firefox versions that are currently showing up in Play Store, Anyway for whatever reason at the moment it doesn't. Nevertheless I'll keep trying from time to time and see what happens. Thanks again! Pleased to have got Firefox back!

''oldchap47 [[#answer-969078|said]]'' <blockquote> ..... I opened 'play store' and in the top left are 3 horizontal bars. Clicking those showed me an option to stop auto updates...... </blockquote> Ah yes, good! Found that thanks. Meanwhile, been looking around and found another option that looks as if it does the same trick. Settings -> System -> About device -> Software update -> uncheck Auto update. In the same place there's an "Update" option which when I press it, connects to the server and currently reports "No updates available". Given I'm now on FF52, was rather expecting that might show the 4.3 or 4.4 Firefox versions that are currently showing up in Play Store, Anyway for whatever reason at the moment it doesn't. Nevertheless I'll keep trying from time to time and see what happens. Thanks again! Pleased to have got Firefox back!
oldchap47 0 solutions 8 answers

Glad to have helped. The option you mention is almost certainly referring to software updates to the operating system of your device which is why you get the 'no updates' available msg.

Glad to have helped. The option you mention is almost certainly referring to software updates to the operating system of your device which is why you get the 'no updates' available msg.
wryun 0 solutions 1 answers

If you'd like to run a later version of Firefox than 52, it's possible to build it yourself.

I've built a Firefox 55.0.3 which works on my device (Sony Tablet P) if you're prepared to try a random APK:

https://github.com/wryun/firefox-ics-tegra2/releases

If you'd like to run a later version of Firefox than 52, it's possible to build it yourself. I've built a Firefox 55.0.3 which works on my device (Sony Tablet P) if you're prepared to try a random APK: https://github.com/wryun/firefox-ics-tegra2/releases