X
Tap here to go to the mobile version of the site.

Support Forum

I have tried all the fixes posted and still can not get FireFox to connect to the internet, all pages come up blank, it will not even show my home page

Posted

I have run ever known form of antivirus scan, malware scan, spyware scan on a system (running windows vista on an HP computer) and FireFox still comes up with all blank pages and the home page will not load, (it comes up blank0 it also can not connect to the internet, I have tried all fixes on this web site with no luck.

I have completely scrubbed anything to do with FireFox off the hard drive and done a full new download of FireFox 50.0, then run a install, it still comes up with the same problem.

I can't post any trouble shooting info yet as I have removed the hard drive from that system and it is in the middle of a hard scrub of the drive, (using a second computer and scrubbing it as a "F" drive) looking for any hidden malware or spyware that may be hidden to the scans when the system is active.

Internet explorer, and Opera work fine, but want to use FF as my main browser, I will post any trouble shooting info when it scans are done if I still cant get to the internet.

I have run ever known form of antivirus scan, malware scan, spyware scan on a system (running windows vista on an HP computer) and FireFox still comes up with all blank pages and the home page will not load, (it comes up blank0 it also can not connect to the internet, I have tried all fixes on this web site with no luck. I have completely scrubbed anything to do with FireFox off the hard drive and done a full new download of FireFox 50.0, then run a install, it still comes up with the same problem. I can't post any trouble shooting info yet as I have removed the hard drive from that system and it is in the middle of a hard scrub of the drive, (using a second computer and scrubbing it as a "F" drive) looking for any hidden malware or spyware that may be hidden to the scans when the system is active. Internet explorer, and Opera work fine, but want to use FF as my main browser, I will post any trouble shooting info when it scans are done if I still cant get to the internet.

Chosen solution

What fixed it was a system restore, it may have been a corrupted file somewhere in some update, or even the full download of FF50.

But it is working now

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59424 answers

What's your computer system and Firefox version?

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

What's your computer system and Firefox version? Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again; * Make sure your Internet security software is up-to-date (i.e. you are running the latest version). * Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link}

Question owner

My OS is posted in my first post, Vista on an HP system with FF 50.0.

And I have tried all of what you posted.

My OS is posted in my first post, Vista on an HP system with FF 50.0. And I have tried all of what you posted.
FredMcD
  • Top 10 Contributor
4248 solutions 59424 answers

Have you checked the modem and your connection?

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.

Have you checked the modem and your connection? Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''Network.''' Look for '''Configure How Firefox Connects''' and press the '''Settings''' button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use '''No Proxy.''' If there is a problem, then try '''System Proxy.'''

Question owner

The system will connect fine to the internet with IE10 and Opera, its FireFox that will not connect.

Again it will not show the home page, it only shows blank pages, I have tried changing the home page to something else and it still will not show it, if you open a new tab and type in an address it comes up blank,

I have the hard drive out of that system and connected to my hard drive test bed an it's in the middle of a deep scan for anything bad that may have been downloaded.(nothing found yet)

As stated I have read all troubleshooting information on this site and nothing has worked, last thing I may have to do is a system restore or a format and recovery.

BUT why did this happen???? and WHAT is causing it to do this, I would like to know, and would like to find a fix for it if I run into this on someone else's computer.

Once I get the drive back in that system I will post the troubleshooting information it comes up with in the FF health report. (or what ever it is)

I may try an older version of FF to see if this version has a bug in it that only runs on Vista.

The system will connect fine to the internet with IE10 and Opera, its FireFox that will not connect. Again '''it will not show the home page''', it only shows blank pages, I have tried changing the home page to something else and it still will not show it, if you open a new tab and type in an address it comes up blank, I have the hard drive out of that system and connected to my hard drive test bed an it's in the middle of a deep scan for anything bad that may have been downloaded.(nothing found yet) As stated I have read all troubleshooting information on this site and nothing has worked, last thing I may have to do is a system restore or a format and recovery. BUT why did this happen???? and WHAT is causing it to do this, I would like to know, and would like to find a fix for it if I run into this on someone else's computer. Once I get the drive back in that system I will post the troubleshooting information it comes up with in the FF health report. (or what ever it is) I may try an older version of FF to see if this version has a bug in it that only runs on Vista.
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40160 answers

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

Have you covered what is posted there?

Typically when Firefox won't load any webpages and other web browsers work fine, the issue is with a "dumb" firewall that won't let Firefox thru. Please see this support article: https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can Have you covered what is posted there? Typically when Firefox won't load any webpages and other web browsers work fine, the issue is with a "dumb" firewall that won't let Firefox thru. Please see this support article: https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet

Question owner

Been there done that several times, it didn't do anything.

Even turning off and disabling the firewall, and all AV, malware and spyware programs did nothing. (running Avast, Malwarebytes and Super anti spyware)


So I think something deeper inside the system is affecting this, but why only Firefox?????

Been there done that several times, it didn't do anything. Even turning off and disabling the firewall, and all AV, malware and spyware programs did nothing. (running Avast, Malwarebytes and Super anti spyware) So I think something deeper inside the system is affecting this, but why only Firefox?????
FredMcD
  • Top 10 Contributor
4248 solutions 59424 answers

Have you check the Network. and Configure How Firefox Connects?

Have you check the Network. and Configure How Firefox Connects?

Question owner

Yup the network is fine, IE and Opera can connect fine.

And I can see all the network dives on the workgroup.

All other computers on this network can connect to the internet just fine, and they are running FireFox 50.1.0 just fine.

I have checked the setting for how FireFox connects on them and it's the same on the problem PC.

Still waiting on the deep scan, once that is finished I will be able to post info from that PC. (after I reinstall the hard drive)

Yup the network is fine, IE and Opera can connect fine. And I can see all the network dives on the workgroup. All other computers on this network can connect to the internet just fine, and they are running FireFox 50.1.0 just fine. I have checked the setting for how FireFox connects on them and it's the same on the problem PC. Still waiting on the deep scan, once that is finished I will be able to post info from that PC. (after I reinstall the hard drive)

Question owner

OK deep scan did not find anything, and after re-installing the hard drive I had to do a system restore, I had to go back to June of last year to get FireFox to run on this PC.

I don't have any ideas on what was causing the problem but it is back to normal.

It shows as version 50.0.2 and wants to update, I'm not sure if I should do this as it is now working.

I will log onto that PC and download the info from it for you all to look at.

Thanks for all the help,

Terryl

OK deep scan did not find anything, and after re-installing the hard drive I had to do a system restore, I had to go back to June of last year to get FireFox to run on this PC. I don't have any ideas on what was causing the problem but it is back to normal. It shows as version 50.0.2 and wants to update, I'm not sure if I should do this as it is now working. I will log onto that PC and download the info from it for you all to look at. Thanks for all the help, Terryl

Question owner

Update worked fine, so I have know idea on what was affecting the system.

It went right to the correct start up page and I can connect to other web pages.

How do I post the information on this setup?

Update worked fine, so I have know idea on what was affecting the system. It went right to the correct start up page and I can connect to other web pages. How do I post the information on this setup?
FredMcD
  • Top 10 Contributor
4248 solutions 59424 answers

If it's working now, I dought we will find anything. It could have been a corrupt file was overwritten.

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

If it's working now, I dought we will find anything. It could have been a corrupt file was overwritten. Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''

Chosen Solution

What fixed it was a system restore, it may have been a corrupted file somewhere in some update, or even the full download of FF50.

But it is working now

What fixed it was a system restore, it may have been a corrupted file somewhere in some update, or even the full download of FF50. But it is working now
FredMcD
  • Top 10 Contributor
4248 solutions 59424 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.