Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Delete messages problem

  • 5 replies
  • 1 has this problem
  • 77 views
  • Last reply by Zenos

more options

I have Mozilla 45.6.0 and gmail (Imap) and I would like to have that simple setting that when I push delete-button on my keaboard, Thunderbird delete the message, but dont put it into the normal trashcan, but into a folder (so its not deleted after 30 days). I have norwegian eddition, and here I have folders that are called "deleted messages", "trash", and folders called "søppelpost" (spammail), søppel (trash) and slettede elementer (deleted messages). But when I delete a message today, it totaly dissapears. I cant find it in Thunderbird, and I cant find it in gmail online when I log on.

The accountant:)

Chosen solution

This isn't quite what you talked about in the first posting, where you led us to think the issue is messages deleting after 30 days…

Do you really have four different places for deleted messages?

  1. folders that are called "deleted messages",
  2. "trash",
  3. and folders called … søppel (trash) and
  4. slettede elementer (deleted messages).

I'd be worried about the ambiguity. Which one is really gmail's preferred Trash folder? And what are gmail's settings for aged message deletion?

Read this answer in context 👍 0

All Replies (5)

more options

Thunderbird has no fixed "delete after 30 days" policy. You can certainly set it to work like this, but equally well you can set it to never delete.

Tools|Account Settings|{select account}|Synchronization & Storage→Disc Space

If your Deleted folder is on an IMAP server then you also need to look to see what your email provider's deletion policy is. You are free to set Thunderbird to save its Deleted folder in Local Folders, safely out of reach of your email provider's server.

Tools|Account Settings|{select account}|Server Settings→Server Settings

more options

Thanks, but dont work. On

Tools|Account Settings|{select account}|Synchronization & Storage→Disc Space I sync all messages, and I dont delete any messages.

Under Tools|Account Settings|{select account}|Server Settings→Server Settings I would like to save them on the server, not localy (in case something happens to my PC). So I have (freely translated) "When I delete a message: move it to trash folder: "trash on myaccount@gmail.com".

But when I delete the message, it disappears. I try to add an image here..

more options

Chosen Solution

This isn't quite what you talked about in the first posting, where you led us to think the issue is messages deleting after 30 days…

Do you really have four different places for deleted messages?

  1. folders that are called "deleted messages",
  2. "trash",
  3. and folders called … søppel (trash) and
  4. slettede elementer (deleted messages).

I'd be worried about the ambiguity. Which one is really gmail's preferred Trash folder? And what are gmail's settings for aged message deletion?

more options

Sorry if my english is confusing you. I dont know wich is preferred, and setting. How do I find out?

more options

I think the one that gmail uses would be safest. I'd go to the gmail website and create a deleted message. Then in Thunderbird find which folder it uses by looking for that deleted message, and set that folder as the "deleted" folder for the account.