Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using about config to disable password for logins

  • 4 replies
  • 3 have this problem
  • 3936 views
  • Last reply by hs-sd

more options

Hi All,

I managed to find one or two posts relevant to my question, however I have tried these settings and they can still be changed by the user.

What I wanted to know is, when going under the FireFox options > Security, is there a way to totally disable the "Remember logins for sites"? I know this can be unticked and have found an option in about:config - signon.rememberSignons;false. All this seems to do is untick it but still allows the user to go in and tick the box again.

I have also found the following preference; signon.autofillForms;false and this helps in someway as when I try to login to services that require a username/password it no longer asks to save the credentials or prompt you with any that it has saved previously when clicking on the box to type it in.

Is there anyway I can totally disable the "Remember logins for sites" option by greying it out or atleast preventing users from ticking it again?

Chosen solution

See also Configuration:


mozilla.cfg in main Firefox program folder:

//
lockPref("signon.rememberSignons", false);

local-settings.js file in the "defaults/pref" folder (this folder contains the channel-prefs.js file that specifies the update channel).

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);
Read this answer in context 👍 0

All Replies (4)

more options

hi hs-sd, if you want to lock certain settings please refer to this article on how to do that: http://kb.mozillazine.org/Locking_preferences

more options

philipp said

hi hs-sd, if you want to lock certain settings please refer to this article on how to do that: http://kb.mozillazine.org/Locking_preferences

Hi Philipp,

Thanks for the quick response. I have had a quick look browse through the link and this seems to be on the right track.

I will give this a try and let you know how i get on.

Many thanks once again.

more options

Chosen Solution

See also Configuration:


mozilla.cfg in main Firefox program folder:

//
lockPref("signon.rememberSignons", false);

local-settings.js file in the "defaults/pref" folder (this folder contains the channel-prefs.js file that specifies the update channel).

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);
more options

cor-el said

See also Configuration:

mozilla.cfg in main Firefox program folder:

//
lockPref("signon.rememberSignons", false);

local-settings.js file in the "defaults/pref" folder (this folder contains the channel-prefs.js file that specifies the update channel).

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0);

cor-el thanks very much for your post as I have now managed to disable the "remember logins for sites" and it now greys it out and prevents any credentials from being saved.