X
Tap here to go to the mobile version of the site.

Support Forum

Second firefox.exe appearing in Processes in Windows Task Manager...

Posted

Hi all!

I began experiencing this problem a few days ago and not sure what's causing it:

In my Windows Task Manager, there are two firefox.exe that appear under Processes (under Applications, Firefox only appears once). I've used End Process to close each of the firefox.exe that appear and the result has been peculiar. Depending on which one I End, either the window closes entirely along with all the tabs or the tab that is currently open crashes and I get the message: "Bad news first: This tab has crashed."

I've scanned my computer with AVG for viruses and everything came back clean. I also scanned it with ESET for malware and nothing was found.


Any idea what I can do to resolve this? Any help would be appreciated.

Hi all! I began experiencing this problem a few days ago and not sure what's causing it: In my Windows Task Manager, there are two firefox.exe that appear under Processes (under Applications, Firefox only appears once). I've used End Process to close each of the firefox.exe that appear and the result has been peculiar. Depending on which one I End, either the window closes entirely along with all the tabs or the tab that is currently open crashes and I get the message: "Bad news first: This tab has crashed." I've scanned my computer with AVG for viruses and everything came back clean. I also scanned it with ESET for malware and nothing was found. Any idea what I can do to resolve this? Any help would be appreciated.

Chosen solution

You're probably seeing the new Multi-process feature in Firefox.

Multi-process Firefox codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess

Started with Firefox 48 for a very small percentage of users who had noi extensions installed; expanded in Firefox 49 to a slightly larger group of users; further expansion in Firefox 50. Automatically disabled when too many extensions installed are detected and when extensions that don't yet support e10s are detected.

Extension compatibility for the most popular extensions which are hosted at AMO are listed here: http://arewee10syet.com/

To disable multiprocess:

Type about:config into the address bar, press Enter, accept the warning. Out this in the Search field at the top browser.tabs.remote.autostart . Double-click that preference in the reduced listing that is below the Search field to toggle the 'Value' from True to False.

Read this answer in context 13

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • GEPlugin
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 10.2 r152
  • 5.1.50901.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40310 answers

Chosen Solution

You're probably seeing the new Multi-process feature in Firefox.

Multi-process Firefox codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess

Started with Firefox 48 for a very small percentage of users who had noi extensions installed; expanded in Firefox 49 to a slightly larger group of users; further expansion in Firefox 50. Automatically disabled when too many extensions installed are detected and when extensions that don't yet support e10s are detected.

Extension compatibility for the most popular extensions which are hosted at AMO are listed here: http://arewee10syet.com/

To disable multiprocess:

Type about:config into the address bar, press Enter, accept the warning. Out this in the Search field at the top browser.tabs.remote.autostart . Double-click that preference in the reduced listing that is below the Search field to toggle the 'Value' from True to False.

You're probably seeing the new Multi-process feature in Firefox. Multi-process Firefox codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess ''Started with Firefox 48 for a very small percentage of users who had noi extensions installed; expanded in Firefox 49 to a slightly larger group of users; further expansion in Firefox 50. Automatically disabled when too many extensions installed are detected and when extensions that don't yet support e10s are detected.'' Extension compatibility for the most popular extensions which are hosted at AMO are listed here: http://arewee10syet.com/ To disable multiprocess: Type '''about:config''' into the address bar, press Enter, accept the warning. Out this in the Search field at the top '''browser.tabs.remote.autostart''' . Double-click that preference in the reduced listing that is below the Search field to toggle the 'Value' from '''''True''''' to '''''False'''''.

Helpful Reply

Thanks very much! That solved the issue.  :)

Thanks very much! That solved the issue. :)
vomdez 0 solutions 10 answers

The property name is now suffixed with a '2' but I was able to achieve the same...hope they dont slyly slip in a '3' in a few weeks ! I was shocked too seeing a second process...WTF

The biggest reason for my jump back from Chrome was the fact that FF is unashamed to show the memory consumption (and in a single freakin process - I dont care about crashes) while Chrome tries every which way to avoid it us seeing it, also killing this property viewing in about:memory.

The property name is now suffixed with a '2' but I was able to achieve the same...hope they dont slyly slip in a '3' in a few weeks ! I was shocked too seeing a second process...WTF The biggest reason for my jump back from Chrome was the fact that FF is unashamed to show the memory consumption (and in a single freakin process - I dont care about crashes) while Chrome tries every which way to avoid it us seeing it, also killing this property viewing in about:memory.