X
Tap here to go to the mobile version of the site.

Support Forum

Firefox loads HTTP site of Google

Posted

When I type "google.com" in the address bar, the HTTP site of Google loads by default. Why does this happen ? How do I make it make it load HTTPS site when I type "google.com" ?

When I type "google.com" in the address bar, the HTTP site of Google loads by default. Why does this happen ? How do I make it make it load HTTPS site when I type "google.com" ?

Chosen solution

Hmm, that's strange. I don't know why Google is doing that.

Due to another change I made on my Firefox, I am getting the secure site. It involves lying to google.com about my mobile browser as described in this thread: https://support.mozilla.org/questions/1125353 (note: image search blanks out with that setting, so if image search is important to you on mobile, I don't recommend it)

With that useragent string set, Google DOES redirect to HTTPS.

It just doesn't make sense that Google gives such an inferior version of its site to Firefox users. At least, from our perspective it doesn't make sense. Google probably has its reasons.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

christ1
  • Top 25 Contributor
2164 solutions 15795 answers

Helpful Reply

By typing https://google.com? Create a bookmark if you get tired of typing it every time.

By typing https://google.com? Create a bookmark if you get tired of typing it every time.

Question owner

christ1 said

By typing https://google.com? Create a bookmark if you get tired of typing it every time.

Is this the default behaviour of Firefox or is it specific to my browser ?Is there no other way to change this behaviour, like clearing cache or something ?

''christ1 [[#answer-917709|said]]'' <blockquote> By typing https://google.com? Create a bookmark if you get tired of typing it every time. </blockquote> Is this the default behaviour of Firefox or is it specific to my browser ?Is there no other way to change this behaviour, like clearing cache or something ?

Modified by Kaartic

christ1
  • Top 25 Contributor
2164 solutions 15795 answers

Helpful Reply

Not sure what default behavior you're talking about.

If you type google.com, then you're implicitly telling the browser to use http://google.com. For secure sites the server would then redirect you to https://google.com. However, that makes you vulnerable to a man-in-the-middle attack.

If security is the concern always use https://google.com.

Why the Google server doesn't do the redirect to https in your case I don't know, but that's something you'd need to ask Google.

Not sure what default behavior you're talking about. If you type google.com, then you're implicitly telling the browser to use http://google.com. For secure sites the server would then redirect you to https://google.com. However, that makes you vulnerable to a man-in-the-middle attack. If security is the concern always use https://google.com. Why the Google server doesn't do the redirect to https in your case I don't know, but that's something you'd need to ask Google.

Question owner

The Desktop browser and the Chrome browser in my mobile, loads https://google.com when I type google.com . So, I am confused about why the Firefox browser for Android loads the HTTP site when I type google.com .

The Desktop browser and the Chrome browser in my mobile, loads https://google.com when I type google.com . So, I am confused about why the Firefox browser for Android loads the HTTP site when I type google.com .
christ1
  • Top 25 Contributor
2164 solutions 15795 answers

Why the Google server doesn't re-direct to the https site while the desktop version does I don't know. It may be related to how HSTS is implemented. https://www.owasp.org/index.php/HTTP_Strict_Transport_Security

You can check with Google, and/or open a bug in Bugzilla for Firefox for Android. https://bugzilla.mozilla.org/

In any case, the safe way is to use https in the first place.

Why the Google server doesn't re-direct to the https site while the desktop version does I don't know. It may be related to how HSTS is implemented. https://www.owasp.org/index.php/HTTP_Strict_Transport_Security You can check with Google, and/or open a bug in Bugzilla for Firefox for Android. https://bugzilla.mozilla.org/ In any case, the safe way is to use https in the first place.
jscher2000
  • Top 10 Contributor
8693 solutions 71064 answers

Chosen Solution

Hmm, that's strange. I don't know why Google is doing that.

Due to another change I made on my Firefox, I am getting the secure site. It involves lying to google.com about my mobile browser as described in this thread: https://support.mozilla.org/questions/1125353 (note: image search blanks out with that setting, so if image search is important to you on mobile, I don't recommend it)

With that useragent string set, Google DOES redirect to HTTPS.

It just doesn't make sense that Google gives such an inferior version of its site to Firefox users. At least, from our perspective it doesn't make sense. Google probably has its reasons.

Hmm, that's strange. I don't know why Google is doing that. Due to another change I made on my Firefox, I am getting the secure site. It involves lying to google''.''com about my mobile browser as described in this thread: https://support.mozilla.org/questions/1125353 (note: image search blanks out with that setting, so if image search is important to you on mobile, I don't recommend it) With that useragent string set, Google DOES redirect to HTTPS. It just doesn't make sense that Google gives such an inferior version of its site to Firefox users. At least, from ''our'' perspective it doesn't make sense. Google probably has its reasons.