Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do I stop Mozilla opening the last viewed page instead of my home page?

  • 7 replies
  • 16 have this problem
  • 4756 views
  • Last reply by harpguy12

more options

It isnt crash recovery, crash count is zero. Home page set to google but never see it. There is no user.js file. I am totally fed up and close to uninstalling Mozilla. I don't want Mozilla opening last viewed page. If I need that I can use history!!

Chosen solution

Solved!!!!! Just change Settings.advanced.restore tabs To don't restore tabs and Job done!

Read this answer in context 👍 1

All Replies (7)

more options

Great service this !

more options

Type in "about:config" in your address bar. Search for "browser.startup.homepage". Does it also say Google?

more options

What are you doing to shut down Firefox when you're done with it? For example:

  • Call up the Android recent apps list and "swipe" Firefox off the list
  • Use "Quit" on Firefox's menu (Quit appears if you set up Firefox to clear any kind of data at shutdown, or you can use an add-on)

If you are simply going to the home screen or another application without terminating the program, Firefox remains loaded until the Android memory manager determines that it needs to be shut down, which may take much longer than you imagine.

more options

If your question is about another version of Firefox, what operating system are you running it on? A moderator can move your question from the Android forum to the Desktop forum where a lot more people will see it.

more options

Using nexus7 and android 5.1.1 and Firefox 48.0 In about config only homepage line is browser.startup.homepage_override.mstone ( value 48.0) If I reset this it just returns Homepage is set to Google in settings I always minimise Firefox and close app to avoid having loads of windows running at once because Nexus is slow until I do regular housekeeping. Using the quit option doesn't help, still opens last viewed page. I am not using Firefox app any more unless this issue is resolved. The number of similar complaints shows there is a major issue.

Modified by harpguy12

more options

Just found out accidentally that if I use the quit option that Firefox is still in the active apps list. If I then also exit the Firefox app then Firefox opens in my homepage ( but forgets all the passwords etc. ) I.e. using either option alone does not work but using both together does! This is however a lot of faffing about and I really need Firefox to remember passwords. Sounds like a bug to me.

more options

Chosen Solution

Solved!!!!! Just change Settings.advanced.restore tabs To don't restore tabs and Job done!