X
Tap here to go to the mobile version of the site.

Support Forum

Can't access Southwest Airlines with 16.0.2 on MacBook OS X Leopard. Help!

Posted

I purchased a ticket on this computer from Southwest. In the last 10 days, I have not been able to get back on the Southwest site using Firefox. I've checked the advanced preferences, et al. I can access everything else under the sun, but get an error message for Southwest. I did access Southwest from a work computer. I can't buy a new Mac, so that won't work. THX

I purchased a ticket on this computer from Southwest. In the last 10 days, I have not been able to get back on the Southwest site using Firefox. I've checked the advanced preferences, et al. I can access everything else under the sun, but get an error message for Southwest. I did access Southwest from a work computer. I can't buy a new Mac, so that won't work. THX

Chosen solution

Hi Pete, thank for your message. I understand that after clearing cache and cookies you still get:

'The connection was reset. The connection to the server was reset while the page was loading.'

And that in Safari you get a secure connection error.

That could be the same problem, but so much has changed since Firefox 16 that I don't know what it can connect to any more.

Could you open this page -- it analyzes the various features of your Firefox's ability to make secure connections:

https://www.ssllabs.com/ssltest/viewMyClient.html

In particular:

(1) Protocols

Southwest requires TLS 1.2. Does your test page show that TLS 1.2 is supported?

(2) Ciphers

This section is hard to read, but does your Firefox list these ciphers as supported?

TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA

In Firefox 48, these are the only ciphers that Firefox and the site share in common; the site does not allow lower strength ciphers.

Info on what the server requires drawn from:

https://www.ssllabs.com/ssltest/analyze.html?d=www.southwest.com

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Helpful Reply

What is the error message you get?


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Or type southwest.com in the box if needed.

Then try reloading the page. Does that help?

What is the error message you get? ---- When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Or type southwest.com in the box if needed. Then try reloading the page. Does that help?
James
  • Moderator
1594 solutions 11232 answers

For people wondering why Firefox 16.0.2 well that is the last Firefox Release that could run on a intel Mac with OSX 10.5. https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5

Firefox 17.0 to the current 48.0 Release will work on OSX 10.6 however the Firefox 49.0 release will require OSX 10.9 at minimum. https://support.mozilla.org/en-US/kb/firefox-osx

For people wondering why Firefox 16.0.2 well that is the last Firefox Release that could run on a intel Mac with OSX 10.5. https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5 Firefox 17.0 to the current 48.0 Release will work on OSX 10.6 however the Firefox 49.0 release will require OSX 10.9 at minimum. https://support.mozilla.org/en-US/kb/firefox-osx

Modified by James

jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Chosen Solution

Hi Pete, thank for your message. I understand that after clearing cache and cookies you still get:

'The connection was reset. The connection to the server was reset while the page was loading.'

And that in Safari you get a secure connection error.

That could be the same problem, but so much has changed since Firefox 16 that I don't know what it can connect to any more.

Could you open this page -- it analyzes the various features of your Firefox's ability to make secure connections:

https://www.ssllabs.com/ssltest/viewMyClient.html

In particular:

(1) Protocols

Southwest requires TLS 1.2. Does your test page show that TLS 1.2 is supported?

(2) Ciphers

This section is hard to read, but does your Firefox list these ciphers as supported?

TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA

In Firefox 48, these are the only ciphers that Firefox and the site share in common; the site does not allow lower strength ciphers.

Info on what the server requires drawn from:

https://www.ssllabs.com/ssltest/analyze.html?d=www.southwest.com

Hi Pete, thank for your message. I understand that after clearing cache and cookies you still get: 'The connection was reset. The connection to the server was reset while the page was loading.' And that in Safari you get a secure connection error. That could be the same problem, but so much has changed since Firefox 16 that I don't know what it can connect to any more. Could you open this page -- it analyzes the various features of your Firefox's ability to make secure connections: https://www.ssllabs.com/ssltest/viewMyClient.html In particular: '''(1) Protocols''' Southwest '''requires''' TLS 1.2. Does your test page show that TLS 1.2 is supported? '''(2) Ciphers''' This section is hard to read, but does your Firefox list these ciphers as supported? TLS_'''ECDHE_RSA'''_WITH_AES_'''128_GCM'''_SHA256 TLS_'''ECDHE_RSA'''_WITH_AES_'''128_CBC'''_SHA TLS_'''ECDHE_RSA'''_WITH_AES_'''256_CBC'''_SHA In Firefox 48, these are the only ciphers that Firefox and the site share in common; the site does not allow lower strength ciphers. Info on what the server requires drawn from: https://www.ssllabs.com/ssltest/analyze.html?d=www.southwest.com
James
  • Moderator
1594 solutions 11232 answers

jscher2000 said

Southwest requires TLS 1.2. Does your test page show that TLS 1.2 is supported?

TLS 1.2 support was added as of Gecko 24.0 or Firefox 24.0 as the old Firefox 16.0.2 did not support TLS 1.2.

''jscher2000 [[#answer-907432|said]]'' <blockquote> Southwest '''requires''' TLS 1.2. Does your test page show that TLS 1.2 is supported? </blockquote> TLS 1.2 support was added as of Gecko 24.0 or Firefox 24.0 as the old Firefox 16.0.2 did not support TLS 1.2.