Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Messages not moved to trash when deleted for gmail account

  • 26 replies
  • 1 has this problem
  • 32 views
  • Last reply by Zenos

more options

Update: I have narrowed down the problem. My preference for where to move deleted messages is not being honored. Deleted messages always go to the [Gmail]/Trash folder regardless of my setting.

However, if I am not subscribed to [Gmail]/Trash, then the message disappears from the original folder, but remains in "[Gmail]/All Mail" whether or not I am subscribed to it. If I delete a message from "[Gmail]/All Mail", the message disappears in Thunderbird's message list until I restart it. The message remains visible in Gmail's web client.

So the question now is: Is there any way to use a folder besides [Gmail]/Trash as my trash folder? Google deletes messages in [Gmail]/Trash after 30 days and I don't want this done. It would also be useful to know if someone else can confirm this behavior for their own Gmail accounts.


Original question follows.

About a month and a half ago deleted messages from my inbox stopped getting moved to the Trash folder. I just noticed it recently as I don't regularly check my trash. This problem only occurs when clicking the "Delete" button or pressing the delete key on the message. I am able to right click on the message and move the message to the Trash folder.

I recently upgraded from Debian Linux stable branch to testing. The change in behavior probably coincided with that upgrade. I am currently running version 38.8.0. [Update - I verified that the last deleted message successfully moved to the Trash folder was just before the upgrade. I did not perform a full upgrade to Debian testing branch and the mail client was not part of the upgrade. I have just now upgraded the mail client to the latest on the testing branch (version 45.1.0) and the problem persists.]

I deleted my configuration directory and recreated my account to see if the problem was caused by some corruption of my settings, but the problem remains.

The problem occurs when accessing my gmail account over IMAP. I have a non-gmail account that appears to work correctly.

I verified that the account is still configured to move messages to the trash on deletion (Account Settings->[account name]->Server Settings->When I delete a message: Move it to this folder: Trash)

I searched for one of the deleted messages in all my mail files (using "grep -r" in my root configuration directory) and it only appears in the INBOX file (presumably because I haven't compressed this folder since deleting the message). So the problem is not simply that it's going to the wrong place and I can't find it.

Modified by mt11

All Replies (20)

more options

Thanks for your quick reply, but that link does not describe the problem I am encountering. I followed the recommendations on that page just in case and it did not resolve me issue.

In my problem, when I delete a message it is being removed from the inbox. It is just not being moved to the trash. It is being permanently deleted.

more options

What is the size of your Trash?

Do you empty Trash on a regular basis?

more options

I have 726 items in my trash totaling 81MB.

I do not empty my trash, although I do delete items in it occasionally to pare it down.

more options
I do not empty my trash

Beats me. You should do that.

more options

Emptied my trash, but that did not help. Configuring deleted messages to go to a different folder does not help either.

more options

are your deleted messages appearing in the All Mail folder? They should be unless you have modified the setting on the gmail server as Gmail uses that folder as an Archive of all mail.

more options

Matt said

are your deleted messages appearing in the All Mail folder?

Yes, they are in the All Mail folder, so they are not completely lost. They are just not properly being moved to the Trash folder.

more options

See https://support.google.com/mail/answer/78755

Also see https://support.google.com/mail/answer/78892 for recommended IMAP settings.

Can you post a screenshot of your folder pane with the folders for your Gmail account visible? http://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

more options

Those links provide some useful background information, but do not explain how to get back to my previous workflow: deleted messages are saved in Trash, but Trash messages are not deleted so are still locally searchable (for more than just 30 days).

The "[Gmail]/All Mail" is close to being useful for this purpose, but contains duplicates of messages in other folders and I can only remove messages from it by permanently deleting them. If I can't get my local Trash working again I will probably settle for using the "All Mail" folder and doing my searches from the web client.

Screenshot uploaded.

more options

Can you confirm this is an IMAP account?

more options

Under Server Settings, Server Type is listed as "IMAP Mail Server"

more options

From your screenshot apparently all the labels underneath [Gmail] are missing. I have no idea how you managed to do that.

Therefore, delete the Gmail account. Since all messages are on the server, nothing will get lost. Restart Thunderbird. Then recreate the account. Make sure to chose 'OAuth2' as 'Authentication method' for both, IMAP and SMTP server. That should recreate your labels in Thunderbird underneath [Gmail].

more options

All of the labels under [Gmail] are missing because I am not subscribed to those folders. (Right click on account name, select subscribe option). I have tested the behavior when subscribed to the [Gmail] subfolders.

If I subscribe to [Gmail]/Trash, then deleted messages always go there regardless of how I have Thunderbird configured. They will then be deleted in 30 days.

If I don't subscribe to [Gmail]/Trash, then deleted messages disappear from the origin folder but remain in "[Gmail]/All Mail", which I prefer to having the messages permanently deleted.

I verified that OAuth2 is being used for both IMAP and SMTP.

more options

You're complaining about messages not going into Trash upon deleting, and at the same time you unsubscribed from [Gmail]/Trash.

I don't think I understand what you want.

more options

I want messages to go to Trash instead of [Gmail]/Trash. The reason for this is that Gmail permanently deletes messages in [Gmail]/Trash after 30 days and I do not want my deleted messages to be permanently deleted.

more options

I can't understand why someone would delete messages that they don't want to be deleted.

more options

Zenos said

I can't understand why someone would delete messages that they don't want to be deleted.

I am with your Zenos. There appear to be lots of folk out there that think deleted means resubmit or Archive.

Right click the account select settings. In Server setting set the trash to me moved to a folder.... any folder, but clearly not one named trash because it is obvious that this is not trash as you want to reference is again.

I wold also suggest you click the advanced button in server settings and insert [Gmail] in the server directory. It will remove the silly [Gmail]\ folders and place them in the root of the account where they belong.

more options

Zenos said

I can't understand why someone would delete messages that they don't want to be deleted.

I can sympathize with this view, but I am merely trying to use Thunderbird in the way it was designed and in its default configuration. Deleted messages are supposed to be moved to the Trash folder. The trash folder is cleaned on the initiative of the user and not automatically. My cleaning interval is on the order of a year or two rather than every month as Gmail forces on its Trash folder - which it discourages using. Google suggests you keep all messages forever.

more options

I also have a gmail imap account and I subscibe to see 'Bin' which is gmails Trash folder and if I do not clear it then gmail will do this automatically each month. This is the way that gmail works. It does not expect you to want to keep unwanted trash for long periods and uses it to help keep the quota down and free up space for new emails.

However, you are not choosing to delete the message. You want to store it for a lengthy period of time before finally deleting the messages. So do not delete them until you actually want to delete them.

I would create an imap folder called something like: 'Pending Trash' Subscribe to see that folder. Move emails to that folder as required after reading.

You can set up a Retention policy on the 'Pending Trash' folder to empty older emails eg: anything older than eg: 300 days. right click on 'Pending Trash' and select 'Properties' selet 'Retention policy' tab uncheck 'Use my account settings' select: 'Delete messages more than xx days' click on OK.

  1. 1
  2. 2