X
Tap here to go to the mobile version of the site.

Support Forum

How do I force show URL/Address in URLBAR instead of site/company name?

Posted

I'm looking for the ABOUT:CONFIG setting to force page addresses to always show in the urlbar instead of showing company or site name. As shown in my screenshot it shows "Mozilla Foundation (US)" instead of the page address starting with http://. It will show the URL if I click/highlight the urlbar, but I want it to show URLs always by default.

Keep in mind I'm using Firefox for Android & no I don't want to install any sort of addon, I just want the ABOUT:CONFIG settings I need to add or change.

Thank you.

Edit: So far I think I've only seen the name instead of address on certain Mozilla sites, does Mozilla force the name instead of url address? If so, this won't really be an issue I guess, but why do they have to be different, I want uniformity dadgummit! Lol Let me know, Thanks.

I'm looking for the ABOUT:CONFIG setting to force page addresses to always show in the urlbar instead of showing company or site name. As shown in my screenshot it shows "Mozilla Foundation (US)" instead of the page address starting with http://. It will show the URL if I click/highlight the urlbar, but I want it to show URLs always by default. Keep in mind I'm using Firefox for Android & no I don't want to install any sort of addon, I just want the ABOUT:CONFIG settings I need to add or change. Thank you. Edit: So far I think I've only seen the name instead of address on certain Mozilla sites, does Mozilla force the name instead of url address? If so, this won't really be an issue I guess, but why do they have to be different, I want uniformity dadgummit! Lol Let me know, Thanks.
Attached screenshots

Modified by PenTech Services

Additional System Details

Installed Plug-ins

No plug-ins installed.

Application

  • User Agent: Mozilla/5.0 (Android 4.4.2; Tablet; rv:47.0) Gecko/47.0 Firefox/47.0

More Information

Question owner

Edit: After testing, it's not just happening on Mozilla sites, it's doing the same thing on github.com and several other sites.

Seriously? Nobody knows why Firefox is suddenly doing this?

Edit: After testing, it's not just happening on Mozilla sites, it's doing the same thing on github.com and several other sites. Seriously? Nobody knows why Firefox is suddenly doing this?
jscher2000
  • Top 10 Contributor
8838 solutions 72241 answers

This was an intentional change and when it looked into it recently I didn't see a way to revert it. Please see the following thread: Url bar only shows domain, not full path - makes browser unusable for me.

This was an intentional change and when it looked into it recently I didn't see a way to revert it. Please see the following thread: [https://support.mozilla.org/questions/1120481 Url bar only shows domain, not full path - makes browser unusable for me].

Question owner

The following either A: breaks the way the EVSSL thing works or B: disables the showing of the name instead of the url in the urlbar.

security.ssl.enable_ocsp_stapling = false security.OCSP.enabled = 0

And so FF doesn't grey out parts of the url & blocks the showing of the http:// part I also DISABLED both of these: browser.urlbar.trimURLs browser.urlbar.formatting.enabled

As you can see in my screenshot it no longer shows the name, it now shows the full URL.

The following either A: breaks the way the EVSSL thing works or B: disables the showing of the name instead of the url in the urlbar. '''security.ssl.enable_ocsp_stapling''' = '''false''' '''security.OCSP.enabled''' = '''0''' And so FF doesn't grey out parts of the url & blocks the showing of the http:// part I also DISABLED both of these: '''browser.urlbar.trimURLs''' '''browser.urlbar.formatting.enabled''' As you can see in my screenshot it no longer shows the name, it now shows the full URL.
jscher2000
  • Top 10 Contributor
8838 solutions 72241 answers

PenTech Services said

The following either A: breaks the way the EVSSL thing works or B: disables the showing of the name instead of the url in the urlbar.
security.ssl.enable_ocsp_stapling = false
security.OCSP.enabled = 0

Those changes prevent verification of ongoing validity because Firefox will no longer check whether any SSL certificate has been revoked. I didn't realize that affected the display of an EVSSL certificate owner's name. either way, keeping OCSP checks enabled is a good security practice.

''PenTech Services [[#answer-876894|said]]'' <blockquote> The following either A: breaks the way the EVSSL thing works or B: disables the showing of the name instead of the url in the urlbar. <br> '''security.ssl.enable_ocsp_stapling''' = '''false''' <br> '''security.OCSP.enabled''' = '''0''' </blockquote> Those changes prevent verification of ongoing validity because Firefox will no longer check whether any SSL certificate has been revoked. I didn't realize that affected the display of an EVSSL certificate owner's name. either way, keeping OCSP checks enabled is a good security practice.