Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't stop Firefox from updating

  • 8 replies
  • 2 have this problem
  • 84 views
  • Last reply by emmessey

more options

A company I do work for has a web application that ONLY works with IE and pre-38 versions of Firefox. I run the latest Firefox, but also have a v37 version I keep on my Mac with a slightly different name. I only use the 37 version to get into this one web site, so I have created a second profile to be used only with v37 so I can turn off auto-update, set the one web site I need as default, and tweak any other preferences I need. However, it keeps auto-downloading the update even though I turned that feature off in Preferences. It's about 3/4 of the way finished downloading and I can't figure out how to make it stop (other than closing the app!) When it's done will it just not update (if so, where is the file so I can delete it?) If it's going to finish because it has already started (no matter the setting) is there a way to stop it?

All Replies (8)

more options

You can disable automatic updates from the Firefox options dialog. To do so, please try the following:

  1. Open the Firefox options
  2. Navigate the the Advanced section
  3. Open the Update tab
  4. Select Never check for updates (not recommended: security risk)
  5. Uncheck Use a background service to install updates

If that doesn't fix the issue, you can also try changing some settings in the Firefox configuration window, by following these steps:

  1. Enter about:config in the Firefox address bar
  2. Click the I'll be careful, I promise! button
  3. Search for the app.update.auto boolean
  4. Change the value of this boolean to false
  5. Search for the app.update.enabled boolean
  6. Change the value of this boolean to false

The above should stop Firefox from updating automatically, but if you still experience an issue, please let us know.

more options

Hello, if above Wesley Branton's suggestion does not work, then try to lock the preferences :

app.update.auto - false app.update.enabled - false app.update.silent - false

http://kb.mozillazine.org/Locking_preferences

thank you

more options

All of the above settings were already set to false. It's still downloading the update.

more options

try to lock the preferences and probably the problem will be solved

thanks again

more options

No dice... if I understood the procedure properly. I created a mozilla.cfg in the /Applications/Firefox.app/Contents/MacOS directory with:

// lockPref("app.update.auto", 0); lockPref("app.update.enabled", 0); lockPref("app.update.silent", 0);

Then a local-settings.js file in /Applications/Firefox.app/defaults/pref with:

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

I get "Configuration Error Failed to read the configuration file." I believe I've successfully saved both files in "ANSI" per the instructions (I'm using TextWranger in which I think ANSI = Western (Windows Latin 1).

Every time I go in to try something, I get closer to the end of the download. It's like a ticking timebomb!

more options

// lockPref("app.update.auto", false); lockPref("app.update.enabled", false); lockPref("app.update.silent", false);

more options

Same error.

more options

Since I wasn't getting anywhere, I decided to remove the local-settings.js file, let it finish updating, then restore the old version from backup hoping that maybe it wouldn't start updating again. After launching, I went into "About" and it's no longer downloading, and holding at v37. No idea what transpired, but I guess it's good for now.