Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird Signature Problems

  • 12 replies
  • 0 have this problem
  • 1988 views
  • Last reply by Toad-Hall

more options

Hey, if someone with the power to move this to the Thunderbird area is on, please do. I can't ask a question about thunderbird because the page is broken at the moment.

So, this is a question about Thunderbird:

I've been asked to make our e-mail signatures link to facebook. I followed the steps of composing a message, inserting the picture of my e-mail signature, assigned the alt text and putting the link to our facebook page in the link section. My signature works fine. I can send a test e-mail, see my signature, and other people can click on it to go to our facebook page. I repeated the same steps on the first coworker's computer and it works fine. But when I did the same for our accountant and shipping department the link disappears. The pointer icon changes indicating there is a button/link to press but the link doesn't exist.

Chosen solution

Thanks for emails. I have looked at source code and compared results between the two emails. I can see an error in the one from the accounting and shipping computer. So the link does not function but the image itself is ok.

Insert > Image After selecting the image you then click on the 'Link' tab to insert the link address. On the one with a problem you have not typed it correctly. It starts with www. but it should start with https://www.

Correcting this small but important error, you should find everything should work as expected.

Read this answer in context 👍 1

All Replies (12)

more options

christ1 said

http://kb.mozillazine.org/Signatures_(Thunderbird)

This doesn't answer the question, unless I'm blind. I've followed the steps as dictated by Thunderbird and am getting different results on different computers.

more options

I'm presuming you used thunderbird Write window to create a signature html file and then set Account Settings to attach to message ?

Is the image you inserted available on all computers - saved in a folder (not in Thunderbird)? Is the signature html file saved in a folder (not in Thunderbird) on all computers ?

more options

Toad-Hall said

I'm presuming you used thunderbird Write window to create a signature html file and then set Account Settings to attach to message ? Is the image you inserted available on all computers - saved in a folder (not in Thunderbird)? Is the signature html file saved in a folder (not in Thunderbird) on all computers ?

Yes to both. Both the image and the HMTL file are in the same location on the actual computer and not a shared drive. On my computer, it shows the link. On the accountant and shipping computer it removes the link DESPITE me setting the link in the HTML file.

more options

did you set the option to not include the image with the email?

more options

re : On the accountant and shipping computer it removes the link DESPITE me setting the link in the HTML file.

Just to confirm: you copy pasted both the image and the html file into exactly the same location and then set the Account Settings to use that html file.

You mention the link does not work, but can you actually see the image? When you hover over the image does the http link address show up in the bottom status bar?


When you created the html file, you used 'Insert' > 'Image' then clicked on 'choose file' and selected the image file. then selected 'Attach this image to the message', so that the actual image will display.

In the 'Image Location' text box, it would say something like this: file:///C:/Users/User Account name/Desktop/signature%20images/the_peke.JPG

that specific location would be included in the html file, but on the accountant and shipping computer that location could be different. Maybe a different User account name etc.

I would copy paste the image to the new computer and then create a new html file using the Write window and hook up to the image again.

more options

Toad-Hall said

re : On the accountant and shipping computer it removes the link DESPITE me setting the link in the HTML file. Just to confirm: you copy pasted both the image and the html file into exactly the same location and then set the Account Settings to use that html file. You mention the link does not work, but can you actually see the image? When you hover over the image does the http link address show up in the bottom status bar?

When you created the html file, you used 'Insert' > 'Image' then clicked on 'choose file' and selected the image file. then selected 'Attach this image to the message', so that the actual image will display.

In the 'Image Location' text box, it would say something like this: file:///C:/Users/User Account name/Desktop/signature%20images/the_peke.JPG

that specific location would be included in the html file, but on the accountant and shipping computer that location could be different. Maybe a different User account name etc.

I would copy paste the image to the new computer and then create a new html file using the Write window and hook up to the image again.

Okay, I need to re-explain this because people aren't getting my problem, or I'm not understanding the explanations.

The image signature displays for everyone. That's not the problem I'm having. You should be able to click the image and go to our Facebook page. That Facebook link refuses to display on in the signatures of several computers despite following the same process on each computer.

I have attached an image of the signature and and the link below. In the first image, on my computer, you hover over the image, the link to Facebook appears, and you can click it and go to Facebook.

In the second image, the accountant's link, you hover over the image, there is no link to Facebook and you can't go to Facebook by clicking it.

I followed the same steps on both computers, placing the Facebook link in the link spot after inserting the image. I have repeated the steps multiple times. It still acts as if there is a link, with the pointer changing to a finger, but it does not display the path to Facebook nor does it open a browser window when clicked.

more options

Please send me an email from the accountant and shipping computer to this email address: mail at anje dot co dot uk

I do not use that email address for correspondence, as all info will be posted in this forum question, but in your situation, it would be useful for me to look at the source code to see what is going on.

more options

Toad-Hall said

Please send me an email from the accountant and shipping computer to this email address: mail at anje dot co dot uk I do not use that email address for correspondence, as all info will be posted in this forum question, but in your situation, it would be useful for me to look at the source code to see what is going on.

Hi Toad,

Sent one from my computer (where the FB link is working) and one from both the accounting and shipping computers (where the FB link is not working).

more options

Chosen Solution

Thanks for emails. I have looked at source code and compared results between the two emails. I can see an error in the one from the accounting and shipping computer. So the link does not function but the image itself is ok.

Insert > Image After selecting the image you then click on the 'Link' tab to insert the link address. On the one with a problem you have not typed it correctly. It starts with www. but it should start with https://www.

Correcting this small but important error, you should find everything should work as expected.

more options

Toad-Hall said

Thanks for emails. I have looked at source code and compared results between the two emails. I can see an error in the one from the accounting and shipping computer. So the link does not function but the image itself is ok. Insert > Image After selecting the image you then click on the 'Link' tab to insert the link address. On the one with a problem you have not typed it correctly. It starts with www. but it should start with https://www. Correcting this small but important error, you should find everything should work as expected.

Hey Toad,

All works. Thanks for getting this sorted for me. I feel like I didn't type the http:// on my own computer but who knows. All that matters is it's working.

Cheers,

Kyle

more options

Good to hear all is now working correctly.