Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why will it not load over LTE

more options

Just downloaded the iOS app for Firefox. The UI is just amazing but the one thing that gets me is that it will not load if my phone is not connected to Wi-Fi or a hotspot. If it is on 3G or LTE it will not load anything at all. Just wanted to know what is the go around for that.

Thank you!!!!! Keep up the bad-ass work!

Chosen solution

Hi Egotisticpain

What do you mean exactly by "the UI will not load"? Please tell us what you did, what you expected and what happened in as much detail as you can and what version of Firefox you are using (you are using the one from the New Zealand app store right?) what iPhone or iPad or iPod Touch you are using and what version of iOS.

I just did the following on Firefox for iOS build 43 (which is the same build you can find on the New Zealand iOS App Store), iOS 8.4.1, iphone 6 plus:

  1. turned off WiFi so it went over LTE
  2. started up Firefox for iOS
  3. surfed to twitter.com and the site loaded and then tapped on a link and it loaded

Cheers!

...Roland

Read this answer in context 👍 5

All Replies (3)

more options

Chosen Solution

Hi Egotisticpain

What do you mean exactly by "the UI will not load"? Please tell us what you did, what you expected and what happened in as much detail as you can and what version of Firefox you are using (you are using the one from the New Zealand app store right?) what iPhone or iPad or iPod Touch you are using and what version of iOS.

I just did the following on Firefox for iOS build 43 (which is the same build you can find on the New Zealand iOS App Store), iOS 8.4.1, iphone 6 plus:

  1. turned off WiFi so it went over LTE
  2. started up Firefox for iOS
  3. surfed to twitter.com and the site loaded and then tapped on a link and it loaded

Cheers!

...Roland

more options

Roland,

I am using iPhone 6 plus, on iOS 9 beta 5. I have the New Zealand app store through the US. I went to use it as soon as I downloaded it and it would not load a page. I checked google, facebook, msn, cnn, ect. But when I turned on my work iPhone 5C hotspot it worked fine, it loaded everything up in a second. I just checked now before typing this and it is working now on LTE, even faster on LTE. I believe it just needed sometime. Other than that it is working like a champ. I can't wait to get home to see how it works with my MacBook Air with the book marks like Safari or better.

Thank you!

more options

Hi Egotisticpain

Glad it is working now on lte on your iphone6plus ios9beta5, not sure why it didn't work initially. if it happens again, please let me know.

Cheers! ...Roland