X
Tap here to go to the mobile version of the site.

Support Forum

Mac Cmd Click is not opening tab in background.

Posted

This is not happening for all websites though. I noticed this on Tumblr and Gmail. I tried safemode but same problem persists. However rightclicking and selecting "open link in new tab" always open in background.

This is not happening for all websites though. I noticed this on Tumblr and Gmail. I tried safemode but same problem persists. However rightclicking and selecting "open link in new tab" always open in background.

Chosen solution

jscher2000 said

If you mean messages listed in the Gmail inbox, those are scripted, not normal links. I looked at this a couple months ago; does this help: https://support.mozilla.org/questions/1061460#answer-726992 That may or may not help with Tumblr, I haven't tested it myself.

Not messages itself. Any <a> links. However setting loadDivertedInBackground fixes my issue. But this should be the default I believe. I am pressing Cmd to express my intention that this link needs to be loaded in background. For whatever product reason Firefox has chosen to hide this behind loadDivertedInBackground setting. Not cool.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.11
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • Facebook Video Calling by Skype
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • LastPass Plugin
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Picasa plugin.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • Symantec PKI Client
  • WebEx64 General Plugin Container Version 205

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

If you mean messages listed in the Gmail inbox, those are scripted, not normal links. I looked at this a couple months ago; does this help: https://support.mozilla.org/questions/1061460#answer-726992

That may or may not help with Tumblr, I haven't tested it myself.

If you mean messages listed in the Gmail inbox, those are scripted, not normal links. I looked at this a couple months ago; does this help: https://support.mozilla.org/questions/1061460#answer-726992 That may or may not help with Tumblr, I haven't tested it myself.

Chosen Solution

jscher2000 said

If you mean messages listed in the Gmail inbox, those are scripted, not normal links. I looked at this a couple months ago; does this help: https://support.mozilla.org/questions/1061460#answer-726992 That may or may not help with Tumblr, I haven't tested it myself.

Not messages itself. Any <a> links. However setting loadDivertedInBackground fixes my issue. But this should be the default I believe. I am pressing Cmd to express my intention that this link needs to be loaded in background. For whatever product reason Firefox has chosen to hide this behind loadDivertedInBackground setting. Not cool.

''jscher2000 [[#answer-752707|said]]'' <blockquote> If you mean messages listed in the Gmail inbox, those are scripted, not normal links. I looked at this a couple months ago; does this help: https://support.mozilla.org/questions/1061460#answer-726992 That may or may not help with Tumblr, I haven't tested it myself. </blockquote> Not messages itself. Any <a> links. However setting loadDivertedInBackground fixes my issue. But this should be the default I believe. I am pressing Cmd to express my intention that this link needs to be loaded in background. For whatever product reason Firefox has chosen to hide this behind loadDivertedInBackground setting. Not cool.
cor-el
  • Top 10 Contributor
  • Moderator
17412 solutions 157274 answers

The browser.tabs.loadDivertedInBackground pref is used for links that use JavaScript window.open(). The setting in Options/Preferences > General is about the browser.tabs.loadInBackground pref that has effect for normal links

The browser.tabs.loadDivertedInBackground pref is used for links that use JavaScript window.open(). The setting in Options/Preferences > General is about the browser.tabs.loadInBackground pref that has effect for normal links

Question owner

cor-el said

The browser.tabs.loadDivertedInBackground pref is used for links that use JavaScript window.open(). The setting in Options/Preferences > General is about the browser.tabs.loadInBackground pref that has effect for normal links

As a user for Firefox it does not matter to me, whether links are JS generated or not. Pressing Cmd should make it open in background. As a layman user, I don't need to know whether it JS generated or not.

''cor-el [[#answer-752770|said]]'' <blockquote> The browser.tabs.loadDivertedInBackground pref is used for links that use JavaScript window.open(). The setting in Options/Preferences > General is about the browser.tabs.loadInBackground pref that has effect for normal links </blockquote> As a user for Firefox it does not matter to me, whether links are JS generated or not. Pressing Cmd should make it open in background. As a layman user, I don't need to know whether it JS generated or not.