X
Tap here to go to the mobile version of the site.

Support Forum

Youtube Html5 and beep sound

Posted

Ok I was wandering what would happen if I would have full html5 features on youtube So I searched on internet and found out how to enable the features so I ended up enabling this on firefox

media.mediasource.enabled;true media.mediasource.mp4.enabled;true media.fragmented-mp4.exposed;true media.fragmented-mp4.use-blank-decoder;true

After I enabled this features I got the ability to watch 1080P videos and even 60 fps versions were available but the sound did not work anymore. Instead of the original video audio I was getting one long tone sound.

So is there a way to fix this issue or I should create a bug report?

Thank you for your time

Ok I was wandering what would happen if I would have full html5 features on youtube So I searched on internet and found out how to enable the features so I ended up enabling this on firefox media.mediasource.enabled;true media.mediasource.mp4.enabled;true media.fragmented-mp4.exposed;true media.fragmented-mp4.use-blank-decoder;true After I enabled this features I got the ability to watch 1080P videos and even 60 fps versions were available but the sound did not work anymore. Instead of the original video audio I was getting one long tone sound. So is there a way to fix this issue or I should create a bug report? Thank you for your time

Chosen solution

Those prefs are disabled for a reason. MSE works on Windows and Mac, but not on Linux.

445 // Whether to enable MediaSource support.
446 // We want to enable on non-release  builds and on release windows and mac
447 // but on release builds restrict to YouTube. We don't enable for other
448 // configurations because code for those platforms isn't ready yet.
449 #if defined(XP_WIN) || defined(XP_MACOSX)
450 pref("media.mediasource.enabled", true);
451 #else
452 pref("media.mediasource.enabled", false);
453 #endif
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • The Videos 3.10.1 plugin handles video and audio streams.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/Linux/en-US/

Extensions

  • ColorfulTabs 27.3 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • DownThemAll! 2.0.18 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Google Image Search 1.15 ({73007fef-a6e0-47d3-b4e7-dfc116ed6f65})
  • SoundCloud Downloader - Technowise 0.94 ({c8d3bc80-0810-4d21-a2c2-be5f2b2832ac})
  • uBlock 0.9.3.5 ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})
  • Video Downloader professional 1.97.37 (ffext_basicvideoext@startpage24)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com) (Inactive)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net) (Inactive)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net) (Inactive)
  • Unity Websites integration 2014.08.06.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 9500 GT/PCIe/SSE2
  • adapterDeviceID: GeForce 9500 GT/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 340.76
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 9500 GT/PCIe/SSE2
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Chosen Solution

Those prefs are disabled for a reason. MSE works on Windows and Mac, but not on Linux.

445 // Whether to enable MediaSource support.
446 // We want to enable on non-release  builds and on release windows and mac
447 // but on release builds restrict to YouTube. We don't enable for other
448 // configurations because code for those platforms isn't ready yet.
449 #if defined(XP_WIN) || defined(XP_MACOSX)
450 pref("media.mediasource.enabled", true);
451 #else
452 pref("media.mediasource.enabled", false);
453 #endif
Those prefs are disabled for a reason. MSE works on Windows and Mac, but not on Linux. *http://mxr.mozilla.org/mozilla-release/source/modules/libpref/init/all.js#445 <pre><nowiki> 445 // Whether to enable MediaSource support. 446 // We want to enable on non-release builds and on release windows and mac 447 // but on release builds restrict to YouTube. We don't enable for other 448 // configurations because code for those platforms isn't ready yet. 449 #if defined(XP_WIN) || defined(XP_MACOSX) 450 pref("media.mediasource.enabled", true); 451 #else 452 pref("media.mediasource.enabled", false); 453 #endif</nowiki></pre>
CiRiX 2 solutions 8 answers

Helpful Reply

I think I got a fix for you!

After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen.

I did some digging and I found out that it was "media.fragmented-mp4.exposed" that was causing this problem.

So all I had to do was to turn everything to "true", and leaving "media.fragmented-mp4.exposed" on "false".


I was then able to view 1080p videos without any problems.

I hope this helps :)

'''I think I got a fix for you!''' After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen. I did some digging and I found out that it was "''media.fragmented-mp4.exposed''" that was causing this problem. So all I had to do was to turn everything to "''true''", and leaving "''media.fragmented-mp4.exposed''" on "''false''". I was then able to view 1080p videos without any problems. I hope this helps :)
Luxx 0 solutions 2 answers

CiRiX said

I think I got a fix for you! After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen. I did some digging and I found out that it was "media.fragmented-mp4.exposed" that was causing this problem. So all I had to do was to turn everything to "true", and leaving "media.fragmented-mp4.exposed" on "false". I was then able to view 1080p videos without any problems. I hope this helps :)

I have been getting a blank green screen and a long annoying BEEEEEEEEP on any JW Player video. I can't believe it! I've been trying to figure out a fix for this for over a MONTH. Thank you. Your fix worked. I am using Linux, btw, and it works fine now, FINALLY, with "media.fragmented-mp4.exposed" on "false".

''CiRiX [[#answer-762563|said]]'' <blockquote> '''I think I got a fix for you!''' After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen. I did some digging and I found out that it was "''media.fragmented-mp4.exposed''" that was causing this problem. So all I had to do was to turn everything to "''true''", and leaving "''media.fragmented-mp4.exposed''" on "''false''". I was then able to view 1080p videos without any problems. I hope this helps :) </blockquote> '''''I have been getting a blank green screen and a long annoying BEEEEEEEEP on any JW Player video. I can't believe it! I've been trying to figure out a fix for this for over a MONTH. Thank you. Your fix worked. I am using Linux, btw, and it works fine now, FINALLY, with "''media.fragmented-mp4.exposed''" on "''false''".

Modified by Luxx

CiRiX 2 solutions 8 answers

Luxx said

CiRiX said
I think I got a fix for you! After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen. I did some digging and I found out that it was "media.fragmented-mp4.exposed" that was causing this problem. So all I had to do was to turn everything to "true", and leaving "media.fragmented-mp4.exposed" on "false". I was then able to view 1080p videos without any problems. I hope this helps :)

I have been getting a blank green screen and a long annoying BEEEEEEEEP on any JW Player video. I can't believe it! I've been trying to figure out a fix for this for over a MONTH. Thank you. Your fix worked. I am using Linux, btw, and it works fine now, FINALLY, with "media.fragmented-mp4.exposed" on "false".

I am glad it worked out! :)
''Luxx [[#answer-764940|said]]'' <blockquote> ''CiRiX [[#answer-762563|said]]'' <blockquote> '''I think I got a fix for you!''' After I updated my OS to Windows 10, and did these changes in about:config to get 1080p, some of the videos were making this sound, and some videos even had a completely green screen. I did some digging and I found out that it was "''media.fragmented-mp4.exposed''" that was causing this problem. So all I had to do was to turn everything to "''true''", and leaving "''media.fragmented-mp4.exposed''" on "''false''". I was then able to view 1080p videos without any problems. I hope this helps :) </blockquote> '''''I have been getting a blank green screen and a long annoying BEEEEEEEEP on any JW Player video. I can't believe it! I've been trying to figure out a fix for this for over a MONTH. Thank you. Your fix worked. I am using Linux, btw, and it works fine now, FINALLY, with "''media.fragmented-mp4.exposed''" on "''false''". </blockquote> I am glad it worked out! :)