X
Tap here to go to the mobile version of the site.

Support Forum

cannot connect to localhost:1410

Posted

Hi: I've googled for about 2 days and then sent my question to fedoraforum.org but didn't get any useful responses atleast yet. Then I started looking on the mozilla forum and it seems that this problem has been encountered before but I'm not knowledgeable enough to understand how to fix it. I went through both documents that explain about ipv6, dns prefetching, clearing you cache etc but still no luck. Here's my problem, but like I said, I think other people have had it also.

Background:

I am learning how to write code to access data from github by using the github api. It is actually an on line course assignment where the problem popped up. no pun intended. I am using linux fedora 19. At the github application site, you need to specify a callback url so that github has some place to send the data that you retrieved back to you. ( this is atleast how I understand it. this is all quite new to me. my understanding could be incorrect ).

So, then I googled and found a note where someone recommended using http://localhost:1410 as the callback url in the github api where you get the secret key etc. So, I use http://localhost:1410 as suggested. But that person might use windows or internet explorer so I don't know if using localhost:1410 is correct. Maybe I should be using something else ?

PROBLEM:

To make a long story shorter, when I use that localhost:1410, I get the error that mozilla cannot access that site. Like I said, I've seen other threads on mozilla support with similar issues but the solutions weren't clear to me. I am not using a proxy so my connection settings are basically blank except that No Proxy is filled in.

My other thought was that maybe I'm supposed to type 1410 somewhere on the connection settings page. It also says No Proxy for localhost.127.0.0.1 but it's very light so I don't think that's actually enabled.

If anyone would be willing to help, I'd really appreciate it. I've spent the better part of two days and my knowledge is limited so I'm pretty stuck. Also, if you need any more information or need me to do anything, I'll gladly be as helpful as I can possibly be. Thank you very much. The fact that mozilla has this support forum is very kool. I never knew about it until today. Thanks again.

Hi: I've googled for about 2 days and then sent my question to fedoraforum.org but didn't get any useful responses atleast yet. Then I started looking on the mozilla forum and it seems that this problem has been encountered before but I'm not knowledgeable enough to understand how to fix it. I went through both documents that explain about ipv6, dns prefetching, clearing you cache etc but still no luck. Here's my problem, but like I said, I think other people have had it also. Background: I am learning how to write code to access data from github by using the github api. It is actually an on line course assignment where the problem popped up. no pun intended. I am using linux fedora 19. At the github application site, you need to specify a callback url so that github has some place to send the data that you retrieved back to you. ( this is atleast how I understand it. this is all quite new to me. my understanding could be incorrect ). So, then I googled and found a note where someone recommended using http://localhost:1410 as the callback url in the github api where you get the secret key etc. So, I use http://localhost:1410 as suggested. But that person might use windows or internet explorer so I don't know if using localhost:1410 is correct. Maybe I should be using something else ? PROBLEM: To make a long story shorter, when I use that localhost:1410, I get the error that mozilla cannot access that site. Like I said, I've seen other threads on mozilla support with similar issues but the solutions weren't clear to me. I am not using a proxy so my connection settings are basically blank except that No Proxy is filled in. My other thought was that maybe I'm supposed to type 1410 somewhere on the connection settings page. It also says No Proxy for localhost.127.0.0.1 but it's very light so I don't think that's actually enabled. If anyone would be willing to help, I'd really appreciate it. I've spent the better part of two days and my knowledge is limited so I'm pretty stuck. Also, if you need any more information or need me to do anything, I'll gladly be as helpful as I can possibly be. Thank you very much. The fact that mozilla has this support forum is very kool. I never knew about it until today. Thanks again.

Chosen solution

When Firefox contacts http://localhost/ it is pointed back to your system. Are you running the Apache webserver (or another webserver) on your system and, if so, is it configured to respond on port 1410 or another port?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.40.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealDownloader Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealPlayer Download Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Shockwave Flash 16.0 r0
  • Shockwave Flash 11.3 r300
  • 5.1.30514.0
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

jscher2000
  • Top 10 Contributor
8792 solutions 71895 answers

Chosen Solution

When Firefox contacts http://localhost/ it is pointed back to your system. Are you running the Apache webserver (or another webserver) on your system and, if so, is it configured to respond on port 1410 or another port?

When Firefox contacts http://localhost/ it is pointed back to your system. Are you running the Apache webserver (or another webserver) on your system and, if so, is it configured to respond on port 1410 or another port?

Question owner

Hi: Thank you for your response. The problem was solved in the following way. There is a package called httpuv in R. I don't understand it very well but it uses sockets and supposedly allows you to connect to the localhost if you run your code through Rstudio ( a particular ide for R ). I was under the impression that you only needed this package only if you were using Rstudio. Also, I had trouble installing it anyway so I didn't worry about it.

Today, someone helped me to install it and, once I did that, the problem went away. I was able to connect to localhost:1410. As far as your question, I don't know the answer to that ? Is there a way for me to tell what webserver I am running on my system. That's just for my own learning purposes. The localhost connection is now working fine. Thank you for your help. I really appreciate it. This is an amazing forum with great articles.










mlofton said

Hi: I've googled for about 2 days and then sent my question to fedoraforum.org but didn't get any useful responses atleast yet. Then I started looking on the mozilla forum and it seems that this problem has been encountered before but I'm not knowledgeable enough to understand how to fix it. I went through both documents that explain about ipv6, dns prefetching, clearing you cache etc but still no luck. Here's my problem, but like I said, I think other people have had it also. Background: I am learning how to write code to access data from github by using the github api. It is actually an on line course assignment where the problem popped up. no pun intended. I am using linux fedora 19. At the github application site, you need to specify a callback url so that github has some place to send the data that you retrieved back to you. ( this is atleast how I understand it. this is all quite new to me. my understanding could be incorrect ). So, then I googled and found a note where someone recommended using http://localhost:1410 as the callback url in the github api where you get the secret key etc. So, I use http://localhost:1410 as suggested. But that person might use windows or internet explorer so I don't know if using localhost:1410 is correct. Maybe I should be using something else ? PROBLEM: To make a long story shorter, when I use that localhost:1410, I get the error that mozilla cannot access that site. Like I said, I've seen other threads on mozilla support with similar issues but the solutions weren't clear to me. I am not using a proxy so my connection settings are basically blank except that No Proxy is filled in. My other thought was that maybe I'm supposed to type 1410 somewhere on the connection settings page. It also says No Proxy for localhost.127.0.0.1 but it's very light so I don't think that's actually enabled. If anyone would be willing to help, I'd really appreciate it. I've spent the better part of two days and my knowledge is limited so I'm pretty stuck. Also, if you need any more information or need me to do anything, I'll gladly be as helpful as I can possibly be. Thank you very much. The fact that mozilla has this support forum is very kool. I never knew about it until today. Thanks again.
Hi: Thank you for your response. The problem was solved in the following way. There is a package called httpuv in R. I don't understand it very well but it uses sockets and supposedly allows you to connect to the localhost if you run your code through Rstudio ( a particular ide for R ). I was under the impression that you only needed this package only if you were using Rstudio. Also, I had trouble installing it anyway so I didn't worry about it. Today, someone helped me to install it and, once I did that, the problem went away. I was able to connect to localhost:1410. As far as your question, I don't know the answer to that ? Is there a way for me to tell what webserver I am running on my system. That's just for my own learning purposes. The localhost connection is now working fine. Thank you for your help. I really appreciate it. This is an amazing forum with great articles. ''mlofton [[#question-1057431|said]]'' <blockquote> Hi: I've googled for about 2 days and then sent my question to fedoraforum.org but didn't get any useful responses atleast yet. Then I started looking on the mozilla forum and it seems that this problem has been encountered before but I'm not knowledgeable enough to understand how to fix it. I went through both documents that explain about ipv6, dns prefetching, clearing you cache etc but still no luck. Here's my problem, but like I said, I think other people have had it also. Background: I am learning how to write code to access data from github by using the github api. It is actually an on line course assignment where the problem popped up. no pun intended. I am using linux fedora 19. At the github application site, you need to specify a callback url so that github has some place to send the data that you retrieved back to you. ( this is atleast how I understand it. this is all quite new to me. my understanding could be incorrect ). So, then I googled and found a note where someone recommended using http://localhost:1410 as the callback url in the github api where you get the secret key etc. So, I use http://localhost:1410 as suggested. But that person might use windows or internet explorer so I don't know if using localhost:1410 is correct. Maybe I should be using something else ? PROBLEM: To make a long story shorter, when I use that localhost:1410, I get the error that mozilla cannot access that site. Like I said, I've seen other threads on mozilla support with similar issues but the solutions weren't clear to me. I am not using a proxy so my connection settings are basically blank except that No Proxy is filled in. My other thought was that maybe I'm supposed to type 1410 somewhere on the connection settings page. It also says No Proxy for localhost.127.0.0.1 but it's very light so I don't think that's actually enabled. If anyone would be willing to help, I'd really appreciate it. I've spent the better part of two days and my knowledge is limited so I'm pretty stuck. Also, if you need any more information or need me to do anything, I'll gladly be as helpful as I can possibly be. Thank you very much. The fact that mozilla has this support forum is very kool. I never knew about it until today. Thanks again. </blockquote>
jscher2000
  • Top 10 Contributor
8792 solutions 71895 answers

You can inspect responses from your local webserver to see how it identifies itself. From the Developer menu, open the Web Console. This should appear in the bottom of the current tab. If you load a page from localhost, a line should appear int he console for that request. If you click it, a small dialog will appear showing the Request and Response headers. Usually the Response headers will identify the server software.

You can inspect responses from your local webserver to see how it identifies itself. From the Developer menu, open the Web Console. This should appear in the bottom of the current tab. If you load a page from localhost, a line should appear int he console for that request. If you click it, a small dialog will appear showing the Request and Response headers. Usually the Response headers will identify the server software.

Question owner

Thank you very much for your explanation. I will try what you said and let you know how it goes. I really appreciate your generosity and patience.

                                                                             Mark
Thank you very much for your explanation. I will try what you said and let you know how it goes. I really appreciate your generosity and patience. Mark
cor-el
  • Top 10 Contributor
  • Moderator
17573 solutions 158952 answers
See also: *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Tools/Browser_Console

Helpful Reply

Hi J Scher2000: I followed your instructions and received below when opened developer icon and then the browser console. Unfortunately it says http server unknown. But atleast it worked.

I'm quite satisified with what you've said so if I can't figure out the server, it's not a big deal. That was more for learning purposes.

Thank you for your great help and it's nice to meet you. I know where to go if I have problems in the future. All the best.


  1. ===============================================================


Request URL: https://safebrowsing.google.com/safebrowsing/downloads?client=navclient-auto-ffox&appver=34.0&pver=2.2&key=no-google-api-key Request Method: POST Status Code: HTTP/1.1 200 OK Request Headers 03:16:45.000 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 Pragma: no-cache Host: safebrowsing.google.com Content-Type: text/plain Content-Length: 166 Connection: keep-alive Cache-Control: no-cache Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Sent Cookie PREF: ID=ce5fa9c670f0cf47:TM=1429107341:LM=1429107341:S=GqwEB4EXvA67sgBH Response Headers Δ93ms X-XSS-Protection: 1; mode=block X-Frame-Options: SAMEORIGIN X-Firefox-Spdy: 3.1 x-content-type-options: nosniff Server: HTTP server (unknown) Date: Fri, 17 Apr 2015 07:13:36 GMT Content-Type: application/vnd.google.safebrowsing-update Content-Length: 414 Alternate-Protocol: 443:quic,p=1

Hi J Scher2000: I followed your instructions and received below when opened developer icon and then the browser console. Unfortunately it says http server unknown. But atleast it worked. I'm quite satisified with what you've said so if I can't figure out the server, it's not a big deal. That was more for learning purposes. Thank you for your great help and it's nice to meet you. I know where to go if I have problems in the future. All the best. #=============================================================== Request URL: https://safebrowsing.google.com/safebrowsing/downloads?client=navclient-auto-ffox&appver=34.0&pver=2.2&key=no-google-api-key Request Method: POST Status Code: HTTP/1.1 200 OK Request Headers 03:16:45.000 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 Pragma: no-cache Host: safebrowsing.google.com Content-Type: text/plain Content-Length: 166 Connection: keep-alive Cache-Control: no-cache Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 Sent Cookie PREF: ID=ce5fa9c670f0cf47:TM=1429107341:LM=1429107341:S=GqwEB4EXvA67sgBH Response Headers Δ93ms X-XSS-Protection: 1; mode=block X-Frame-Options: SAMEORIGIN X-Firefox-Spdy: 3.1 x-content-type-options: nosniff Server: HTTP server (unknown) Date: Fri, 17 Apr 2015 07:13:36 GMT Content-Type: application/vnd.google.safebrowsing-update Content-Length: 414 Alternate-Protocol: 443:quic,p=1
jscher2000
  • Top 10 Contributor
8792 solutions 71895 answers

Hi mlofton, it would be worth looking at a few more requests. That one seems to be a response from a Google server instead of from your localhost (judging from the host listed in the Request Headers).

Hi mlofton, it would be worth looking at a few more requests. That one seems to be a response from a Google server instead of from your localhost (judging from the host listed in the Request Headers).

Question owner

Hi: Do you know how I can make sure that the request is from the local host ? Should I just type in http://localhost:1410 inside the browser ? Basically, I'm not sure how to request from the localhost. thanks.

Hi: Do you know how I can make sure that the request is from the local host ? Should I just type in http://localhost:1410 inside the browser ? Basically, I'm not sure how to request from the localhost. thanks.

Modified by mlofton

jscher2000
  • Top 10 Contributor
8792 solutions 71895 answers

I guess the callback is unpredictable and could be buried in the noise. If you are using the Browser Console (Ctrl+Shift+j) there is filter/search box in the upper right corner. If you type localhost in that box, any matching entries should be displayed. I'm not sure of the "capacity" of the console, i.e., how many page loads of data are retained, so perhaps it is more efficient to access it directly as you proposed.

I guess the callback is unpredictable and could be buried in the noise. If you are using the Browser Console (Ctrl+Shift+j) there is filter/search box in the upper right corner. If you type localhost in that box, any matching entries should be displayed. I'm not sure of the "capacity" of the console, i.e., how many page loads of data are retained, so perhaps it is more efficient to access it directly as you proposed.