X
Tap here to go to the mobile version of the site.

Support Forum

Why does my ZTE open c Firefox OS smart phone forget the wlan settings and does not ring the alarm?

Posted

Sometimes it is even enough to go outside to the waste bin to let my smartphone forget the settings for the wireless lan. When I return I have to enter the - not so short - code from my wlan router again. After that the internet connection is running as it should.

Additionally the alarm clock does not work, I can set alarms as I like, setting the volume to the max and activate also the vibration alarm but nothing happens when the preset time is arrived, even when the alarm clock is shown on the screen the whole time. Is my phone broken? Or is it a bug in my Firefox OS installation?

Where does Firefox OS store these values for wlan connection and alarm times? Is there an internal database that is maybe corrupted?

Sometimes it is even enough to go outside to the waste bin to let my smartphone forget the settings for the wireless lan. When I return I have to enter the - not so short - code from my wlan router again. After that the internet connection is running as it should. Additionally the alarm clock does not work, I can set alarms as I like, setting the volume to the max and activate also the vibration alarm but nothing happens when the preset time is arrived, even when the alarm clock is shown on the screen the whole time. Is my phone broken? Or is it a bug in my Firefox OS installation? Where does Firefox OS store these values for wlan connection and alarm times? Is there an internal database that is maybe corrupted?

Chosen solution

Hi Markus,

I understand that you're having issues with the Wi-Fi connection and the alarm clock in your ZTE Open C device.

The alarm clock issue appears to be similar to what has been reported by other users and is being tracked on bug 1052245.

Do you have more information regarding the alarm clock issues that you encounter? This may be very helpful to our engineering teams investigating. Please be aware that ZTE is the manufacturer of your device, and only they are able to release an update.

The wifi issue may be related to bug 923324.

Please reply to this message with the following information:

  • What is the OS version and Build ID found in the Device Information page? Please visit this link if you need help finding the Build ID of your phone.
  • Please provide the exact steps to reproduce the issue you are encountering.
  • How often do you encounter this issue?

Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we have all the necessary information to investigate this behavior.

- Ralph

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Chosen Solution

Hi Markus,

I understand that you're having issues with the Wi-Fi connection and the alarm clock in your ZTE Open C device.

The alarm clock issue appears to be similar to what has been reported by other users and is being tracked on bug 1052245.

Do you have more information regarding the alarm clock issues that you encounter? This may be very helpful to our engineering teams investigating. Please be aware that ZTE is the manufacturer of your device, and only they are able to release an update.

The wifi issue may be related to bug 923324.

Please reply to this message with the following information:

  • What is the OS version and Build ID found in the Device Information page? Please visit this link if you need help finding the Build ID of your phone.
  • Please provide the exact steps to reproduce the issue you are encountering.
  • How often do you encounter this issue?

Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we have all the necessary information to investigate this behavior.

- Ralph

Hi Markus, I understand that you're having issues with the Wi-Fi connection and the alarm clock in your ZTE Open C device. The alarm clock issue appears to be similar to what has been reported by other users and is being tracked on [https://bugzilla.mozilla.org/show_bug.cgi?id=1052245 bug 1052245]. Do you have more information regarding the alarm clock issues that you encounter? This may be very helpful to our engineering teams investigating. Please be aware that ZTE is the manufacturer of your device, and only they are able to release an update. The wifi issue may be related to [https://bugzilla.mozilla.org/show_bug.cgi?id=923324 bug 923324]. Please reply to this message with the following information: * What is the OS version and Build ID found in the Device Information page? Please visit [https://support.mozilla.org/en-US/kb/how-do-i-find-what-version-firefox-os-i-have this link] if you need help finding the Build ID of your phone. * Please provide the exact steps to reproduce the issue you are encountering. * How often do you encounter this issue? Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we have all the necessary information to investigate this behavior. - Ralph

Question owner

Hello Ralph,

thank you for your very long message. Unfortunately I cannot reproduce this error currently because after I reset the phone everything is working well.

But I had always the most recent version that the updater installed.

So maybe it is a good idea to make a backup of all stored data and especially the contacts and do a complete reset. Currently my phone stores not only the wifi credentials at home but also in the office. And after reaching one of these locations the connection is established automatically, sometimes I have to to a restart to push it to do so. But that does not bother me.

Best regards Markus

Hello Ralph, thank you for your very long message. Unfortunately I cannot reproduce this error currently because after I reset the phone everything is working well. But I had always the most recent version that the updater installed. So maybe it is a good idea to make a backup of all stored data and especially the contacts and do a complete reset. Currently my phone stores not only the wifi credentials at home but also in the office. And after reaching one of these locations the connection is established automatically, sometimes I have to to a restart to push it to do so. But that does not bother me. Best regards Markus