X
Tap here to go to the mobile version of the site.

Support Forum

On Firefox 34.0.1 for android running 4.3 JellyBean, why is the flash content showing up as a gray box?

Posted

I used to have no problem using Firefox on my phone. I have an HTC One M7 with Android OS 4.3. As you may know, this phone came pre installed with Adobe flash. I would use my native browser but Lookout alerted me to a vulnerability on android browsers for OS 4.3 and below. Because of this, I installed Firefox. When it came to playing flash content, I had no problems viewing it through Firefox. About a couple weeks ago I started to notice issues with the flash content. I figured I needed to update Firefox so I did that. I still had the same problem. I also "force closed", restarted the phone, cleared the data and did a uninstall/reinstall. Nothing worked. I also went ahead and updated my flash player to the most up to date available. That hasn't worked either. I decided to test out Firefox on my old HTC EVO 4G with Android OS 2.3.5. Believe it or not, the same problem is occurring there so I KNOW it has to be something with Firefox. Did Firefox change something recently which is causing this issue??? Is there anything that can be done to solve this problem? I even tried installing an older version of Firefox (32 & 33) and still had the same issue. Someone please help.

I used to have no problem using Firefox on my phone. I have an HTC One M7 with Android OS 4.3. As you may know, this phone came pre installed with Adobe flash. I would use my native browser but Lookout alerted me to a vulnerability on android browsers for OS 4.3 and below. Because of this, I installed Firefox. When it came to playing flash content, I had no problems viewing it through Firefox. About a couple weeks ago I started to notice issues with the flash content. I figured I needed to update Firefox so I did that. I still had the same problem. I also "force closed", restarted the phone, cleared the data and did a uninstall/reinstall. Nothing worked. I also went ahead and updated my flash player to the most up to date available. That hasn't worked either. I decided to test out Firefox on my old HTC EVO 4G with Android OS 2.3.5. Believe it or not, the same problem is occurring there so I KNOW it has to be something with Firefox. Did Firefox change something recently which is causing this issue??? Is there anything that can be done to solve this problem? I even tried installing an older version of Firefox (32 & 33) and still had the same issue. Someone please help.
Attached screenshots

Modified by twisterspin3

Chosen solution

It should be fixed now https://bugzilla.mozilla.org/show_bug.cgi?id=1112086#c23

Note that Bugzilla is Not a discussion forum like here.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; McAfee; InfoPath.2; rv:11.0) like Gecko

More Information

petef 4 solutions 60 answers

Helpful Reply

I have a very similar problem, as do lots of others judging by the number of posts in this forum. I use Flash rarely, so unsure when things went wrong, but I first noticed with Fx 34.0. I tried 34.1 - same. Now on 33.1 - same. Not prepared to try reinstalling any earlier versions as it's so much work (have to uninstall Fx completely, reinstall from backup and set up Fx completely from scratch including all add-ons). What I have found is that if I reinstall Flash, then it works the first time Fx is used. Once Fx has been completely closed down, then Flash will not work in Fx again until Flash is again reinstalled. Obviously this is not a working solution. Android 4.2.2

I have a very similar problem, as do lots of others judging by the number of posts in this forum. I use Flash rarely, so unsure when things went wrong, but I first noticed with Fx 34.0. I tried 34.1 - same. Now on 33.1 - same. Not prepared to try reinstalling any earlier versions as it's so much work (have to uninstall Fx completely, reinstall from backup and set up Fx completely from scratch including all add-ons). What I have found is that if I reinstall Flash, then it works the first time Fx is used. Once Fx has been completely closed down, then Flash will not work in Fx again until Flash is again reinstalled. Obviously this is not a working solution. Android 4.2.2
Ererer 15 solutions 94 answers

I have the same issue, but using Android 4.4.2

I have the same issue, but using Android 4.4.2
petef 4 solutions 60 answers

It seems there are lots of people having this problem. Does Flash work for anyone now?

It seems there are lots of people having this problem. Does Flash work for anyone now?
James
  • Moderator
1594 solutions 11229 answers

Chosen Solution

It should be fixed now https://bugzilla.mozilla.org/show_bug.cgi?id=1112086#c23

Note that Bugzilla is Not a discussion forum like here.

It should be fixed now https://bugzilla.mozilla.org/show_bug.cgi?id=1112086#c23 Note that Bugzilla is Not a discussion forum like here.
petef 4 solutions 60 answers

Thanks James. Flash now working for me. Fx 3.1 Android 4.2.2.

Thanks James. Flash now working for me. Fx 3.1 Android 4.2.2.
James
  • Moderator
1594 solutions 11229 answers

You meant Fx 34.0.1  ;)

You meant Fx 34.0.1 ;)
Ererer 15 solutions 94 answers

Thanks, James! Now it works

Thanks, James! Now it works

Question owner

Well I'll be darned, its working again. Thanks so much. Now let me do some testing just to make sure.

Well I'll be darned, its working again. Thanks so much. Now let me do some testing just to make sure.