X
Tap here to go to the mobile version of the site.

Support Forum

Help! My 2.2 update bricked my Flame phone!

Posted

I love FirefoxOS, but clearly I'm a noob playing around where I shouldn't - so please help me!!

I've been using various versions on my Flame phone and have been able to successfully put v1.3, v1.4 and v2.1 on my phone using a Mac, a USB cable and adb via terminal and the shallowflash tool. However, I recently tried to install v2.2 (30-Sep-2014 nightly build) and it seemed to brick my phone - even though the adb terminal said Push was successful, after it rebooted, then the Flame gets hung on the Thundersoft logo forever.

So I removed battery, nothing - still hung on Thundersoft logo.

So I tried the power+volume up+home to get to the menu and I did a factory reset from that menu and then that seemed to work, then reboot still gets hung on Thundersoft logo.

So I searched around and found this page's Troubleshooting: Which showed how to get into fastboot sideload mode: https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame

So I did that, and then finally the phone was showing up in terminal when I used "fastboot devices"

So then I found this page: https://hacks.mozilla.org/2013/06/updating-and-tweaking-your-firefox-os-developer-preview-phonegeeksphone/

And followed the steps under "Ok, so I bricked my phone" and in terminal entered these steps in the folder of the base download for Flame_2.0_v180_1

    fastboot flash recovery recovery.img
    fastboot flash boot boot.img
    fastboot flash userdata userdata.img
    fastboot flash system system.img
    fastboot reboot

All the steps said [OKAY] so I thought it was all worked, but I borked something because now the Flame not only gets stuck on the Thundersoft logo, but now it repeatedly reboots every 2 secs without touching it once it is on back and forth to the Thundersoft logo.

Can anyone please help me?? At this stage I'd even love to go back to v1.4 - I hope I haven't ruined my Flame phone.

thanks very much for any step by step instructions on how to fix this. :)

I love FirefoxOS, but clearly I'm a noob playing around where I shouldn't - so please help me!! I've been using various versions on my Flame phone and have been able to successfully put v1.3, v1.4 and v2.1 on my phone using a Mac, a USB cable and adb via terminal and the shallowflash tool. However, I recently tried to install v2.2 (30-Sep-2014 nightly build) and it seemed to brick my phone - even though the adb terminal said Push was successful, after it rebooted, then the Flame gets hung on the Thundersoft logo forever. So I removed battery, nothing - still hung on Thundersoft logo. So I tried the power+volume up+home to get to the menu and I did a factory reset from that menu and then that seemed to work, then reboot still gets hung on Thundersoft logo. So I searched around and found this page's Troubleshooting: Which showed how to get into fastboot sideload mode: https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame So I did that, and then finally the phone was showing up in terminal when I used "fastboot devices" So then I found this page: https://hacks.mozilla.org/2013/06/updating-and-tweaking-your-firefox-os-developer-preview-phonegeeksphone/ And followed the steps under "Ok, so I bricked my phone" and in terminal entered these steps in the folder of the base download for Flame_2.0_v180_1 fastboot flash recovery recovery.img fastboot flash boot boot.img fastboot flash userdata userdata.img fastboot flash system system.img fastboot reboot All the steps said [OKAY] so I thought it was all worked, but I borked something because now the Flame not only gets stuck on the Thundersoft logo, but now it repeatedly reboots every 2 secs without touching it once it is on back and forth to the Thundersoft logo. Can anyone please help me?? At this stage I'd even love to go back to v1.4 - I hope I haven't ruined my Flame phone. thanks very much for any step by step instructions on how to fix this. :)

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

Question owner

In case anyone gets this problem. I eventually fixed the non-stop reboots, by taking out the battery and rebooting with holding POWER+VolumeDOWN and then it stopped rebooting and in terminal I could see the device with "fastboot devices"

So I went to the basev180 folder "Flame_2.0_v180_1" and ran .\flash.sh and it seemed to re flash my device and eventually it booted up with the 2.0.0.0 prerelease and is working again.

I'm still afraid to update to 2.2 now, but I might try to update to 2.1 which worked in the past. So maybe someone can clarify what happened to me and how to avoid this problem in the future??

thanks!

In case anyone gets this problem. I eventually fixed the non-stop reboots, by taking out the battery and rebooting with holding POWER+VolumeDOWN and then it stopped rebooting and in terminal I could see the device with "fastboot devices" So I went to the basev180 folder "Flame_2.0_v180_1" and ran .\flash.sh and it seemed to re flash my device and eventually it booted up with the 2.0.0.0 prerelease and is working again. I'm still afraid to update to 2.2 now, but I might try to update to 2.1 which worked in the past. So maybe someone can clarify what happened to me and how to avoid this problem in the future?? thanks!
holztest08 0 solutions 6 answers

Hi, I had the same problem with flashing to 2.1 or 2.2. It hung up on ThunderSoft logo. My solution was to run flash.sh again with 2.0 although I could only see the ThunderSoft logo.

Hi, I had the same problem with flashing to 2.1 or 2.2. It hung up on ThunderSoft logo. My solution was to run flash.sh again with 2.0 although I could only see the ThunderSoft logo.
Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Hi ppdev,

If installing v2.1 or 2.2, or a newer v2.0 build on your device, you must first flash the v180 Base Build - the same one that resolved your issue through Fastboot.

If you attempt to flash v2.1 or v2.2 on your device again, it *should* work correctly since you now have the v180 Base Build installed underneath it all. =)

I hope thatyou find this information helpful. Please let us know if you have any other questions or comments about your Firefox OS Flame device.

Thanks,

- Ralph

Hi ppdev, If installing v2.1 or 2.2, or a newer v2.0 build on your device, you must first flash the v180 Base Build - the same one that resolved your issue through Fastboot. If you attempt to flash v2.1 or v2.2 on your device again, it *should* work correctly since you now have the v180 Base Build installed underneath it all. =) I hope thatyou find this information helpful. Please let us know if you have any other questions or comments about your Firefox OS Flame device. Thanks, - Ralph
holztest08 0 solutions 6 answers

Hi,

for me this doesn't work. After flashing v180 Base Build I still couldn't flash to v2.1. It hung up on ThunderSoft logo.

Hi, for me this doesn't work. After flashing v180 Base Build I still couldn't flash to v2.1. It hung up on ThunderSoft logo.
Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Hi holztest08,

I'm sorry to hear you are still having problems flashing your Flame device to v2.1.

Where did you download the v180 Base Build and the v2.1 images from?

Can you attempt to re-download the latest images from MDN's Updating Your Flame's software page? You can use the following links for the latest images:

I hope this information is helpful. Please let us know if you are successful flashing your Flame device with v2.1, or if you have any other questions about your Firefox OS device.

Thanks,

- Ralph

Hi holztest08, I'm sorry to hear you are still having problems flashing your Flame device to v2.1. Where did you download the v180 Base Build and the v2.1 images from? Can you attempt to re-download the latest images from MDN's '''[https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame#Updating_your_Flame%27s_software Updating Your Flame's software]''' page? You can use the following links for the latest images: * [http://cds.w5v8t3u9.hwcdn.net/Flame_2.0_v180_1.zip Flame 2.0 v180 Base Image] * [http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-aurora-flame-kk/ Latest Aurora (v2.1) Production Build] * [http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-aurora-flame-kk-eng/ Latest Aurora (v2.1) Engineering Builds - with test apps and only pseudo-locales] I hope this information is helpful. Please let us know if you are successful flashing your Flame device with v2.1, or if you have any other questions about your Firefox OS device. Thanks, - Ralph
holztest08 0 solutions 6 answers

Hi, thanks, but the same problem with this links. I flash it with v180 Base Image and then I tried to flash it with v2.1. Regards

Hi, thanks, but the same problem with this links. I flash it with v180 Base Image and then I tried to flash it with v2.1. Regards