Wiederherstellen wichtiger Daten aus einem alten Profil

Wenn Sie zunehmend Probleme mit Firefox bekommen, empfiehlt es sich, einfach ein neues Firefox-Profil anzulegen und dort Ihre wichtigsten Daten hinein zu kopieren, anstatt den genauen Grund des Problems zu suchen und zu beheben.

Ein Firefox-Profil speichert alle Ihre wichtigen Daten wie Lesezeichen, Chronik, Passwörter usw. Wenn Sie ein neues Firefox-Profil erstellen und in dieses bestimmte Dateien aus dem bisherigen Profil übertragen, bedeutet das einen sauberen Neubeginn für Sie. Ihre wichtigen persönlichen Daten bleiben dabei erhalten.

Hinweis: Da häufig Einstellungen und Erweiterungen die Ursache von Problemen sind, erklärt dieser Artikel nicht, wie Sie diese von Profil zu Profil kopieren können. Erst nach Abarbeitung der in diesem Artikel erklärten Schritte können Sie die Erweiterungen neu installieren und die Firefox-Einstellungen Ihren Wünschen gemäß erneut anpassen.

Daten Ihres aktuell genutzten Firefox-Profils sichern

Bevor Sie beginnen, wird empfohlen, eine vollständige Sicherheitskopie des existierenden Firefox-Profilordners zu erstellen – für den Fall, dass etwas schief gehen sollte. Bitte lesen Sie dazu den Artikel Daten in Firefox-Profilen sichern und wiederherstellen.

Ein neues Firefox-Profil erstellen

Wie ein neues Firefox-Profil erstellt werden kann, erfahren Sie in der Anleitung Profil erstellen.

Dateien von einem zum anderen Profilordner kopieren

Hinweis: Firefox muss vollständig beendet sein, während Sie Daten von einem Profilordner zum anderen kopieren.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus auf eine Datei, die Sie kopieren möchten, und wählen Sie Kopieren.
  5. Öffnen Sie den neuen Profilordner.
  6. Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus in den neuen Profilordner und wählen Element Einfügen.

Wiederholen Sie die Schritte 2-5 für jede Datei, die Sie in den neuen Profilordner übertragen wollen.

Wenn Sie Ihre persönlichen Daten in das neue Firefox-Profil kopieren, kann es vorkommen, dass Sie den Fehler, den Sie beheben wollen, ungewollt mit übertragen. Je mehr Dateien Sie übertragen, desto größer ist die Wahrscheinlichkeit dafür. Es empfiehlt sich folgende Vorgehensweise:

  • Übertragen Sie nur die wichtigsten Ihrer persönlichen Dateien, auf die Sie unter keinen Umständen verzichten möchten.
  • Überprüfen Sie nun, ob das Problem behoben ist. Wenn dies so ist, können Sie weitere Daten in das neue Profil übertragen.

Ihre wichtigsten Daten und deren Dateien

Lesezeichen und die Chronik

  • places.sqlite

Diese Datei enthält alle Firefox-Lesezeichen und die Liste der Webseiten, die Sie bisher besucht haben. Weitere Informationen dazu finden Sie im Artikel Lesezeichen.

Passwörter

Ihre Passwörter werden in zwei verschiedenen Dateien gespeichert, die beide erforderlich sind:

  • key3.db – Diese Datei enthält die Schlüsseldatenbank Ihrer Passwörter. Um die gespeicherten Passwörter ins neue Profil zu übertragen, müssen Sie diese und die folgende Datei kopieren.
  • signons.sqlite – Gespeicherte Passwörter.

Weitere Informationen dazu finden Sie im Artikel Passwörter verwalten – speichern, löschen und ändern gespeicherter Passwörter in Firefox.

Seitenspezifische Einstellungen

  • permissions.sqlite

Diese Datei enthält Ihre Voreinstellungen für jede besuchte Webseite. Beispielsweise, welcher Webseite Sie erlaubt oder verboten haben, Cookies zu speichern, Erweiterungen zu installieren, Grafiken darzustellen, Pop-ups zuzulassen usw.

Suchmaschinen

  • search.sqlite
  • Ordner /searchplugins/

Wenn Sie zusätzliche Suchmaschinen installiert haben, finden Sie diese im Ordner /searchplugins/. Die Datei search.sqlite enthält die Reihenfolge der Suchmaschinen in Firefox. Näheres hierzu finden Sie im Artikel Suchleiste.

Persönliches Wörterbuch

  • persdict.dat

Diese Datei enthält jene Wörter, die Sie dem Firefox-Wörterbuch hinzugefügt haben. Wenn Sie keine eigenen Wörter hinzugefügt haben, ist diese Datei nicht vorhanden. Für weitere Informationen lesen Sie den Artikel Rechtschreibprüfung nutzen.

Such- und Formulardaten

  • formhistory.sqlite

Diese Datei enthält die in der Firefox-Suchleiste eingegebenen Suchbegriffe und die Eingaben in Formularen von Webseiten. Für weitere Informationen lesen Sie den Artikel Formular-Autovervollständigung.

Cookies

  • cookies.sqlite

Cookies können von Webseiten für eine Vielzahl von Informationen gesetzt werden. Etwa für Ihre Anmeldung, die personalisierte Darstellung von Webseiten, persönliche Daten zur Identifikation usw. Für weitere Informationen lesen Sie den Artikel Cookies.

Sicherheitszertifikate-Einstellungen

  • cert8.db

Diese Datei enthält alle Einstellungen zu Ihren Sicherheitszertifikaten sowie alle SSL-Zertifikate, die Sie in Firefox importiert haben.

Download-Aktionen

  • mimeTypes.rdf

Die Datei enthält Ihre Einstellungen, wie Firefox mit bekannten Dateien umgehen soll. Weitere Informationen hierzu erhalten Sie im Artikel Einstellen, was Firefox tun soll, wenn eine Datei angeklickt oder heruntergeladen wird.

Benutzerdefinierte Stil-Einstellungen

  • /chrome/userChrome.css
  • /chrome/userContent.css

Wenn diese beiden Dateien im Verzeichnis Chrome existieren, enthalten sie die vom Benutzer vorgenommenen Änderungen am Firefox-Layout sowie am Erscheinungsbild und der Funktionsweise bestimmter Webseiten und/oder HTML-Elemente. Diese Dateien müssen vom Benutzer angelegt werden. Sollte dies bei Ihnen nicht der Fall sein, finden Sie im Verzeichnis Chrome die beiden Dateien userChrome-example.css und userContent-example.css, welche beide gefahrlos ignoriert werden können.


Basiert auf Informationen des Artikels Transferring data to a new profile - Firefox (mozillaZine KB)

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel. Auch Sie können helfen – erfahren Sie, wie.