Daten in Firefox-Profilen sichern und wiederherstellen

Mozilla Firefox speichert Ihre persönlichen Daten wie zum Beispiel Lesezeichen, Passwörter und Einstellungen in einem Profilordner, der sich auf Ihrem Rechner befindet. Dieser Artikel erklärt, wie Sie Ihr Profil sichern, wiederherstellen oder an einen neuen Ort auf Ihrem Rechner verschieben können.

Wo befindet sich Ihr Profil?

Der Standard-Speicherort des Firefox-Profilordners ist %APPDATA%\Mozilla\Firefox\Profiles\xxxxxxxx.default\.

  • %APPDATA% ist ein Kürzel für den Ordner C:\Benutzer\<Ihr Benutzername>\AppData\Roaming\C:\Dokumente und Einstellungen\<Ihr Benutzername>\Anwendungsdaten\, wobei Ihr Benutzername dem Namen entspricht, mit dem Sie sich bei Windows angemeldet haben.

Der Standard-Speicherort des Firefox-Profilordners ist ~/Library/Application Support/Firefox/Profiles/xxxxxxxx.default/.

Der Standard-Speicherort des Firefox-Profilordners ist ~/.mozilla/firefox/xxxxxxxx.default/.

  • xxxxxxxx steht für acht zufällige, automatisch generierte Zeichen, die bei jedem Profil unterschiedlich sind.

Sie können Ihren Profilordner auf folgende Art aufrufen:

Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  • Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  • Hinweis: Wenn Sie Firefox nicht starten können, öffnen Sie den Profilordner wie in der nachfolgenden Anleitung.
    1. Klicken Sie auf die Start-Schaltfläche von Windows und geben Sie %APPDATA%\Mozilla\Firefox\Profiles\ in das Eingabefeld am unteren Rand des Startmenüs ein, ohne die Eingabetaste zu drücken. Daraufhin wird im Startmenü eine Liste der verfügbaren Profile angezeigt.
    2. Klicken Sie auf eines der Profile (z. B. xxxxxxxx.default), um den entsprechenden Profilordner im Windows-Explorer zu öffnen.

      a58c2481f8610cfdf0587592bf155871-1263117201-688-1.png
    1. Klicken Sie zuerst auf die Start-Schaltfläche von Windows und dann auf Ausführen....

      a58c2481f8610cfdf0587592bf155871-1263117201-688-2.png

    2. Geben Sie %APPDATA%\Mozilla\Firefox\Profiles\ ein und klicken Sie auf OK.

      a58c2481f8610cfdf0587592bf155871-1263117201-688-3.png

    Im Windows-Explorer öffnet sich daraufhin der Profiles-Ordner, der die einzelnen Profile enthält.

    1. Öffnen Sie das Charms-Menü (das Menü am rechten Rand des Desktops) und wählen Sie Suche.
    2. Suchen Sie in Apps nach Ausführen.
    3. Wählen Sie Ausführen und Sie werden auf den Desktop mit der Ausführen-Anwendung weitergeleitet.
    4. Geben Sie %APPDATA%\Mozilla\Firefox\Profiles\ ein und klicken Sie auf OK. Im Windows-Explorer öffnet sich daraufhin der Profiles-Ordner, der die einzelnen Profile enthält.
    1. Öffnen Sie Finder im Dock.
    2. Klicken Sie in der Menüleiste auf das Menü Gehe zu und wählen Sie Gehe zum Ordner….
    3. Fügen Sie im Fenster Gehe zum Ordner diesen Text ein: ~/Library/Application Support/Firefox/Profiles und klicken Sie dann auf Start.
    4. Ein Fenster mit den Profilordnern wird sich öffnen.
    5. Klicken Sie doppelt mit der Maustaste auf den Ordner mit “default” im Namen, um ihn zu öffnen.
    Hinweis: Diese Anweisungen gelten für die verbreitetsten Linux-Distributionen. Ihre Distribution hat gegebenenfalls eine andere Oberfläche.

    Ubuntu

    Für Distributionen wie Ubuntu, die Unity als Arbeitsoberfläche per Voreinstellung einsetzen:

    1. Klicken Sie im Startmenü von Unity auf das Symbol für den Persönlichen Ordner.
      • Alternativ dazu können Sie den Schnellstart öffnen, indem Sie auf das oberste Ubuntu-Symbol klicken oder die Taste Windows/Super betätigen, und tippen Sie „persönlich“ ein. Wählen Sie das Symbol für den „Persönlichen Ordner“ aus.

      Persönlicher Ordner 01 Unity
      Der Dateimanager öffnet sich.
    2. Bewegen Sie die Maus an den oberen Rand des Bildschirms und klicken Sie auf das Menü Ansicht. Wählen Sie Verborgene Dateien anzeigen und setzen Sie damit ein Häkchen vor diese Option.

      Persönlicher Ordner 02 Unity
    3. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
    4. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

      Persönlicher Ordner 03 Unity

    GNOME

    Für Distributionen wie Fedora, Red Hat Enterprise Linux und andere, die die GNOME-Arbeitsumgebung per Voreinstellung einsetzen:

    Neue Version 3

    1. Klicken Sie auf die Schaltfläche Aktivitäten in der linken, oberen Ecke des Bildschirms.
    2. Tippen Sie „persönlich“ in das Suchfeld rechts oben ein und öffnen Sie den „Persönlichen Ordner“ im Dateimanager.

      Persönlicher Ordner 01 Fedora
      Der Dateimanager öffnet sich.
    3. Klicken Sie auf das Menü Ansicht und aktivieren Sie Verborgene Dateien anzeigen.

      Persönlicher Ordner 02 Fedora
    4. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
    5. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

    Alte Version 2

    1. Klicken Sie auf das Menü Orte oben links auf dem Bildschirm und wählen Sie Persönlicher Ordner aus. Ein Fenster des Dateimanagers wird erscheinen.
    2. Klicken Sie auf das Menü Ansicht und aktivieren Sie Verborgene Dateien anzeigen.

      a64b318a52ca9ee53eb43686f1b993d7-1252101959-148-1.jpg

    3. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
    4. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

      a64b318a52ca9ee53eb43686f1b993d7-1252101015-702-1.png

    KDE

    Für Distributionen wie Kubuntu, openSUSE, Mandriva Linux, PCLinuxOS, Knoppix und andere, die die Arbeitsumgebung KDE Software Compilation per Voreinstellung einsetzen:

    1. Öffnen Sie den Dateimanager Ihrer Distribution.
      • (Kubuntu) Klicken Sie auf das K links unten und wählen Sie Rechner aus und öffnen Sie dort Persönlicher Ordner.

        Persönlicher Ordner 01 Kubuntu
      • (openSUSE) Klicken Sie auf das openSUSE-Symbol links unten und wählen Sie Rechner aus und öffnen Sie dort Persönlicher Ordner.
    2. Gehen Sie in das Menü Ansicht.
    3. Aktivieren Sie die Option Versteckte Dateien anzeigen.

      Persönlicher Ordner 02 openSUSE
    4. Klicken Sie auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
    5. Klicken Sie auf den Ordner firefox. Ihre einzelnen Profil-Ordner befinden sich in diesem Ordner.

    LXDE

    Für Distributionen wie Lubuntu und andere, die die LXDE-Arbeitsumgebung als Standard oder Alternative einsetzen:

    1. Starten Sie den Dateimanager im LXPanel.
    2. Gehen Sie in das Menü Ansicht.
    3. Aktivieren Sie die Option Verborgene Dateien anzeigen.
    4. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
    5. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

    Andere

    Für Distributionen wie Linux Mint und andere, die Arbeitsumgebung einsetzen, die sich von den oben angesprochenen unterscheiden:

    1. Öffnen Sie den Dateimanager oder den Persönlichen Ordner über das Hauptmenü oder Panel Ihrer Distribution.
    2. Gehen Sie in das Menü Ansicht oder Anzeige.
    3. Aktivieren Sie die Option Verborgene Dateien anzeigen oder eine ähnlich lautende.
    4. Öffnen Sie den Ordner .mozilla in Ihrem Persönlichen Ordner.
    5. Öffnen Sie den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

    Ein Profil sichern

    Ein Profil zu sichern ist sehr einfach. Schließen Sie Firefox, wenn es noch läuft, und kopieren Sie den Profilordner an einen anderen Ort.

    1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

      Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

    2. Rufen Sie Ihren Profilordner wie oben beschrieben auf.
    3. Wechseln Sie gegebenenfalls in den übergeordneten Ordner, der Ihren Profilordner enthält, z. B. %APPDATA%\Mozilla\Firefox\Profiles\~/Library/Application Support/Firefox/Profiles/~/.mozilla/firefox/
    4. Klicken Sie mit der rechten Maustaste auf Ihren Profilordner (z. B. xxxxxxxx.default)Halten Sie Strg gedrückt, während Sie auf Ihren Profilordner (z.B. xxxxxxxx.default) klicken, und wählen Sie Kopieren aus.
    5. Klicken Sie mit der rechten Maustaste auf den OrdnerHalten Sie Strg gedrückt, während Sie auf den Ordner klicken, in den Sie das Profil kopieren möchten (z.B. auf einen USB-Stick oder eine beschreibbare CD), und wählen Sie Einfügen.

    Ein gesichertes Profil wiederherstellen

    1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

      Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

    2. Wenn der vorhandene Profilordner und der Ordner, der die Sicherung enthält, den gleichen Namen haben, ersetzen Sie einfach den vorhandenen durch den gesicherten Ordner und starten Sie Firefox.
    Wichtig: Die Namen müssen identisch sein - auch die 8 zufälligen Zeichen am Anfang des Ordnernamens. Wenn die Namen unterschiedlich sind oder Sie das Profil an einem anderen Ort wiederherstellen möchten, folgen Sie bitte der Anleitung weiter unten.

    Ein Profil an einem anderen Ort wiederherstellen

    Wenn die Namen unterschiedlich sind oder Sie das Profil an einem anderen Ort wiederherstellen oder kopieren möchten, folgen Sie bitte dieser Anleitung:

    1. Beenden Sie Firefox vollständig:

      Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

      Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

    2. Verwenden Sie den Profil-Manager von Firefox, um ein neues Profil am gewünschten Ort zu erstellen, und schließen Sie dann den Profil-Manager.
      Hinweis: Wenn Sie Firefox gerade auf einem neuen Rechner installiert haben, können Sie auch den beim ersten Start automatisch erstellten Profilordner verwenden, statt ein neues Profil anzulegen.
    3. Öffnen Sie den Profilordner, den Sie zuvor gesichert haben (z. B. xxxxxxxx.default auf Ihren USB-Stick).
    4. Kopieren Sie den gesamten Inhalt des Ordners – also alle Dateien wie mimeTypes.rdf und prefs.js sowie alle Ordner wie bookmarkbackups usw.
    5. Gehen Sie wie oben beschrieben zum neuen Profilordner und beenden Sie danach Firefox, falls es läuft.
    6. Fügen Sie die kopierten Daten in den neuen Profilordner ein. Überschreiben Sie dabei alle vorhandenen Dateien.
    7. Starten Sie Firefox.



    Teile diesen Artikel: http://mzl.la/LHJo6V

    War der Artikel hilfreich? Bitte warten…

    Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, pollti. Auch Sie können helfen – erfahren Sie, wie.