Solucionar problemas com plugins como o Flash ou Java para corrigir problemas frequentes do Firefox

A Mozilla planeja abandonar o suporte a todos os plugins NPAPI, exceto para Flash, em Março de 2017, quando a versão 52 do Firefox for lançada. Consulte este artigo e este artigo do blogue para detalhes.

Se está a ter problemas com websites que utilizam plugins (tais como o Adobe Flash, Java e outros) para exibir conteúdos, poderá ter que verificar se um plugin estará a causar o problema.

Nota: Atualmente a versão 64-bit do Firefox reconhece e suporta apenas os plugins Adobe Flash e Microsoft Silverlight NPAPI.

Problemas frequentes causados por plugins incluem:

Este artigo descreve como solucionar problemas com plugins. Se está a ter um problema com uma extensão ou um tema, consulte Soluções para problemas com extensões, temas e aceleração de hardware para resolver problemas frequentes do Firefox. Para informações gerais sobre plugins, consulte Use os plugins para reproduzir áudio, vídeo, jogos e mais.

Determinar se um plugin é o problema

Pode desativar seletivamente plugins enquanto o Firefox está a ser executado. Se suspeita de um determinado plugin, desative-o primeiro, e depois teste se o problema persiste. Se não sabe qual plugin desativar:

  1. No topo da janela do Firefox, clique no botão FirefoxNa barra de menu, clique no menu FerramentasNo topo da janela do Firefox, clique no menu Ferramentas e clique em Extras. O separador Gestor de extras será apresentado. Clique no botão do menu New Fx Menu e escolha Extras. O separador Gestor de extras será apresentado.

  2. No separador Gestor de extras, selecione o painel Plugins.
  3. Selecione um plugin na lista e depois selecione Nunca ativar no próprio menu pendente. Repita este passo para cada plugin da lista, até que todos estejam desativados. Não é necessário reiniciar o Firefox para que as alterações sejam aplicadas.
  4. Teste se o problema persiste. Se este já não ocorrer, retorne ao separador de gestor de extras e reative os plugins um a um com o botão Ativar sempre no menu pendente até descobrir qual é o plugin que causa o problema.

Se achar que desativar um plugin resolver o problema, continue a seguir os passos neste artigo.

Atualizar ou reinstalar os plugins

Muitos problemas com plugins podem ser solucionados atualizando-os com a versão mais recente do plugin. Para confirmar se qualquer um dos seus plugins está desatualizado, visite a página de verificação e atualizações de plugins da Mozilla.

Se atualizar para a versão mais recente do plugin ou reinstalá-lo não solucionar o problema, pode deixá-lo desativado.

Desinstalar um plugin manualmente

Se não consegue utilizar um programa de desinstalação para remover um plugin, pode removê-lo manualmente:

  1. Digite about:plugins na barra de endereço e pressione EnterReturn para mostrar a página Acerca dos plugins.
  2. Cada entrada na página Acerca dos plugins irão ter o "Ficheiro:" e "Caminho:", a mostrar o nome e localização do ficheiro do plugin. Utilize o Explorador do Windows para navegarNavigar para a pasta mostrada para o plugin que pretende remover.
  3. Renomeie o ficheiro para adicionar um X à frente do nome do ficheiro (por exemplo, npswf32 altera-se para Xnpswf32).

O plugin será removido.

Reinicializar a base de dados dos plugins

Nalguns casos, poderá não conseguir instalar ou reinstalar um plugin. Reinicializar a base de dados dos plugins pode corrigir este problema:

  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Elimine o ficheiro pluginreg.dat.
  6. Abra o Firefox
  7. Na barra de localização digite about:plugins e pressione EnterReturn para mostrar a lista de plugins do Firefox.

Este artigo foi útil? Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: albertdecastro. Você também pode ajudar - descubra como.