Showing questions tagged: Show all questions

Firefox Can’t Open This Page To protect your security, www.youtube.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

My web page (HTML) has one embedded video (my own, uploaded to YouTube). The embedding code line is ... <iframe title="YouTube video player" width="480" height="390" … (read more)

My web page (HTML) has one embedded video (my own, uploaded to YouTube). The embedding code line is ...

  • <iframe title="YouTube video player" width="480" height="390" src="https://youtu.be/pj3d3fOlr-A" frameborder="0" allowfullscreen></iframe>

  • and the error/warning I get when I open my page isL

    Firefox Can’t Open This Page To protect your security, www.youtube.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

    How do I fix this issue, please? Thank you Regards Fred James

    Asked by fredjame1 2 days ago

    Last reply by cor-el 1 day ago

    Firefox storages are broken

    It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially: … (read more)

    It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially:

    • QuotaManager
    • Bad: Totally Broken. (fullyBroken)
    • IndexedDB
    • Bad: Totally Broken. (fullyBroken)
    • Cache API
    • Bad: Totally Broken. (fullyBroken)

    Is there any way to fix this? I'm using Firefox ESR on Linux and it seems there isn't new Firefox ESR updates.

    Asked by thecowmilk 5 days ago

    Last reply by cor-el 1 day ago

    Firefox Add-On need to open an open dialog from the activeTab page

    Hi all, i'm currently developing an add-on that has an import from file feature that needs to open an "Open file" dialog, now the problem is that in order to do that i h… (read more)

    Hi all,

    i'm currently developing an add-on that has an import from file feature that needs to open an "Open file" dialog, now the problem is that in order to do that i had to do the following:

    • inject some javascript code in the active page as a content script
    • call the execute command from the extension to open the dialog popup (that is actually emulating a click)

    I have to do it, because from an extension when a "File open" dialog appear, the extension lose the focus and it is automatically closed, and its context destroyed, so when i actually press open on the dialog, the "caller" is already gone (https://stackoverflow.com/questions/26884140/open-import-file-in-a-chrome-extension/26917671#26917671 you can refer to my stackoverflow question to get an idea of what i was doing)

    This works fine in chrome (And it worked for a while on firefox) but probably in the latest months/years (not sure when it happened) it stopped working and when i press the import button nothing happens, after some investigation i found what is the problem: the "block popup" windows option enabled by default (i suppose it is enabled by default i don't remember to have never enabled it), so when i disable it, the feature resume working. What i'm wondering is if there is a way to programmatically add an exception to the popup blocker option while installing the extension, or if there is any way to avoid closing the exception popup when the "File Open" Dialog appears.

    Thanks everyone

    Asked by ivan.gualandri 2 days ago

    Last reply by jscher2000 2 days ago

    Firefox bloquea equipo

    Soy usuario de firefox con Ubuntu 18.04. En varias ocasiones al tener varias pestañas de navegación el equipo se bloquea por completo, solo es posible forzar el apagado c… (read more)

    Soy usuario de firefox con Ubuntu 18.04. En varias ocasiones al tener varias pestañas de navegación el equipo se bloquea por completo, solo es posible forzar el apagado con el boton de encendido. También creo que este problema lo tenia con Ubuntu 16.

    ¿Alguna sugerencia?

    Asked by jluishg 3 days ago

    Last reply by JP 2 days ago

    Title bar near Mozilla Firefox has strange symbol

    My title bar has a weird symbol in front of where it says Mozilla Firefox Sort of looks like a yen symbol and the m of the Mozilla Firefox looks weird as well Posting on … (read more)

    My title bar has a weird symbol in front of where it says Mozilla Firefox

    Sort of looks like a yen symbol and the m of the Mozilla Firefox looks weird as well

    Posting on mobile devices other wise would attach photo

    Asked by Kobra 3 days ago

    Last reply by FredMcD 2 days ago

    How can I get a border around inactive tabs?

    Hello, I updated firefox and it's now hard to tell when one tab ends and another begins when you have multiple inactive tabs next to each other, which is a major annoyanc… (read more)

    Hello,

    I updated firefox and it's now hard to tell when one tab ends and another begins when you have multiple inactive tabs next to each other, which is a major annoyance.

    The way to solve this would be to have the inactive tabs have a border around them like the active tab, have them have a different background color from the toolbar, or otherwise have some kind of separator between them. I saw another answer that gave a temporary solution, but the same answer said the solution was going to stop working in a future update. Is there a permanent solution?

    Asked by Andreas Eriksson 4 days ago

    Last reply by JP 3 days ago

    Firefox 90.0 Crashes Constantly

    Hello, At first I thought it was a tired Arch Manjaro install that was perhaps the issue. Now that I've done fresh installs of Arch (Manjaro & Arco), Ubuntu (KDE, Gn… (read more)

    Hello,

    At first I thought it was a tired Arch Manjaro install that was perhaps the issue. Now that I've done fresh installs of Arch (Manjaro & Arco), Ubuntu (KDE, Gnome, & XFCE) on both my workstation and laptop, I can say it's not my Hardware or OS. So why is Firefox crashing all the time? Mid chat conversations, etc. Again, fresh OS install and zero Add-Ons installed. I can't use Firefox, even if I badly wanted too when it tanks on me all the time.

    Asked by aldspamacct 3 days ago

    Last reply by FredMcD 3 days ago

    PDF.JS display chinese font issue.

    when using firefox plugin PDF viewer (PDF.JS) display chinese content cause some issue, fontface and font doesn't display correctly. will this issue fix in next version??… (read more)

    when using firefox plugin PDF viewer (PDF.JS) display chinese content cause some issue, fontface and font doesn't display correctly. will this issue fix in next version?? tks.

    Asked by neko19720429 4 days ago

    Last reply by cor-el 3 days ago

    RSS feeds broken - content security policy issue?

    Since I upgraded to Firefox 90.0, my RSS feeds can not longer be refreshed in my feed reader. I get a 403 error ("access denied"). When I check the debug information on t… (read more)

    Since I upgraded to Firefox 90.0, my RSS feeds can not longer be refreshed in my feed reader. I get a 403 error ("access denied"). When I check the debug information on the URL, it says:

    Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”).

    I am using Feedbro on Firefox 90 on Ubuntu 20.04 on two different computers, and getting same problem.

    Clearing the cache, trying other feed readers, deleting cookies etc do not help.

    A sample feed URL: https://news.google.com/rss/search?hl=en-US&gl=US&q=mozilla&ceid=US:en In Firefox, I can open a tab and see the text file. But Feedbro, or any other reader, cannot detect the feeds on this page any more.

    Any advice? I absolutely rely on RSS feeds for my work.

    Thank you kindly!

    Asked by oryza 4 days ago

    Last reply by TyDraniu 4 days ago

    POST action turns into a GET, which is incorrect.

    Using Apache2 to serve web pages. Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux The following appears in the access.log:- 127.0.0.1 - … (read more)

    Using Apache2 to serve web pages.

    Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux

    The following appears in the access.log:-

    127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "POST /scripts_php/memb_login.php HTTP/1.1" 302 314 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0" 127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "GET /scripts_php/memb_login.php HTTP/1.1" 200 499 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"

    The form method is POST and the action is to call a PHP script which expects a POST array. The "302 314" appears to be correct, but, a GET is returned immediately.

    According to w3.org:-

    Note: RFC 1945 and RFC 2068 specify that the client is not allowed

         to change the method on the redirected request.  However, most
         existing user agent implementations treat 302 as if it were a 303
         response, performing a GET on the Location field-value regardless
         of the original request method. The status codes 303 and 307 have
         been added for servers that wish to make unambiguously clear which
         kind of reaction is expected of the client.
    

    This has just started to occur after a recent upgrade to Firefox. It might be caused by the browser but there might be some other explanation or configuration setting that needs tweaking. Could somebody please help.

    Thanks.

    Asked by rob2floripa 4 days ago

    Last reply by TyDraniu 4 days ago

    Extremely high CPU usage while playing video (youtube)

    Firefox become hopelessly show to play even 480p videos from youtube 90% CPU usage while playing 720p video from youtube freezing randomly. (same issue on other notebook… (read more)

    Firefox become hopelessly show to play even 480p videos from youtube 90% CPU usage while playing 720p video from youtube freezing randomly. (same issue on other notebooks, so I have a strong feeling it is not a hardware/notebook related issue) Hardware:

    • CPU: i7-6500U
    • RAM: 8GB / DDR3
    • Video: Intel HD graphics
    • Memory usage never runs above 60%

    OS: doesn't matter, experiencing same issue on windows 7/10 and linux.

    to compare, same video 1080p/60Hz played with:

    • brave/chromium ~30..35% cpu
    • mpv playing same video directly from youtube ~ 19..25% cpu
    • Firefox - constantly freezing, youtube autmatically switching from 1080p to 720p, then to 480p, playing 480p @ 60..90% cpu usage

    I have tried everything from this forum and from others - nothing helped.

    And finally, last nail in a coffin - even my very old notebook Core2duo with 2GB ram playing 720p videos with brave browser without issues while firefox struggling to play 480p, constantly freezing and making notebook fan run like crazy.

    Firefox is literally forcing me to use other browser.

    Asked by George Eliozov 1 week ago

    Last reply by jonzn4SUSE 6 days ago

    Can't pin "Nightly" to Ubuntu taskbar. Can only load from "MOZ" command! Help!

    My install of Firefox was somehow corrupted. I was instructed by FF tech support to download the latest "Nightly" build, extract it to my "Downloads" folder, and launch i… (read more)

    My install of Firefox was somehow corrupted. I was instructed by FF tech support to download the latest "Nightly" build, extract it to my "Downloads" folder, and launch it using the following command:

    MOZ_ACCELERATED=0 MOZ_WEBRENDER=0 ~/Downloads/firefox/firefox

    This opens a working install of "Nightly" (with purple & blue firefox icon), but as soon as I close it, the icon goes away. The program is not recognized as "installed" so it does not appear in a search for installed apps. And if I right-click on its icon while running, "Pin to taskbar" is not an option.

    "Nighly" is working (I'm using it to type this) and I even have it Synced to my account, but the ONLY way to launch it is via the Terminal CLI. :(

    My broken copy of "Firefox" is still listed as installed, but is unusable.

    HELP! TIA

    Asked by Mugsy 2 weeks ago

    Last reply by Seburo 1 week ago

    Tabs on Bottom complication with FF 90.0.2 ...

    The thread https://support.mozilla.org/en-US/questions/1325905#answer-1429736 was "locked" after I requested help about removing toolbar "fog". Thank you for your replies… (read more)

    The thread https://support.mozilla.org/en-US/questions/1325905#answer-1429736 was "locked" after I requested help about removing toolbar "fog".

    Thank you for your replies.

    Asked by henrietta_stroph 1 week ago

    Last reply by cor-el 1 week ago

    I am not able to access the website which has embedded links.

    I am not able to access the website which has embedded links. when i try to clear everything and selected never remember history. After that also i could not access the … (read more)

    I am not able to access the website which has embedded links.

    when i try to clear everything and selected never remember history. After that also i could not access the trusted website. could you please explain what can i do for the below error ?

    this is the error i am getting, Firefox Can’t Open This Page

    To protect your security, login.microsoftonline.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

    Learn more…

    Report errors like this to help Mozilla identify and block malicious sites

    Asked by keerthihana7 1 week ago

    Last reply by cor-el 1 week ago

    Google services not working sometimes

    Hi! Some days ago I started experiencing problems to load Google service webpages. For example sometimes youtube tells that there is a connection problem, when loading gm… (read more)

    Hi! Some days ago I started experiencing problems to load Google service webpages. For example sometimes youtube tells that there is a connection problem, when loading gmail I get " has experienced a network protocol violation that cannot be repaired". When I use other browser I can access to that services with no problem. I am in linux, and I have tried disabling all the add-ons, starting in "safe-mode" and rebooting my computer. At the beginning everything works fine, but after some time starts failing. I have tried with different Firefox versions, and the problems persists.

    Asked by inaki6martinez 2 weeks ago

    Last reply by jonzn4SUSE 1 week ago

    Bookmarks window is not resizeable

    Hi, This is from loooong time a very seriously problem of Firefox. When you are trying bookmarking link, the window doesn't give a possibility to resize. It is a very us… (read more)

    Hi, This is from loooong time a very seriously problem of Firefox. When you are trying bookmarking link, the window doesn't give a possibility to resize. It is a very useful. Can Firefox team sorting this malfunction, please?

    My system Linux, Manjaro.


    Thank you.

    Asked by Chris Fx Wolf 1 week ago

    Last reply by cor-el 1 week ago

    can't logout old accounts

    I'm trying to log out old and duplicate accounts from my firefox account list, I've managed to logout from all of those except 2 old account, if I press "sign out" button… (read more)

    I'm trying to log out old and duplicate accounts from my firefox account list, I've managed to logout from all of those except 2 old account, if I press "sign out" button and enter the reason why I'm doing that it simply doesn't work, no errors no anything, it'll just stay there. any fix?

    Asked by tsft1 1 week ago

    Last reply by FredMcD 1 week ago

    Change color of blank page

    If I set my home page to "blank" in Firefox settings, it defaults to a blank white page. How do I change the color of this page? Setting background color in the "appeara… (read more)

    If I set my home page to "blank" in Firefox settings, it defaults to a blank white page. How do I change the color of this page?

    Setting background color in the "appearance" section has no effect for me.

    I'm on linux if it matters.

    Asked by 24michaelpartridge 1 week ago

    Last reply by TerryN21 1 week ago