Showing questions tagged: Show all questions

Firefox does not display background color in option tags

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text: ```<select id="stroke… (read more)

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text:

```<select id="strokeColor" name="strokeColor" style="width: 10em;">

             <option value="black" style="background: #000000; text: #FFFFFF">
                     black
             </option>

<option value="aqua" style="background: #00FFFF">

                     aqua
             </option>

<option value="blue" style="background: #0000FF">

                     blue
             </option>

<option value="brown" style="background: #A52A2A">

                     brown
             </option>

<option value="gray" style="background: #808080">

                     gray
             </option>

<option value="green" style="background: #00FF00">

                     green
             </option>

<option value="magenta" style="background: #FF00FF">

                     magenta
             </option>

<option value="orange" style="background: #FFA500">

                     orange
             </option>

<option value="purple" style="background: #800080">

                     purple
             </option>

<option value="red" style="background: #FF0000">

                     red
             </option>

<option value="white" style="background: #FFFFFF">

                     white
             </option>

<option value="yellow" style="background: #FFFF00">

                     yellow
             </option>

<option value="#000000" selected="" style="background: #000000">

                     #000000
             </option>
         </select>```

On Chrome this displays as expected:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-25-eebbd5.png

But on Firefox the background colors are ignored:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-35-bd90ee.png

How can I get Firefox to display the background colors?

Asked by jamescobban 1 day ago

Last reply by jscher2000 - Support Volunteer 5 hours ago

Netflix Error - F&355-1203

Hi, I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error… (read more)

Hi,

I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error F7355-1203.

I've checked the DRM setting and it is enabled, I checked addons and I have OpenH264 and Widevine installed, both set to always active.

I've checked installed codecs and I do have libavcodec58 installed. No update for that available via apt. I also have ffmpeg installed, no problem with that either. I can play Netflix videos in Chrome, but not in Firefox now. Something happened to Firefox when I updated from 120.x to 124.x. Today I updated to 125.x, same problem, Netflix video won't play.

I've unchecked the DRM setting and re-checked it, and that does reinstalled Widevine but does not fix the problem.

Any ideas what could be the cause?

Asked by mark545 2 days ago

Last reply by zeroknight 6 hours ago

firefox private mode language error

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok . … (read more)

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok .

Asked by SD SD 2 days ago

Last reply by zeroknight 2 days ago

Unintended scroll to top of page

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've … (read more)

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've serached the internet and can't find anything related. Please help

Asked by myblackfrog 2 days ago

Last reply by zeroknight 2 days ago

Google Maps Street View

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand cor… (read more)

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand corner terminates street view. This does not happen with other browsers.

My OS is Debian 12, Firefox is the latest version 115.9.1esr (64bit).

Asked by johnh009 3 days ago

Last reply by zeroknight 2 days ago

Integrated Webcam not working

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), an… (read more)

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), and chromium. I've checked the permissions (about:preferences#privacy), and that is not the problem. about:support does not list the device in the input at all. I've tried using LD_PRELOAD=/usr/lib64/libv4l/libv4l1compat.so, but that has not helped. Does anyone have any suggestions?

Asked by Mike Benson 1 week ago

Last reply by zeroknight 2 days ago

Change Firefox filename pattern for Take Screenshots

Firefox can take screenshots of pages or screenshots of custom areas of pages. According to the documentation, when we download the image, the filename should follow the… (read more)

Firefox can take screenshots of pages or screenshots of custom areas of pages.

According to the documentation, when we download the image, the filename should follow the pattern: Screen Shot yyy-mm-dd at hh.mm.ss.png. If I use the :screenshot at the console, the pattern works as documented.

But Firefox is using a different pattern when I choose Take Screenshot from the context menu. The pattern includes the page's title. Example: Screenshot 2024-04-14 at 18-35-16 General ‹ Settings ‹ Geomaster Lda — WordPress.png.

Since the page title can have non common filename characters, I have problems with such filenames. My uploads to MediaWiki fails with such filenames. I know I can report or improve MediaWiki, but my question here is quite simple.

Can I change the Firefox's default pattern for Take Screenshot's downloads?

Asked by Jorge Gustavo Rocha 3 days ago

Last reply by jonzn4SUSE 2 days ago

extensions.json key

Hello I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can'… (read more)

Hello

I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can't find any documentation to it's keys online.

There's "rootURI:" with a "jar:file://path/to/extension.xpi!/", so i tried just replacing the path with the shared one. Though i observed that just makes firefox replace the path with the current one. So i examined further and found the "location:" key with the default value "app-profile". So my guess is, there's other values for other usecases, right?

So, in summary, what i need is:

  • documentation to extensions.json keys or possible values to "location" key.
  • if that isn't intended/doesn't work, how i can achieve my goal otherwise.

And please don't suggest the sync feature, that doesn't work for my usecase.

Asked by dani.priv+moz 3 days ago

Last reply by cor-el 3 days ago

Japanese Input not appearing

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works ever… (read more)

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Asked by Paracelsus 3 months ago

Last reply by zeroknight 3 days ago

What and where is my Security Key and how do I touch it?

Please see the attached image. Firefox believes I have a security key. What is a security key? Where do I find it? Why does Firefox think I have one? And why is the… (read more)

Please see the attached image.

Firefox believes I have a security key.

What is a security key? Where do I find it? Why does Firefox think I have one?

And why is there no helpful information to explain this confusing UX?

Asked by kurrent93 4 days ago

Last reply by zeroknight 3 days ago

How to enable closing tabs in order of appearance to avoid jumping around

Today when I close many tabs using control w firefox seems to randomly jump around when choosing which next tab to close I wish to have firefox always close the adjac… (read more)

Today when I close many tabs using control w firefox seems to randomly jump around when choosing which next tab to close

I wish to have firefox always close the adjacent tab to the tab I just closed

This should be the default behavior ... I do not see any setting for this ... is there an addon to do this ?

I am using the latest firefox on ubuntu

      • UPDATE*** below answer for setting `browser.tabs.selectOwnerOnClose` has no impact on this

Asked by EventHorizon 4 months ago

Last reply by James 3 months ago

when can we have firefox with the translator switches OFF?

hi, When can we have firefox with translation set OFF by default? I mean, it's pretty unfair that intelligent people have to keep turning off the dumb translator... al… (read more)

hi,

When can we have firefox with translation set OFF by default?

I mean, it's pretty unfair that intelligent people have to keep turning off the dumb translator... all the time... We need a setting, openly available, in the Edit/Settings menu, where it belongs, an option to switch it off. In fact, when it first asks if we want a page translated, we need an option: never ask this again...

All we can see is "go under the hood of firefox, config:option, go into the about:config section where 10 of 10 million people will ever get... and there find your way to disable this horrible translator". When can we expect an option in the pop-up: "never ask me this question again"?

The translator in this offensive form has been around since 2023... I seems high time we didn't have to bother with this anymore...

Peter

- - - Thank you for developing firefox and keeping it intelligent - - -

Asked by jepe69 4 days ago

Last reply by cor-el 4 days ago

Tabs not completely shifted over to the left.

Hello Good People, I installed Firefox a few days ago and it was looking good. I don't like that icon in the top-left hand so I right clicked it and removed it. All was … (read more)

Hello Good People,

I installed Firefox a few days ago and it was looking good. I don't like that icon in the top-left hand so I right clicked it and removed it. All was good. However, today there is a blank black space in the corner as if the icon was back (but without an actual icon). It's only a small thing but it bugs me. I want the tabs to be shifted all the way over to the left like they have been up to today. It's triggering my OCD. Anyway, any advice appreciated.

Best Wishes

Matt Hammond

Asked by m.p.hammond 5 days ago

Last reply by jscher2000 - Support Volunteer 5 days ago

Videos automatically play after a short period of time after being paused (Ubuntu 22.04)

When I pause a video (any site) and go to another tab / stay on the site, after a seemingly random amount of time the video starts playing again. I'm using latest Firef… (read more)

When I pause a video (any site) and go to another tab / stay on the site, after a seemingly random amount of time the video starts playing again.

I'm using latest Firefox on Ubuntu 22.04 (snap).

I've tried (didn't work):

  • Disabling media hardware controls through about:config
  • Disabling autoplay through about:config

Asked by Pawel Len 5 days ago

Last reply by cor-el 5 days ago

Popups still appear despite blocking

Hi, Some websites still managed to smuggle in popups despite all the blockings. I use as add-ons: privacy badger, no-script, ublock origin and recently tried popup block… (read more)

Hi,

Some websites still managed to smuggle in popups despite all the blockings. I use as add-ons: privacy badger, no-script, ublock origin and recently tried popup blocker (strict) and even have the 'block pop-up windows' enabled. I also tried to fiddle around in ´about:config´ but nothing helps. I think it's a recent occurrence as I don't remember having this problem, let's say, a couple of months ago.

The funny thing is that this problem doesn't occur in opera-browser (in which I hardly use extensions).

The websites that this occurs are: arabicpost.net (a pop-up will occur about 10 sec after right-clicking a new tab). focus.de (a video pop-up will occur if there's a video in it). Again opera-browser blocks all of this. I expect there will be other websites to add in the future.

Please help. S.O.S. -> g.o.i.n.g..i.n.s.a.n.e!

Asked by b.hawassa 1 week ago

Last reply by zeroknight 6 days ago

Can only get to site in private mode

I have a website that I host. It is behind a proxy. It is a resolvable FQDN with DNS hosted by a major provider. The issue is when I browse to it via Firefox 124 it ev… (read more)

I have a website that I host. It is behind a proxy. It is a resolvable FQDN with DNS hosted by a major provider. The issue is when I browse to it via Firefox 124 it eventually errors out with connection reset, however if I open a private window it goes right there. I have tested other browsers and it works fine with them (Chrome, Safari, Vivaldi). I thought maybe it was plugins so I tried shutting off plugins one by one restarting after each one and that did not help. I tried in safe mode and could not get there. So I backed up my bookmarks and wiped out the directory and all for Firefox and tried on a fresh directory and that did not work except in private window mode.

Asked by Arianna Brandstetter 1 week ago

Last reply by zeroknight 1 week ago

Control key and Shift key triggers some weird deleting symptom

How to reproduce the bug: Jump to the address bar, and then press shift, ctrol, alt or windows_start, you can see the address getting deleted. You can also see it in Goog… (read more)

How to reproduce the bug: Jump to the address bar, and then press shift, ctrol, alt or windows_start, you can see the address getting deleted. You can also see it in Google Sheets and Microsoft Excel Online, it just deletes the cell, or a selection of multiple cells. --Interestingly on Google Docs it doesn't delete but just move the cursor to the first character when a string is selected.

 It happens only once per mouse click, or focus change

What I expect: Shift, Control or any mod key should not delete content or move a cursor

Thanks!

Asked by Gunwoo Gim 2 months ago

Last reply by zeroknight 1 week ago

Firefox with open AI

can anyone of you test chat open ai com with linux 32 bits? for more than 5-7 months its been unusable. it completely freeze. I recently reported this to open ai devs a… (read more)

can anyone of you test chat open ai com with linux 32 bits?

for more than 5-7 months its been unusable. it completely freeze. I recently reported this to open ai devs and they tried to do something. Now page responds is in 20-60 seconds range.

means, I open website, i wait 20-60 seconds to load. I ask chat gpt something, i wait 20-60 to actually type my messsage (for my message to be printed after I hit enter). then i refresh page (because nothing moves), wait 20-60 secs to load page and I see the reply.

and yes, each time I was always trying to do with latest version of browser. and I also tried it on a new browser without any extension.

I have a video, I can only share it private with firefox devs if helps.

the reason I didn't reported this last year, was because I got extremely disappointed and unhappy.

it initially started by showing that button-bar at the top, telling that page load slow and to [stop]. by the next month it became worst than 2000's dialup internet, so I stopped using it

Asked by Mdaley 1 week ago

Last reply by zeroknight 1 week ago

Firefox-esr/ Firefox jumps back to page beginning while scrolling, not solved

I have followed the troubleshooting suggestions with no avail. I am currently in troubleshooting mode with all add-ons disabled. The problem persists. The only way to han… (read more)

I have followed the troubleshooting suggestions with no avail. I am currently in troubleshooting mode with all add-ons disabled. The problem persists. The only way to handle the problem is to depress the scroll wheel on the mouse and start scrolling. However, the problem returns with the next page. The problem shows up on Windows 10 as well as Debian bullseye.

I have used Firefox and Firefox-esr for years on the same platforms. This problem started about six months ago with no resolution. So what has changed? On Win 10 Firefox keeps getting updates whereas Firefox-esr never gets updates. The problem persists on both platforms. More than one mouse has been used with the same results. I have removed Firefox and Firefox-esr and re loaded them, no joy here either.

Asked by meparsons 3 weeks ago

Last reply by zeroknight 1 week ago