X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FireFox on Nook Simple Touch rooted with NookManager

Posted

I rooted my Nook Simple Touch (firmware 1.2.1) with Nook Manager.

The NST has an ARM7 cpu with 256MB RAM. The Android version is 2.1.

I was able to install Fennec 2.0a1 using the apk here: http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/2.0a1/android-r7/fennec.apk

See this discussion for details of why I did not stop there: http://forum.xda-developers.com/showthread.php?t=1809768

I then upgraded to 4.0 beta 1 using this file: http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/4.0b1-real/android-r7/fennec.apk

My goal is to get a version of Firefox mobile that is compatible with the NoScript plugin. I would like to use selective cookie delete also, but that is a secondary goal.

Reading on wikipedia, I see that versions after 20 require Android 2.2 or above.

I tried installing 14, 5 and 5 beta 7 with no luck. I get Native ABI mismatch from package file errors.

Any advice on achieving my goal would be appreciated. I am happy to provide whatever additional info might be helpful.

Modified by LambdaFox

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Question owner

Sorry, I forgot to mention... I installed a Class 10 microSD card, and then installed swapper2 to expand the RAM. The 4.0 beta 1 that is installed works MUCH better after that, but still NoScript is not available for it.

Modified by LambdaFox

kbrosnan
  • Top 25 Contributor
  • Moderator
248 solutions 1750 answers

Noscript does not work on Firefox for Android according to its addons.mozilla.org page.

The most up to date version of Firefox you could run on your device is http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/10.0.5esr/android/multi/fennec-10.0.5esr.multi.android-arm.apk

Question owner

That file gives me the same "Native ABI mismatch from package file" I got from the others. With a little research, I found that FF 10.0.5esr is the last build that runs on Android 2.1. Wikipedia wrongly states that anything before 20 runs on 2.1...

Modified by LambdaFox

Question owner

The Native ABI mismatch errors begin with the mozilla-central-android-r7 4.0b3pre from 12-03-2010. Builds up to and including 12-02-2010 install w/o a problem.

Does anyone have a clue what changed then to no longer allow installation on my NST?

The NoScript for Firefox Mobile is in alpha testing. The version for Firefox Mobile 4 is the more finished product. I have posted in their forums asking what versions of FF Mobile it can be installed and enabled on.