X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

unagi flash with wiped phone memory

Posted

get a new unagi device, press and hold the volume down button and press power, on the menu wipe the data/factory reset and wipe cache partition (i'm using ubuntu 12.10) download the b2g git continue the process to flash you device again to make it work true this link (followed by 3 other pages)

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Firefox_OS_build_prerequisites?redirectlocale=en-US&redirectslug=Firefox_OS%2FFirefox_OS_build_prerequisites

or more faster http://blog.techno-barje.fr/post/2012/10/27/firefox-os-bootstrap/

when you do ./build.sh it gives you some error because it needs to check something on the phone that has been wiped.

i would be happy if some one could help me out

The only thing that i found on google was this but i can't access it (i need a username password but i don't know where to sign up) https://intranet.mozilla.org/B2G_Team/Unagi#Get_a_copy_of_backup-unagi you can contact me at awesome@soroushabtahi.com

(this is the error code that i get) : virex@virex-lap:~/B2G$ ./build.sh

================================

PLATFORM_VERSION_CODENAME=AOSP PLATFORM_VERSION=4.0.4.0.4.0.4 TARGET_PRODUCT=full_unagi TARGET_BUILD_VARIANT=eng TARGET_BUILD_TYPE=release TARGET_BUILD_APPS= TARGET_ARCH=arm TARGET_ARCH_VARIANT=armv7-a-neon HOST_ARCH=x86 HOST_OS=linux HOST_OS_EXTRA=Linux-3.5.0-22-generic-x86_64-with-Ubuntu-12.10-quantal HOST_BUILD_TYPE=release BUILD_ID=OPENMASTER OUT_DIR=out

================================

Blob setup script has changed, re-running Pulling files from device Found unknown firmware with build ID OPENMASTER Please download a compatible backup-unagi directory. Check the unagi intranet page for information on how to get one.

> Build failed! <

Build with |./build.sh -j1| for better messages If all else fails, use |rm -rf objdir-gecko| to clobber gecko and |rm -rf out| to clobber everything else.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Hi,

Did you do the last suggestions? The rm -rf steps to clobber?

Based on your error message I would do that and update your repo again with the latest and try the steps all over again--things are changing so much in the code all day every day some script just will be out of date or maybe the build was broken that day when you did the clone.

Let me know how it is going and thanks for this question! If you still need more help, I will find someone to post back here with additional suggestions for you.

-Michelle

Question owner

it is still the same error (i checked today) any updates? if you got an unagi phone and you didn't flash it before, if you wipe the phone by pressing the volume down button and powering up and wiping the data/factory and the cache you will get the same error

Modified by soroush731

Question owner

I finally get it fixed, it's because some drivers that are not available publicly