Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web sites requires MS IE 6.0 or greater and I use Firefox, what do I do?

  • No replies
  • 1 has this problem
  • 3 views
more options

I am job searching and this state web site will not let me apply saying I need Microsoft Internet Explorer 6.0 or greater browser and I am using Firefox. I need a job so what can I do? Thanks.

I am job searching and this state web site will not let me apply saying I need Microsoft Internet Explorer 6.0 or greater browser and I am using Firefox. I need a job so what can I do? Thanks.